Contribute
Register

Audio - HDMI Audio AppleHDA [Guide]

Status
Not open for further replies.
Joined
Jul 15, 2013
Messages
5
Mac
Classic Mac
Mobile Phone
I have a Gigabyte EP45-UD3P motherboard with an XFX HD5770 and a fresh install of Yosemite 10.10. My goal is to have HDMI audio working via the HDMI port on the 5770. I do not care about audio out on my motherboard. I had the HDMI audio out working on Mavericks, but I do not remember how I did it. I am new to hackintosh builds and have read through your guides and tried everything I can try on my own, but I cannot get HDMI audio out working on my HD5770. Can you please point me in the right direction?
 

toleda

Moderator
Joined
May 20, 2010
Messages
23,008
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
My goal is to have HDMI audio working via the HDMI port on the 5770.
No difference in dsdt edits for Mavericks and Yosemite.
Post #1, use 1. 5 series and 2. AMD guides. For help, see Problem Reporting.
 
Joined
Feb 3, 2014
Messages
81
Motherboard
Gigabyte GA-H87M-D3H
CPU
i5
Graphics
HD 4600
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. Android
Total misunderstanding.
What you did wrong: Clean compile 3 times
Correct method: Apply any patch one time only.

Start over with the native dsdt, apply each patch once. Reply with edited dsdt.

Hi Toleda,

I was able to do again. No errors in entire process. But no HDMI audio like i have before with Mavericks.

Regards,
LP
 

Attachments

  • DSDT.aml
    51.4 KB · Views: 91

toleda

Moderator
Joined
May 20, 2010
Messages
23,008
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
No errors in entire process.
Not correct, 2x Clean_Complie. The "native" dsdt already has Clean_ Compile
Start over.
Do not apply Clean Compile
1. Compile, if no errors proceed. If errors, attach dsdt
2. Patch/8series/AMI-add_dsdt/PCI0/P0P2/ (w/ssdt/PEGO)/Apply/Close/Compile
3. Patch/8series/AMI-HD4600-AMD-Nvidia-A1/Apply/Close/Compile
4. Save
Attach edited dsdt.
 
Joined
Apr 17, 2013
Messages
81
Motherboard
GA-Z170X-UD3
CPU
i5-6600K
Graphics
RX 580
Mobile Phone
  1. iOS
I'm on Yosemite 10.10 I did step by step but it's not boot.
laptop Acer E1-571G + intel4000HD + nvidia 710m Optimus
It's my chameleon boot file: ( I use Chimera 4.0.1 )

<dict>
<key>DropSSDT</key>
<string>Yes</string>
<key>EthernetBuiltIn</key>
<string>Yes</string>
<key>Kernel Flags</key>
<string>kext-dev-mode=1</string>
<key>Legacy Logo</key>
<string>Yes</string>
<key>Timeout</key>
<string>2</string>
</dict>



I could boot with backed up DSDT and IGPEnabler=Yes kernel argument.
my current progress: I have AppleIntelFramebufferCapri.kerxt patched + my old DSDT. with this config without IGPEnabler show me just 3MB for VGA and very slow + bad resolution . IGPEnabler fixed this issue but No HDMI audio. I still have HDMI but now audio.

I tried HDAEnabley module + HDEFLayouID 1 .. 3 but not works. No HDMI audio int audio output settings.

I attached IOReg and DSDT file.

 

Attachments

  • Vahid’s MacBook Pro.zip
    353.7 KB · Views: 75
  • DSDT.aml.zip
    21.6 KB · Views: 81

toleda

Moderator
Joined
May 20, 2010
Messages
23,008
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
I tried HDAEnabley module + HDEFLayouID 1 .. 3 but not works. No HDMI audio
The installed AppleHDA.kext does not support HDEFLayoutID=3, use 1.
[FONT=Verdana, Geneva, sans-serif]Two problems:[/FONT]

1. edit dsdt/HDEF/hda-gfx
before: onboard-2
after: onboard-1
2. edit Capri/03 00 66 01
find:
02 05 00 00 00 04 00 00 07 04 00 00
replace:
02 05 00 00 00 08 00 00 06 00 00 00
 
Joined
Mar 30, 2013
Messages
12
Motherboard
GA-Z77M-D3H
CPU
Core i5 3570K
Graphics
intel HD 4000
Mac
Classic Mac
Mobile Phone
  1. iOS
I'm following this method to enable HDMI audi in my yosemite.
my hack specifications is i5 3570k, GA-z77m-d3h.
after installing unibeast with free dsdt, my pc work with iCloud in system preferences, it can be log me in.
after following this method, and my HDMI audio work, my iCloud cannot get me to login also iTunes store account too, and error -50 appear every time I open iTunes.
please help me to fix this.
 
Joined
Jan 26, 2011
Messages
505
Motherboard
Gigabyte GA-Z68XP-UD3P
CPU
i7-2600K OC @ 4.2GHz
Graphics
RX580
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hey guys

I've recently reinstalled my main system from scratch with Yosemite, and have since lost HDMI audio.

I'm not running on a dual ssd raid0, so I started fresh.

View attachment R4 ioreg.zip

I've included my iorer and have to following configs

I have HDAEnabler.dylib in /Extra/modules

My current "testing" boot.plist is

Code:
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
    <key>EthernetBuiltIn</key>
    <string>Yes</string>
    <key>GenerateCStates</key>
    <string>Yes</string>
    <key>GeneratePStates</key>
    <string>Yes</string>
    <key>Graphics Mode</key>
    <string>1920x1200x32</string>
    <key>GraphicsEnabler</key>
    <string>Yes</string>
###
    <key>HDEFLayoutID</key>
    <string>79030000</string>
    <key>EnableHDMIAudio</key>
    <string>Yes</string>
    <key>Vendor10deDevice06dd</key>
    <key>DSDT</key>
    <string>/Extra/DSDT_2014.aml</string>
<key>HDAEnabler</key>
<string>Yes</string>
<key>HDEFLayoutID</key>
<string>01000000</string>
    <key>SMBIOS</key>
    <string>/Extra/smbios.plist</string>
#####
    <key>IGPEnabler</key>
    <string>No</string>
    <key>Kernel Flags</key>
    <string>kext-dev-mode=1 rd=uuid boot-uuid=CE6C7595-9829-4E05-B140-A1DF705EB5F9</string>
#    <key>Legacy Logo</key>
#    <string>Yes</string>
    <key>Timeout</key>
    <string>2</string>
    <key>UseKernelCache</key>
    <string>Yes</string>
    <key>Theme</key>
    <string>Default</string>

</dict>
</plist>

AppleHDA version.plist is

Code:
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
    <key>BuildVersion</key>
    <string>4</string>
    <key>CFBundleShortVersionString</key>
    <string>2.5.3</string>
    <key>CFBundleVersion</key>
    <string>2.5.3fc1</string>
    <key>ProjectName</key>
    <string>AppleHDA</string>
    <key>SourceVersion</key>
    <string>253004001000000</string>
</dict>
</plist>

In the past, Toleda helped me hex edit applehda to recognize the quadro 4000 device id in AppleHDA, but is this required now? Are there better simpler ways?

Any insight appreciated :)
 

Attachments

  • DSDT_2014.aml
    41.2 KB · Views: 95
  • SSDT.aml
    945 bytes · Views: 107
Last edited:
Joined
Jun 28, 2012
Messages
4
Motherboard
MSI Z77MA-G45 Custom Lanbox
CPU
Core i7 3770
Graphics
hd4000
Mac
Classic Mac
Mobile Phone
ALC892 HD4000 MSI Z77MA-G45

Almost there. I have HDMI audio but stereo comes out mono and DTS/Dolby Digital are coming out of wrong speakers. My Amp always says PCM.

I followed the guide in this thread. Attached are all my files. If you could point me in the right direction I would really appreciate it.
 

Attachments

  • DSDT.aml
    40.7 KB · Views: 85
  • bootplist.png
    bootplist.png
    63.6 KB · Views: 147
  • dpci.png
    dpci.png
    85.5 KB · Views: 133
  • myioreg.zip
    433.3 KB · Views: 69
  • AppleIntelFramebufferCapri.kext.zip
    267 KB · Views: 84
  • AppleHDA.kext.zip
    909.2 KB · Views: 69
Status
Not open for further replies.
Top