Contribute
Register

Audio-DSDT error HP Omen

Joined
Apr 25, 2019
Messages
21
Motherboard
HP 8259
CPU
i7-7700HQ
Graphics
HD 630 + GTX 1050
Mobile Phone
Android
I update Clover, with Clover Configurator and clover freezes when load mac, it freezes in +++++ line
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
12,889
Motherboard
Asus N752VX-Clover
CPU
i7-6700HQ / HM170
Graphics
HD530 + GTX 950m 1920 x 1080
Mac
iMac
Mobile Phone
iOS
I update Clover, with Clover Configurator and clover freezes when load mac, it freezes in +++++ line
i don't use that.

download from sourceforge either version and check the drivers64UEFI folder afterwards to make sure AptioMemoryFix is in there
 
Joined
Apr 25, 2019
Messages
21
Motherboard
HP 8259
CPU
i7-7700HQ
Graphics
HD 630 + GTX 1050
Mobile Phone
Android
i don't use that.

download from sourceforge either version and check the drivers64UEFI folder afterwards to make sure AptioMemoryFix is in there
I have AptioMemoryFix-64.efi.
I had reinstall CodecCommander.kext, AppleALC.kext and Lilu.kext, layout-id=28 and reboot, it worked, audio! but reboot again and didn't recognize nothing (AGAIN)

Edit: Updated to 4862 and nothing.
 
Last edited:
Joined
Jan 15, 2010
Messages
124
Motherboard
HP Omen 17-an011na
CPU
i7-7700HQ/HM175
Graphics
GTX 1050, HD 630
Mac
Mac Pro
Classic Mac
iMac, Power Mac
Mobile Phone
Android

Feartech

Moderator
Joined
Aug 3, 2013
Messages
12,889
Motherboard
Asus N752VX-Clover
CPU
i7-6700HQ / HM170
Graphics
HD530 + GTX 950m 1920 x 1080
Mac
iMac
Mobile Phone
iOS
I have AptioMemoryFix-64.efi.
I had reinstall CodecCommander.kext, AppleALC.kext and Lilu.kext, layout-id=28 and reboot, it worked, audio! but reboot again and didn't recognize nothing (AGAIN)

Edit: Updated to 4862 and nothing.
not sure without new problem reporting files
 
Joined
Apr 25, 2019
Messages
21
Motherboard
HP 8259
CPU
i7-7700HQ
Graphics
HD 630 + GTX 1050
Mobile Phone
Android

Attachments

Feartech

Moderator
Joined
Aug 3, 2013
Messages
12,889
Motherboard
Asus N752VX-Clover
CPU
i7-6700HQ / HM170
Graphics
HD530 + GTX 950m 1920 x 1080
Mac
iMac
Mobile Phone
iOS
Sure, here is it.
And a pic from the boot in verbose mode.
View attachment 402689
you may want to experiment without different layout id (currently 13):
Code:
<key>Properties</key>
        <dict>
            <key>PciRoot(0x0)/Pci(0x1f,0x3)</key>
            <dict>
                <key>#PinConfigurations</key>
                <data>
                </data>
                <key>hda-gfx</key>
                <string>onboard-1</string>
                <key>layout-id</key>
                <integer>13</integer>
                <key>no-controller-patch</key>
                <integer>1</integer>
            </dict>
from your config.plist

also check the wiki on what id's are supported on your device:
https://github.com/acidanthera/AppleALC/wiki/Supported-codecs
 
Joined
Apr 25, 2019
Messages
21
Motherboard
HP 8259
CPU
i7-7700HQ
Graphics
HD 630 + GTX 1050
Mobile Phone
Android
you may want to experiment without different layout id (currently 13):
Code:
<key>Properties</key>
        <dict>
            <key>PciRoot(0x0)/Pci(0x1f,0x3)</key>
            <dict>
                <key>#PinConfigurations</key>
                <data>
                </data>
                <key>hda-gfx</key>
                <string>onboard-1</string>
                <key>layout-id</key>
                <integer>13</integer>
                <key>no-controller-patch</key>
                <integer>1</integer>
            </dict>
from your config.plist

also check the wiki on what id's are supported on your device:
https://github.com/acidanthera/AppleALC/wiki/Supported-codecs
I tried all of them 1, 3, 13, 14, 15, 28

Btw I wanna know if AppleALC.kext must be installed in L/E/ and have a copy in kexts/other, because I tried having only in L/E/ but nothing, I tried to follow this guide: https://www.tonymacx86.com/threads/hp-omen-ax250mw.272602/#post-1928659
And I tried the audio section but without works.
I have in kexts/other folder: Lilu, RealtekRTL811, AppleALC, FakeSMC, CodecCommander, WhateverGreen and VoodooPS2Controller
 
Last edited:
Joined
Jan 15, 2010
Messages
124
Motherboard
HP Omen 17-an011na
CPU
i7-7700HQ/HM175
Graphics
GTX 1050, HD 630
Mac
Mac Pro
Classic Mac
iMac, Power Mac
Mobile Phone
Android
I tried all of them 1, 3, 13, 14, 15, 28

Btw I wanna know if AppleALC.kext must be installed in L/E/ and have a copy in kexts/other, because I tried having only in L/E/ but nothing, I tried to follow this guide: https://www.tonymacx86.com/threads/hp-omen-ax250mw.272602/#post-1928659
And I tried the audio section but without works.
I have in kexts/other folder: Lilu, RealtekRTL811, AppleALC, FakeSMC, CodecCommander, WhateverGreen and VoodooPS2Controller
Keep copies in L/E/ and extra for essential kexts (the ones you've listed). One tip try rebuilding kextcache after setting a new layout id and reboot twice, first boot doesn't always work.
 
Joined
Apr 25, 2019
Messages
21
Motherboard
HP 8259
CPU
i7-7700HQ
Graphics
HD 630 + GTX 1050
Mobile Phone
Android
Keep copies in L/E/ and extra for essential kexts (the ones you've listed). One tip try rebuilding kextcache after setting a new layout id and reboot twice, first boot doesn't always work.
Nothing, first I reinstalled the 3 kext AppleALC, CodecCommander and Lilu, first I tried to use it without CodecCommander, and audio is recognize but not sound so I'm in the same, then install CodecCommander, rebuild kextcache, reboot twice, nothing, then change layout-id, rebuild kextcache, reboot twice and nothing, change layout-id like 4 times, rebuild kextcache and reboot twice every time, and nothing. What can I do? This is impossible.
 
Top