Contribute
Register

Audio-DSDT error HP Omen

Joined
Apr 25, 2019
Messages
21
Motherboard
HP 8259
CPU
i7-7700HQ
Graphics
HD 630 + GTX 1050
Mobile Phone
Android
Hi, I installed Mac OS High Sierra yesterday, but, following tutorials in this forum (RehabMan's tutorials) literally all give me errors.
First of all, my laptop is a HP Omen 16GB ram, motherboard HP 8259, graphic Intel HD 630 + GTX 1050 (disabled with arg -disablegfxfirmware and -nv_disable=1) and CPU i7-7700HQ.
When install finished, I executed MultiBeast and install UEFI boot mode, Audio driver VoodooHDA Universal v2.9.0d10 (first reboot after multibeast audio works, then not, the audio works 3 of 10 times), fakeSMC, network Realtek RTL811 v2.2.2 (works perfect), boot loader clover uefi mode and system definitions like an iMac 14,2.

Following the laptop battery status guide and DSDT guide, when disassembly it, it gives me a bunch of errors, and I don't know how to fix it. I was going to install ACPIBatteryManager.kext but if DSDT gives me errors I prefer to wait until a solution, I attached 2 files, if need more files, tell me, thank you all
P.S I don't know a lot about hackintosh and this world.
 

Attachments

Feartech

Moderator
Joined
Aug 3, 2013
Messages
12,581
Motherboard
Asus N752VX-Clover
CPU
i7-6700HQ / HM170
Graphics
HD530 + GTX 950m 1920 x 1080
Mac
iMac
Mobile Phone
Android
Hi, I installed Mac OS High Sierra yesterday, but, following tutorials in this forum (RehabMan's tutorials) literally all give me errors.
First of all, my laptop is a HP Omen 16GB ram, motherboard HP 8259, graphic Intel HD 630 + GTX 1050 (disabled with arg -disablegfxfirmware and -nv_disable=1) and CPU i7-7700HQ.
When install finished, I executed MultiBeast and install UEFI boot mode, Audio driver VoodooHDA Universal v2.9.0d10 (first reboot after multibeast audio works, then not, the audio works 3 of 10 times), fakeSMC, network Realtek RTL811 v2.2.2 (works perfect), boot loader clover uefi mode and system definitions like an iMac 14,2.

Following the laptop battery status guide and DSDT guide, when disassembly it, it gives me a bunch of errors, and I don't know how to fix it. I was going to install ACPIBatteryManager.kext but if DSDT gives me errors I prefer to wait until a solution, I attached 2 files, if need more files, tell me, thank you all
P.S I don't know a lot about hackintosh and this world.
laptop guide doesn't use multibeast

why use a desktop smbios for a laptop?

Link to laptop guide:
 
Joined
Apr 25, 2019
Messages
21
Motherboard
HP 8259
CPU
i7-7700HQ
Graphics
HD 630 + GTX 1050
Mobile Phone
Android
laptop guide doesn't use multibeast

why use a desktop smbios for a laptop?

Link to laptop guide:
Thanks for reply so fast, first of all, I have changed the clover config.plist, I think that I have to uninstall all multibeast installed before, but how can I install all the drivers for audio, battery, ethernet, PS2 keyboard and trackpad, brightness, etc? Through DSDT-SSDT files?
Btw where can I find a good SMBios for my laptop or just a good one to laptops that works?
 
Last edited:

Feartech

Moderator
Joined
Aug 3, 2013
Messages
12,581
Motherboard
Asus N752VX-Clover
CPU
i7-6700HQ / HM170
Graphics
HD530 + GTX 950m 1920 x 1080
Mac
iMac
Mobile Phone
Android
Thanks for reply so fast, first of all, I have changed the clover config.plist, I think that I have to uninstall all multibeast installed before, but how can I install all the drivers for audio, battery, ethernet, PS2 keyboard and trackpad, brightness, etc? Through DSDT-SSDT files?
Btw where can I find a good SMBios for my laptop or just a good one to laptops that works?
post 2 of the guide explains how to install kexts

your other issues, read the pinned threads:
https://www.tonymacx86.com/forums/mojave-laptop-support.196/
 
Joined
Apr 25, 2019
Messages
21
Motherboard
HP 8259
CPU
i7-7700HQ
Graphics
HD 630 + GTX 1050
Mobile Phone
Android
use the intel630 config from there https://github.com/RehabMan/OS-X-Clover-Laptop-Config "config_HD615_620_630_640_650.plist" it has smbios that will be fine.

Also this guide may help https://www.tonymacx86.com/threads/hp-omen-ax250mw.272602/post-1928659
post 2 of the guide explains how to install kexts

your other issues, read the pinned threads:
https://www.tonymacx86.com/forums/mojave-laptop-support.196/
Thank you both, I have changed the config.plist and installed kexts for ethernet and audio (Universal > VoodooHDA v2.9.0d10 and Realtek for ethernet) only works the ethernet, voodooHDA like with multibeast, doesn't work.
Now I'm reading the post that posted GffMaC, I'll write later about what about, thank you a lot.
 

Attachments

Last edited:
Joined
Apr 25, 2019
Messages
21
Motherboard
HP 8259
CPU
i7-7700HQ
Graphics
HD 630 + GTX 1050
Mobile Phone
Android
Hi @GffMaC I choose to reinstall from zero again, because the kexts installed from multibeast, audio voodoo Universal and then AppleALC, whatever, reinstall. Now I have battery status ok, charging, discharging, brightness, but audio is not working, I don't know 100% where put layout-id if in #layout-id or in the value, so I tried both, when loading Mac in verbose mode, show me an error:
AppleALC: alc @ failed to obtain device info for analog controller (1).
Any help? only fail the audio.

P.S. Battery discharging so fast, I followed the guide that you send me up, but discharge fast, like 10% in 5 min or a little more.
 
Last edited:
Joined
Jan 15, 2010
Messages
124
Motherboard
HP Omen 17-an011na
CPU
i7-7700HQ/HM175
Graphics
GTX 1050, HD 630
Mac
Mac Pro
Classic Mac
iMac, Power Mac
Mobile Phone
Android
Thank you both, I have changed the config.plist and installed kexts for ethernet and audio (Universal > VoodooHDA v2.9.0d10 and Realtek for ethernet) only works the ethernet, voodooHDA like with multibeast, doesn't work.
Now I'm reading the post that posted GffMaC, I'll write later about what about, thank you a lot.
Show me your config.plist
 

Top