Contribute
Register

AUDIO DRIVERS FOR HIGH SIERRA

Status
Not open for further replies.
Joined
Dec 7, 2016
Messages
66
Motherboard
Asus Z170M-PLUS
CPU
Intel i5 6500
Graphics
HD530
Mac
  1. iMac
Mobile Phone
  1. iOS
HI, as you can see I own an Asus z170-plus and I've just installed high Sierra. Can you tell me witch are the right kexts I have to install? if there aren't kexts how can I do??
thanks
 
Joined
Jul 1, 2017
Messages
40
Motherboard
GA-Z270-Gaming K3
CPU
i7 7700
Graphics
HD 630
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
Please, move this post to Post Installation > Audio forum. This section is incorrect and you maybe won't get support.

Regards!
 
Last edited:
Joined
Jul 1, 2017
Messages
40
Motherboard
GA-Z270-Gaming K3
CPU
i7 7700
Graphics
HD 630
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
Actually the best way to get audio works is use AppleALC + Lilu kexts from vit9696.

According with your MOBO, you have Realtek ALC887. So, first, download the kexts:

https://github.com/vit9696/AppleALC/releases/download/1.2.0/1.2.0.RELEASE.zip
https://github.com/vit9696/Lilu/releases/download/1.2.0/1.2.0.RELEASE.zip

Put these .kext on /EFI/EFI/CLOVER/Kexts/Others (Use EFI Mounter to see EFI partition). Now open the file /EFI/EFI/CLOVER/config.plist with Clover Configurator and on the tab "Devices" write in Audio -> Inject the layout watching the supported list here. In your case, start trying layout 1. Save, reboot and test the audio.
 
Joined
Dec 7, 2016
Messages
66
Motherboard
Asus Z170M-PLUS
CPU
Intel i5 6500
Graphics
HD530
Mac
  1. iMac
Mobile Phone
  1. iOS
Actually the best way to get audio works is use AppleALC + Lilu kexts from vit9696.

According with your MOBO, you have Realtek ALC887. So, first, download the kexts:

https://github.com/vit9696/AppleALC/releases/download/1.2.0/1.2.0.RELEASE.zip
https://github.com/vit9696/Lilu/releases/download/1.2.0/1.2.0.RELEASE.zip

Put these .kext on /EFI/EFI/CLOVER/Kexts/Others (Use EFI Mounter to see EFI partition). Now open the file /EFI/EFI/CLOVER/config.plist with Clover Configurator and on the tab "Devices" write in Audio -> Inject the layout watching the supported list here. In your case, start trying layout 1. Save, reboot and test the audio.
Actually the best way to get audio works is use AppleALC + Lilu kexts from vit9696.

According with your MOBO, you have Realtek ALC887. So, first, download the kexts:

https://github.com/vit9696/AppleALC/releases/download/1.2.0/1.2.0.RELEASE.zip
https://github.com/vit9696/Lilu/releases/download/1.2.0/1.2.0.RELEASE.zip

Put these .kext on /EFI/EFI/CLOVER/Kexts/Others (Use EFI Mounter to see EFI partition). Now open the file /EFI/EFI/CLOVER/config.plist with Clover Configurator and on the tab "Devices" write in Audio -> Inject the layout watching the supported list here. In your case, start trying layout 1. Save, reboot and test the audio.
thank you very much
 
Joined
Dec 7, 2016
Messages
66
Motherboard
Asus Z170M-PLUS
CPU
Intel i5 6500
Graphics
HD530
Mac
  1. iMac
Mobile Phone
  1. iOS
Actually the best way to get audio works is use AppleALC + Lilu kexts from vit9696.

According with your MOBO, you have Realtek ALC887. So, first, download the kexts:

https://github.com/vit9696/AppleALC/releases/download/1.2.0/1.2.0.RELEASE.zip
https://github.com/vit9696/Lilu/releases/download/1.2.0/1.2.0.RELEASE.zip

Put these .kext on /EFI/EFI/CLOVER/Kexts/Others (Use EFI Mounter to see EFI partition). Now open the file /EFI/EFI/CLOVER/config.plist with Clover Configurator and on the tab "Devices" write in Audio -> Inject the layout watching the supported list here. In your case, start trying layout 1. Save, reboot and test the audio.
is it ok? it seems to me but audio is still not working
 

Attachments

  • Schermata 2017-11-07 alle 17.43.33.png
    Schermata 2017-11-07 alle 17.43.33.png
    2.8 MB · Views: 616
Joined
Jul 1, 2017
Messages
40
Motherboard
GA-Z270-Gaming K3
CPU
i7 7700
Graphics
HD 630
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
Check if Lilu and AppleALC kexts are loaded:
Code:
kextstat |grep "AppleALC"
Code:
kextstat |grep "Lilu"

If the result of these commands are empty, something are wrong.

Then, try all the supported layouts for you: 1, 2, 3, 5, 7, 11, 13, 17, 18, 33, 99
 
Status
Not open for further replies.
Top