Contribute
Register

ATI Sapphire HD6450 1GB DDR3 PCI-E

Joined
Feb 11, 2011
Messages
9
Motherboard
Gigabyte G41MT-D3V Rev 1.3
CPU
Q8200
Graphics
HD 6450
This is my preliminar installer for video card ATI Sapphire HD 6450 1GB DDR3 Driver for OSX 10.6.8.

Package contents:

Driver 10.6.8 Patched ATI6000Controller.kext (Patched Framebuffer: Bulrushes, Cattail, Duckweed, Elodea, Fanwort, Gibba, Hydrilla, Ipomoea, Lotus, Muskgrass and Phitecia)

Driver 10.6.8 Vanilla ATI6000Controller.kext

DSDT Auto-Patcher Tool with patchs to create PEGP device in PCI0 device of your DSDT and enable HDMI audio [grisno].

Status:

Acceleration: Full
Sleep: OK
AutoSleep: OK
WakeUp PWBR/USB: OK
PowerOn/Off: OK
Restart: OK
VGA: OK
DVI: OK
HDMI Video: OK
HDMI Audio: OK
Dual Monitor Clone: OK
Dual Monitor Exteneded: OK
EDID: OK

Note: Remove IRQ's of HDEF device to avoid problems with play videos (Audio Card ALC889 in motherboard Gigabyte GA-G41MT-D3V tested).
 

Attachments

Joined
May 28, 2012
Messages
28
Motherboard
El Capitan 10.11.6
CPU
Intel Pentium Dual Core E5700 3.00 Ghz - GA-G41MT-D3V F2
Graphics
AMD RADEON HD 6450 - 1 GB DDR3
Mobile Phone
Android
Hello , i am new to Mac and trying to enable hdmi audio out with no luck...
with graphics enabler=yes i get unsupported card but system boots...
everything else works except wake from sleep i think...
If i run your zip file it will work in 10.7.5 or it is only for 10.6.8 ?
Can you help?
Thanks in Advance...
 

Attachments

Joined
Feb 11, 2011
Messages
9
Motherboard
Gigabyte G41MT-D3V Rev 1.3
CPU
Q8200
Graphics
HD 6450
Hello

You have the same motherboard and graphics card than me. With this combination the Audio, HDMI-Audio and Sleep / Weak works perfectly in 10.6.x, 10.7.x and 10.8.x after modifying the DSDT (HPET, RTC, PCI0, SLEEP, REBOOT, ACPI, EHCI, UHCI, ETH0 , HDMI, HDEF, DTGP, LPC, PS2K, PS2M, PWRB, SMBUS, WAK, TIMR, IPIC, MATH), AppleHDA.kext and inject the graphics card (with ATI6000Controller.kext patched framebuffer or using GraphicsEnabler = yes)

It is very important that you disable the Intel integrated graphics or have problems with Sleep / Weak

Some bootloaders do not perform well injection of ATI HD6450 Shappire DDR3 PCI-E when using GraphicsEnabler = yes parameter.

Some of the possible errors that can happen when injecting with bootloader:

- Select an unsupported framebuffer (Ipomoea framebuffer works fine without patching the framebuffer. In this case the monitor is detected as if external)
- Configure port number incorrectly (for this card the value is three),
- Computer Hangs on startup (this happens with the latest versions of Chimera active when GraphicsEnabler = yes)
- Blank screen appears (this happens in Moutain Lion, you must patch the Framebuffer mandatory)
- No injection is performed properly because the bootloader does not support your card model (this happens in older versions of Chameleon)

In the sample screenshot, you can clearly see that the graphics card is not injected. You can confirm this if you check the kexts loaded, you will see that the ATI6000Controller.kext not loaded.

I created an installer for motherboard GA-G41MT-D3V that I have published in:

http://www.osx86.net/downloads.php?do=file&id=3326

This installer is used to install OSX 10.6.8 on motherboard GA-G41MT-D3V (includes some additional drivers). Many components of installer are perfectly valid to install over 10.7.x or 10.8.x (DSDT, FakeSMC, HWSensors, AppleHDA). I'm finishing the development of the installer for OSX 10.7.x (right now I have a lot of work and I can not devote much time)

I have not tried to install 10.6.8 ATI6000Controller.kext over 10.7.x. Make a backup and run the installer and tell me the result. I recommend you use the latest version of Chameleon bootloader (without adding any additional module) with GraphicsEnabler = yes, Framebuffer = Ipomoea and AtiPorts = 3

http://www.osx86.net/view/3414-chameleon-enoch_r2140_ [daily_updates]. html

Salutations
 
Joined
May 28, 2012
Messages
28
Motherboard
El Capitan 10.11.6
CPU
Intel Pentium Dual Core E5700 3.00 Ghz - GA-G41MT-D3V F2
Graphics
AMD RADEON HD 6450 - 1 GB DDR3
Mobile Phone
Android
Hello..thank you for the quick reply...
As i said i'm new to Mac and i dont understand
some things you wrote above...but i 'll try to figure then out and i will
try the instaler you have made and i 'll let you know how it goes...
I only use the mac system for a few days and trying to figure how it works...
Anyway ...i have to update my chameleon bootloader (i dont know how , maybe with the chameleon wizard) and
i dont understand this (Framebuffer = Ipomoea and AtiPorts = 3) where to put this value?
Thanks in advance...
The second link doesnt show anything...
 
Joined
Feb 11, 2011
Messages
9
Motherboard
Gigabyte G41MT-D3V Rev 1.3
CPU
Q8200
Graphics
HD 6450
If this is your first time using OSX on a hackintosh, I recommend you start with osx 10.6.8 and use my installer that is perfect for your hardware configuration (which is almost identical to mine and it works stably). This test will help you learn and evaluate osx without advanced knowledge.

I think it's easier to do that than to have to read tutorials. What do you think?
 
Joined
May 28, 2012
Messages
28
Motherboard
El Capitan 10.11.6
CPU
Intel Pentium Dual Core E5700 3.00 Ghz - GA-G41MT-D3V F2
Graphics
AMD RADEON HD 6450 - 1 GB DDR3
Mobile Phone
Android
It is my first Hackintosh and first time using Mac system...i thing i will mess around a little while with 10.7.5 edition
and then i will try your installer (great job you 've done)
If i manage to fix something i let you know..
Thanks again for your time...
Ohh i forgot to tell you ...a few days ago i run the "Sapphire Radeon HD 6450 1GB DDR3.mpkg" zip file
which you include in your first post and i had no sound and graphic mode (i had a resolution only for my screen but not the right one) and no tv shows up...
then i run combo update again and all normal...
If i run your dstd installer should i check something for the Ati card ?
 

Attachments

Joined
May 28, 2012
Messages
28
Motherboard
El Capitan 10.11.6
CPU
Intel Pentium Dual Core E5700 3.00 Ghz - GA-G41MT-D3V F2
Graphics
AMD RADEON HD 6450 - 1 GB DDR3
Mobile Phone
Android
Hello again...i will try to run Snow Leopard with your Installer, will you help?
steps
1: Install snow leopard (h) and check what in customize?
2:if everything goes right and boot install combo update 10.6.8 and check customize what?
3:dont reboot and install your package as it is?
reboot
tell me the steps if you want... to try it...if you find the time of course...
atach a photo with customization ....if you have one
ok thanks in advance and hope you help.....
 
Top