Contribute
Register

ATI Radeon HD 6870 - White screen with a mouse pointer

Joined
Jan 7, 2011
Messages
88
Motherboard
Gigabyte Z370 AORUS Gaming 7
CPU
Intel Core i7-8700K
Graphics
Intel UHD 630
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Hello folks,

I bought OS X ML 10.8 from app store and downloaded it. I ran UniBeast 1.5 to set up my thumb drive. It only took 10-15 minutes to complete. Yes, I am using new 8 GB USB 3.0 Patriot XT supersonic thumb drive.

I restarted system and tried boot it. I always ended up white screen with a mouse pointer through many different boot settings. I learned a few users have same problems due to ATI 6870 graphics card. One of users removed a 6870 and it went through.

With Lion 10.7.x, I have same problems with video stream. It always freeze after just started.

Does anyone have any solution with ATI Radeon 6870 graphics card? My system configs are:

ASUS Maximus IV Extreme
i7-2600K processor
8 GB memory modules
MSI R6870 Hawk

Thanks!
 
Joined
Jul 6, 2011
Messages
120
Motherboard
Slimbook Pro2
CPU
i5-8250U
Graphics
UHD 620, 3200x1800
Mobile Phone
  1. Android
Use the CPU's Onboard graphics for the installation, then switch back to the graphics card after you're done. 68xx graphics cards work fine in ML itself, but the installer doesn't seem to like them!

Hello folks,

I bought OS X ML 10.8 from app store and downloaded it. I ran UniBeast 1.5 to set up my thumb drive. It only took 10-15 minutes to complete. Yes, I am using new 8 GB USB 3.0 Patriot XT supersonic thumb drive.

I restarted system and tried boot it. I always ended up white screen with a mouse pointer through many different boot settings. I learned a few users have same problems due to ATI 6870 graphics card. One of users removed a 6870 and it went through.

With Lion 10.7.x, I have same problems with video stream. It always freeze after just started.

Does anyone have any solution with ATI Radeon 6870 graphics card? My system configs are:

ASUS Maximus IV Extreme
i7-2600K processor
8 GB memory modules
MSI R6870 Hawk

Thanks!
 
Joined
Jan 7, 2011
Messages
88
Motherboard
Gigabyte Z370 AORUS Gaming 7
CPU
Intel Core i7-8700K
Graphics
Intel UHD 630
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Ok, I got it but my motherboard uses P67 chipset that does not support onboard graphics. It still requires graphics card plugged in. Only solution is replacing it with a new P77 motherboard. Or get different graphics card.

Which graphics card do installer supports?

Thanks.
 
Joined
Dec 5, 2012
Messages
30
Motherboard
ASUS P8Z77-M Pro
CPU
i5-3570K
Graphics
HD 6870
The final solution!

In 10.8.2 everything works perfectly, except installation. If you have integrated GPU, then use it while you install the ML. In bios, just set IGPU to primary and set memory to 64MB (don't forget to plug your monitor to the right dock).

Now you can install OSX smoothly. Do those steps you should do to make your Mt. Lion ready.

After you've done everything (at least the second normal boot of your system), go to BIOS and set your GPU to auto again.

If you haven't done it before, add GraphicsEnabler=Yes flag to your boot file. Now you should see your Graphics correctly in system profiler. It should use Duckweed by itself! No need to pciroot or any other graphic patch in boot file!

If you don't have integrated GPU, try maybe use a working ati6000.kext from someones system. Maybe it helps.
 
Top