Contribute
Register

ATI Radeon HD 4850 on Sierra

Status
Not open for further replies.
Joined
Feb 25, 2011
Messages
2
Mac
Classic Mac
Mobile Phone
Hi,
I have successfully installed Sierra with everything working (including graphics) on legacy bootloader (old GA-P55A- MB).
I also have a Radeon HD4850 with 512 MB mem.
It is detected, but it is detected with 7MB only, and the graphics performance is very bad and laggy.
This is the description from the about this mac -> Overview: "Graphics ATI Radeon HD 4850 Series 7 MB".

I am upgrading from OSX ML. There i used $$$$.kext and it worked perfectly.
(attached are images from sierra and ML).

Any ideas on how to fix this issue?
Thanks!.

My HW:
MB: GA-P55A-UD3 (F11)
CPU: Inter i7 870
RAM: 8 GB.
Graphics: ATI Radeon HD 4850 with 512 MB.
Sierra.png ML.png
 
Joined
Dec 25, 2013
Messages
1
Motherboard
P7H55M-SI
CPU
intel core i7
Graphics
ATI HD4800
Mac
Classic Mac
Mobile Phone
Spoofing the device ID to HD 4870 (-> 0x94401002) should do the trick. Details are in the Radeon Compatibility thread (HD 4xxx generation is missing, but the general procedure still applies).
Spoofing the ID didn't do the work :(
I got the device ID (radeon 4850, 0x94421002) and added it to the AMD4800Controller.kext, didn't have to change the ATIRadeonX2000.kext cause it already included the ID... But after restarting, sierra recognises the card but still 5mb... Any other ideas?
 

Attachments

  • Screen Shot 2017-05-21 at 00.04.43.png
    Screen Shot 2017-05-21 at 00.04.43.png
    317.7 KB · Views: 1,454
Last edited:
Status
Not open for further replies.
Top