Contribute
Register

ATI 5770 and Apple 27"

Status
Not open for further replies.
Joined
Feb 2, 2011
Messages
277
Motherboard
Asus x79 sabertooth
CPU
Core i7 4930K *
Graphics
Nvidia Geforce GTX 770
Mac
  1. MacBook Pro
  2. Mac Pro
Classic Mac
Mobile Phone
  1. iOS
mjgunn said:
Magestrate, from what I'm reading it looks like its only the 5xxx cards with the problems, 6870s are working ok. Is DVD Player working for you in 10.6.8 with the new drivers or does it crash?
its funny you ask about the dvd player i have a bd rom that used to unmount every now and again but now its been a week or so after the update it works...
 
Joined
Jan 24, 2011
Messages
96
Mac
Classic Mac
Mobile Phone
So the actual DVD player app opens and works ok?
 
Joined
Feb 2, 2011
Messages
277
Motherboard
Asus x79 sabertooth
CPU
Core i7 4930K *
Graphics
Nvidia Geforce GTX 770
Mac
  1. MacBook Pro
  2. Mac Pro
Classic Mac
Mobile Phone
  1. iOS
hey did you check to see if you have your dvd player installed on the grey sata ports on your mother board maybe thats why you might be having a problem no grey ports os x doesn't support them.
 
Joined
Jan 16, 2011
Messages
532
Motherboard
Asus ROG MAXIMUS X HERO
CPU
i7-9700K
Graphics
RX 580
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
mjgunn said:
Well that's some disturbing news. I assume you tried the different framebuffers to see if one of them would enable the displayport?
In the meanwhile I tried a different approach:
Replaced the 10.6.8 ATI kext files in S/L/E with those of 10.6.7 via KextBeast.
Also deleted one additional kext from 10.6.8 which is not within 10.6.7 (namely ATI6000controller.kext) and run MultiBeast system utilities.
Now the DP works again, also multi monitoring.
Strange though the DP monitor stays black after boot and has to be cycled off/on to power the display.
 
Joined
Apr 5, 2010
Messages
10
Motherboard
Lion 10.7.5
CPU
intel i5-750
Graphics
hd6870
Mac
Classic Mac
Mobile Phone
I sold my XFX 5770 and bought the Sapphire 6870 my problem miraculously solved. Everything works wonderfully :headbang:
 
Joined
Jun 26, 2011
Messages
15
Mac
Classic Mac
Mobile Phone
Sometimes I just like asking up front. I have been reading about 12 pages of this thread. Someone mentioned the XFX Radeon HD 6870 (HD-687A-ZDFC) was having issues not sleeping. Was that ever fixed? Does anyone have sleep with that card?
 
Joined
May 15, 2011
Messages
10
Mac
Classic Mac
Mobile Phone
just got my 27 inches of beauty. Is there any progress with the XFX single Slot 5770 + Cinema Display Combo on Lion? I don't mind using older kexts... or anything.

Just got this 5770 a couple of weeks ago because I was sure it would work - now it seems like everyone is jumping board for the 6870. :(
 
Joined
Jan 25, 2011
Messages
727
Motherboard
GA-X58A-UD3R
CPU
X5650
Graphics
R9 290
Mac
  1. MacBook
Mobile Phone
  1. Android
  2. iOS
macspear said:
just got my 27 inches of beauty. Is there any progress with the XFX single Slot 5770 + Cinema Display Combo on Lion? I don't mind using older kexts... or anything.

Just got this 5770 a couple of weeks ago because I was sure it would work - now it seems like everyone is jumping board for the 6870. :(

I've attempted two things that have failed:

1) Vanilla 10.7 install. Installation works, and I can boot with a DVI monitor... but not mDP to my 27 ACD.

2) Replace ATI5000Controller w/ a custom version and add framebuffer to boot.plist. Hangs at apple boot screen. No KP visible, but just sits there. I am forced to power-button turn off my machine... and strangely this ends up preventing BIOS from posting. So I have to turn PSU off, on, and then select the last known good state from a BIOS menu option at next boot to select my 10.6.7 primary drive to get back into my system.

The next step is to try what I've been doing for 10.6.8... which is use the 10.6.7 kexts in S/L/E. Of course, this is less than ideal. But I still hope it works.

R
 
Status
Not open for further replies.
Top