Contribute
Register

ATI 5770 and Apple 27"

Status
Not open for further replies.
Joined
Jun 29, 2011
Messages
1
Mac
Classic Mac
Mobile Phone
Yo,

There is mixed feedback going around regarding 27" ACD and PC compatibility. Some can get it to work and some cannot. I seem to have found myself somewhere in the middle...awesome.

Basically I purchased the AMD Radeon HD 6800 series video card which obviously has a Display port. I then also purchased the adapter cable http://estore.circuitassembly.com/p...Female-to-Displayport-Male-Adapter-Cable.html

Screen works fine, perfect colour, resolution and all that. Only problem being is that occasionally, during certain tasks, the video driver wiggs-out. By wigg-out I mean the screen freezes temporarily, then flashes a colour (pink, green, white....whatever), and then either goes back to normal, with an error message saying that my "AMD display driver has stopped responding and has recovered", or the computer freezes entirely and I need to reboot. Sometimes I have even been lucky enough to be graced with the dreaded blue screen.

Generally the tasks which lead to driver wigg-outs include maximising videos/games to fullscreen, scrolling up/down on some web pages, using windows aero theme, and also the windows 7 sticky notes sometimes screw it up.

What do you think???

Im pretty confident that Im fighting a losing battle, but if anyone has any ideas before I trade this bad boy it would be much appreciated.

NB- I update my video driver regularly in hope that the problem will eventually disappear.


Windows 7 (64 bit)
AMD RADEON HD 6800 series
 

eelhead

Super Moderator
Joined
Mar 1, 2011
Messages
3,117
Motherboard
GA-Z170X-Designare
CPU
i5 7600k
Graphics
GTX 1070
Mac
  1. iMac
  2. MacBook Pro
Classic Mac
  1. iMac
  2. Power Mac
Mobile Phone
  1. iOS
I have no issues with my 6870 and ACD.
You might also want to check out the cable and see if there has been any issues with it anywhere. I know some cables are finicky. Just a thought.
 
Joined
Jan 25, 2011
Messages
728
Motherboard
GA-X58A-UD3R
CPU
X5650
Graphics
R9 290
Mac
  1. MacBook
Mobile Phone
  1. Android
  2. iOS
My 5770 works a charm in Win7 64-bit, driving the ACD 27 from the mini Display Port on the card (single slot).

It even plays crysis at full resolution (Ok, but it DOES occasionally overheat/soft crash in crysis, not losing any data, but temporarily sending me to the crysis menu... but crysis is known for its bugs).

If anything, I've had more problems with 10.6.8... had to use the 10.6.7 kexts to get the screen to do anything other than show black (even tried the plug/unplug and the sleep/wake tricks).
 
Joined
Jan 16, 2011
Messages
532
Motherboard
Asus ROG MAXIMUS X HERO
CPU
i7-9700K
Graphics
RX 580
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
mjgunn said:
Anyone here running 10.6.8 and having a problem with their ACD? A little worried after seeing this guys post saying that some of his cards won't work with his ACD in 10.6.8 and Lion which were running it fine previously.

http://www.insanelymac.com/forum/index. ... pic=258514

Not an ACD, but with similar specs on a Dell U2711.
With my HD5770 SilentCell working full res in 10.6.7 via DVI, DP (2560x1440) and HDMI (1080p), also multi monitoring (except HDMI which is mirrored).

10.6.8 however only allows use via DVI (2560x1440).
Same as described: After Apple boot screen monitor blacks out.

10.6.8 uses newer ATI kexts (1.6.36) whereas 10.6.7 had 1.6.32.
I did not try to rollback yet as I´m normally only on one monitor.
Also an option to try could be MB version 3.7.2 which had the ATI 1.6.34 kexts.

And of course the SilentCell is not reference design, but that was not causing problems up to now, worked oob.
 
Joined
Jan 24, 2011
Messages
96
Mac
Classic Mac
Mobile Phone
Well that's some disturbing news. I assume you tried the different framebuffers to see if one of them would enable the displayport?
 
Joined
Jan 16, 2011
Messages
532
Motherboard
Asus ROG MAXIMUS X HERO
CPU
i7-9700K
Graphics
RX 580
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
mjgunn said:
Well that's some disturbing news. I assume you tried the different framebuffers to see if one of them would enable the displayport?

Actually no.
Just bought the Dell yesterday and had no pressure to use framebuffers before on my 24"ACDs.
And as lion is approaching I guess I´ll rather wait what´s coming up with it... ;)
 
Joined
Feb 3, 2011
Messages
277
Motherboard
Asus x79 sabertooth
CPU
Core i7 4930K *
Graphics
Nvidia Geforce GTX 770
Mac
  1. MacBook Pro
  2. Mac Pro
Classic Mac
Mobile Phone
  1. iOS
mjgunn said:
Anyone here running 10.6.8 and having a problem with their ACD? A little worried after seeing this guys post saying that some of his cards won't work with his ACD in 10.6.8 and Lion which were running it fine previously.

http://www.insanelymac.com/forum/index. ... pic=258514
nope i installed 10.6.8 and everything working minty fresh!! :D
Screen shot 2011-07-02 at 9.44.01 AM.png
Screen shot 2011-07-02 at 9.44.27 AM.png
 

Attachments

  • Screen shot 2011-07-02 at 9.44.01 AM.png
    Screen shot 2011-07-02 at 9.44.01 AM.png
    33.8 KB · Views: 100
  • Screen shot 2011-07-02 at 9.44.27 AM.png
    Screen shot 2011-07-02 at 9.44.27 AM.png
    40.7 KB · Views: 113
Joined
Jan 24, 2011
Messages
96
Mac
Classic Mac
Mobile Phone
Magestrate, from what I'm reading it looks like its only the 5xxx cards with the problems, 6870s are working ok. Is DVD Player working for you in 10.6.8 with the new drivers or does it crash?
 
Status
Not open for further replies.
Top