Contribute
Register

Atheros Bluetooth: IOath3kfrmwr.kext: Not Working (AR3011)

Joined
Jan 13, 2017
Messages
282
Motherboard
Gigabyte Designare Z390
CPU
i9 9900K
Graphics
RX580
Mac
  1. iMac
  2. Mac Pro
Classic Mac
  1. Apple
Mobile Phone
  1. iOS
it's in S/L/E.

now I remove it from /s/l/e and here is output

kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext USBInjectAll.kext

kext-dev-mode allowing invalid signature -67013 0xFFFFFFFFFFFEFA3B for kext AppleMobileDevice.kext

kext-dev-mode allowing invalid signature -67013 0xFFFFFFFFFFFEFA3B for kext IOHDAFamily.kext

kext-dev-mode allowing invalid signature -67030 0xFFFFFFFFFFFEFA2A for kext AppleHDAHardwareConfigDriver.kext

kext-dev-mode allowing invalid signature -67013 0xFFFFFFFFFFFEFA3B for kext AppleHDAController.kext

kext-dev-mode allowing invalid signature -67061 0xFFFFFFFFFFFEFA0B for kext AppleHDA.kext

AppleDataSetManagement.kext - dependency for com.apple.iokit.IOAHCIBlockStorage lacks valid OSBundleCompatibleVersion.

AppleDataSetManagement.kext is missing dependencies (including anyway; dependencies may be available from elsewhere)

AppleDataSetManagement.kext - dependency for com.apple.iokit.IOAHCIBlockStorage lacks valid OSBundleCompatibleVersion.


but again no bluetooth device if I unplug / plug wireless card bluetooth coming. But there is no possible to make connection with any device and if I restart laptop again no device.
 
Last edited:

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,093
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
it's in S/L/E.

OK, I see it now in your kextcache output.

Your ioreg shows bluetooth working.
What is the issue?

Please describe the problem clearly.
 
Joined
Jan 13, 2017
Messages
282
Motherboard
Gigabyte Designare Z390
CPU
i9 9900K
Graphics
RX580
Mac
  1. iMac
  2. Mac Pro
Classic Mac
  1. Apple
Mobile Phone
  1. iOS
I attach ioreg wen bluetooth are available and work.
here is right now without IOath3kfrmwr.kext and no bluetooth device
and 2 ioreg + kext - no device
 

Attachments

  • ChainBook’s iMac-NO.ioreg
    3 MB · Views: 107
  • ChainBook’s iMac+kext-nodevice.ioreg
    2.9 MB · Views: 82
Last edited:

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,093
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I attach ioreg wen bluetooth are available and work.
here is right now without IOath3kfrmwr.kext and no bluetooth device
and 2 ioreg + kext - no device

The ioreg shows no bluetooth on the USB bus.
Under what conditions does this happen?
 
Joined
Jan 13, 2017
Messages
282
Motherboard
Gigabyte Designare Z390
CPU
i9 9900K
Graphics
RX580
Mac
  1. iMac
  2. Mac Pro
Classic Mac
  1. Apple
Mobile Phone
  1. iOS
so wen I power ON laptop there is no bluetooth device, I just unplug and plugin wireless card ( wen laptop is ON ) and bluetooth is coming, but this destroy wireless connection and I restart laptop after that sierra running normal with WiFI+BT ON.. IF I put laptop should down I should do the same operation, but If I make only restart is no problem.
and this I can not fix.. I should remove / plugin wireless card every time wen start laptop...
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,093
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
so wen I power ON laptop there is no bluetooth device, I just unplug and plugin wireless card ( wen laptop is ON ) and bluetooth is coming, but this destroy wireless connection and I restart laptop after that sierra running normal with WiFI+BT ON.. IF I put laptop should down I should do the same operation, but If I make only restart is no problem.
and this I can not fix.. I should remove / plugin wireless card every time wen start laptop...

It is a likely problem with your USB setup.
Read here:
https://www.tonymacx86.com/threads/guide-10-11-usb-changes-and-solutions.173616/
 
Joined
Mar 20, 2020
Messages
10
Motherboard
ASUSTeK N56VB
CPU
i7-3630QM
Graphics
HD4000
Hello @RehabMan
Screen Shot 2020-09-27 at 23.59.44.png

I attached all necessary logs. EFI, DarwinDumper и IORegistryExplorer
I tried to install your latest version from here RehabMan-Atheros-2015-0624.zip
Thank you for your help!!
 

Attachments

  • MacBook Pro.ioreg.zip
    4.6 MB · Views: 30
  • DarwinDumper_3.1.1_2020.09.28_00.04.30_MacBookPro9,2_AMI_X64_5122_(master,_commit_f4e10b1a2)_C...zip
    8.4 MB · Views: 21
  • CLOVER.zip
    12.1 MB · Views: 33
Top