Contribute
Register

Solved > Atheros AR5B195 problems

Joined
May 29, 2019
Messages
5
Motherboard
MSI
CPU
Intel
Graphics
Nvidia
I have searched and searched for days and tried every kext and method I can find to get this card working in 10.13.6. I have even attempted to patch the DSDT but I can never get the window to change to apply in the MACiASL program. Literally have 10-12 hours on the machine trying to get this one thing working. The laptop is a Thinkpad X220 which seems to have a lot of support. I just can't figure out what I am doing wrong. It started out not showing in wifi at all to showing up with no hardware. Eventually I can got to a point where it would search for a network but never find one to connect. It is now back to saying "WiFI No hardware installed" Can someone be kind enough to help me out on this or point me in the right direction? Thank you.
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
11,239
Motherboard
Asus N752VX-Clover
CPU
i7-6700HQ / HM170
Graphics
HD530 + GTX 950m 1920 x 1080
Mac
iMac
Mobile Phone
Android
I have searched and searched for days and tried every kext and method I can find to get this card working in 10.13.6. I have even attempted to patch the DSDT but I can never get the window to change to apply in the MACiASL program. Literally have 10-12 hours on the machine trying to get this one thing working. The laptop is a Thinkpad X220 which seems to have a lot of support. I just can't figure out what I am doing wrong. It started out not showing in wifi at all to showing up with no hardware. Eventually I can got to a point where it would search for a network but never find one to connect. It is now back to saying "WiFI No hardware installed" Can someone be kind enough to help me out on this or point me in the right direction? Thank you.
the faq:

has details on how to setup wifi
 
Joined
May 29, 2019
Messages
5
Motherboard
MSI
CPU
Intel
Graphics
Nvidia
the faq:

has details on how to setup wifi
Thank you for the information. This is first place I started but unfortunately I haven't been able to resolve the problem from the information available there. As stated before, I have tried many kexts and attempted to try a DSDT patch but I have been unable to complete the DSDT patch because I can not apply the changes using MACiASL. I'm confident that I am doing something wrong or missing something somewhere but I am unable to determine on my own what the problem is. If there are any files I can post that would help, please let me know I will provide them. Thanks again.
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
11,239
Motherboard
Asus N752VX-Clover
CPU
i7-6700HQ / HM170
Graphics
HD530 + GTX 950m 1920 x 1080
Mac
iMac
Mobile Phone
Android
Thank you for the information. This is first place I started but unfortunately I haven't been able to resolve the problem from the information available there. As stated before, I have tried many kexts and attempted to try a DSDT patch but I have been unable to complete the DSDT patch because I can not apply the changes using MACiASL. I'm confident that I am doing something wrong or missing something somewhere but I am unable to determine on my own what the problem is. If there are any files I can post that would help, please let me know I will provide them. Thanks again.
i have no experience with that hardware but i could take a look to see if i can see something obvious though

please read the faq for proper hardware profile setup:

and then:
Use this tool and upload your problem reporting files:
 
Joined
May 29, 2019
Messages
5
Motherboard
MSI
CPU
Intel
Graphics
Nvidia
Use this tool and upload your problem reporting files:
I have tried to use the script and it is failing at the point of Fetching the EFI mount script. The only way I can connect to the internet is through the WAN port since I am trying to get WiFi working. It passes the first connectivity test but fails at the point stated. "Using custom test URL github.com Unable to connect to the Internet. Aborted." Safari and other internet programs are connecting fine. Any ideas?
 
Joined
May 29, 2019
Messages
5
Motherboard
MSI
CPU
Intel
Graphics
Nvidia
Resolved the problem today. First, I did a reinstall of High Sierra (neither of the other fixes helped until I did this) Second, taped pin 20 on the card. Third, installed the toledaARPT.kext. Sound was also not working so I installed the VoodoHDA.kext. Wifi and sound both working good now.
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
11,239
Motherboard
Asus N752VX-Clover
CPU
i7-6700HQ / HM170
Graphics
HD530 + GTX 950m 1920 x 1080
Mac
iMac
Mobile Phone
Android
Resolved the problem today. First, I did a reinstall of High Sierra (neither of the other fixes helped until I did this) Second, taped pin 20 on the card. Third, installed the toledaARPT.kext. Sound was also not working so I installed the VoodoHDA.kext. Wifi and sound both working good now.
well done!

although lilu and AppleALC may be a better choice for audio
 
Joined
May 29, 2019
Messages
5
Motherboard
MSI
CPU
Intel
Graphics
Nvidia
well done!

although lilu and AppleALC may be a better choice for audio
To be honest, I stuck with the first thing that worked for audio but I will keep your suggestion in mind. Can I ask the reason as to why you think lilu and AppleALC would be a better choice?
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
11,239
Motherboard
Asus N752VX-Clover
CPU
i7-6700HQ / HM170
Graphics
HD530 + GTX 950m 1920 x 1080
Mac
iMac
Mobile Phone
Android
To be honest, I stuck with the first thing that worked for audio but I will keep your suggestion in mind. Can I ask the reason as to why you think lilu and AppleALC would be a better choice?
bit more native, maybe trial and error and see how you get on
 
Top