Contribute
Register

ASUS ZenBook 14 UX431FAC - Nice Hackintosh

Joined
Oct 24, 2019
Messages
103
Motherboard
Asus ProArt Z490 Creator
CPU
i5-10600K
Graphics
RX 5700
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS

This laptop is quite hackintosheable. I purchased it without an OS, and it's pretty affordable. A great MBP alternative!

Specs:
  • Intel Core i5 10210U (HD630) - Comet Lake
  • 8 GB LPDDR3
  • Intel (Optane?) 512 GB SSD NVMe
  • 14" FHD
  • Ports: HDMI 1.4b, USB-C, USB 3, USB 2, SD, jack.
  • Backlight keyboard
  • Intel WiFi AX200 9462 2nd
What works: I think it's quicker to say what doesn't and what's untested. Yes WiFi works thanks to the itlwm project.

Partial work: Microphone AND speakers won't work at the same time. Speakers will work on layout 66 but microphone on layout 21. Maybe we need to union those layouts, it would work.

Untested/Unsure: SD (maybe won't work as usual), USB-C (at least it gives power).


Battery issue:

I tried my best to make a DSDT patch, a SSDT patch, etc... no luck so far. But now I know something:


Seriously, I got not only BAT0 but BAT1 and BAT2.

In fact, I tried to fuse them in a BATC following VirtualSMC's instructions (Docs) for dual battery. Still have problems.

And I get this on startup:

2020-08-05 08:13:02.909437+0200 localhost kernel[0]: (Lilu) SMCBatteryManager bmgr: @ failed to find batteries or adapters!
2020-08-05 08:13:02.909446+0200 localhost kernel[0]: (Lilu) SMCBatteryManager smcbus: @ BatteryManager probe failure

It's pretty obvious the main problem is that the battery is not detected.

Any clue on this?


SOLVED.
In fact, the problem was either 16-bit values and ADP1 that needed to be replaced in a SSDT because of _STA. I'M CRYING.
FINALLY! IT'S THE BEST HACKINTOSH EVER.

Here's a Gist with my patch :)
---

Reuploading EFI soon.
looks good
 
Joined
Dec 20, 2020
Messages
4
Motherboard
AsusTek
CPU
Intel Core i5
Graphics
Intel UHD Graphics 620
Mac
  1. MacBook Air
Classic Mac
  1. Portable
Mobile Phone
  1. Android
Ouch, sorry to hear that :(

BTW I uploaded the EFI/OC in my GitHub.
Your work is awesome !!!!!!!!!

All the devices and kests works on my Hackintosh
Thank you.

I Susamax, I have the same Laptop UX431FA ZENBOOK Asus with the same config.

But with your latest EFI i can Boot on Opencore With Mac OS.
But i can't boot On Windows why?
 
Joined
Jul 30, 2020
Messages
19
Motherboard
ASUS UX431FA
CPU
i5 10210U
Graphics
Intel UHD Graphics 630 (Mobile)
Mac
  1. iMac
Mobile Phone
  1. Android
  2. iOS
I edited first post. Also, this build has reached some stability and almost everything work. I use it as my main operating system.

Your work is awesome !!!!!!!!!

All the devices and kests works on my Hackintosh
Thank you.

I Susamax, I have the same Laptop UX431FA ZENBOOK Asus with the same config.

But with your latest EFI i can Boot on Opencore With Mac OS.
But i can't boot On Windows why?
I use ESC to enter another OS like Fedora. On OpenCore I can only select macOS.

My advice is to use rEFInd to have a multi boot selector.

I'm glad this work helps more people :)
 
Last edited:
Joined
Dec 20, 2020
Messages
4
Motherboard
AsusTek
CPU
Intel Core i5
Graphics
Intel UHD Graphics 620
Mac
  1. MacBook Air
Classic Mac
  1. Portable
Mobile Phone
  1. Android
I edited first post. Also, this build has reached some stability and almost everything work. I use it as my main operating system.


I use ESC to enter another OS like Fedora. On OpenCore I can only select macOS.

My advice is to use rEFInd to have a multi boot selector.

I'm glad this work helps more people :)
okay thank you for your response.
I have a question what's your bios settings for the install mac os.
Because i can boot in the setup mac os for the installation but after the the installation i can't boot in the mac os system.
 
Joined
Jul 30, 2020
Messages
19
Motherboard
ASUS UX431FA
CPU
i5 10210U
Graphics
Intel UHD Graphics 630 (Mobile)
Mac
  1. iMac
Mobile Phone
  1. Android
  2. iOS
okay thank you for your response.
I have a question what's your bios settings for the install mac os.
Because i can boot in the setup mac os for the installation but after the the installation i can't boot in the mac os system.
Default works. Also, don't forget to install OpenCore on the EFI partition (a 200 MiB sized partition on the begin). I think you forgot the EFI (copy-pasting EFI/ folder into the EFI partition works).
 
Joined
Dec 20, 2020
Messages
4
Motherboard
AsusTek
CPU
Intel Core i5
Graphics
Intel UHD Graphics 620
Mac
  1. MacBook Air
Classic Mac
  1. Portable
Mobile Phone
  1. Android
Default works. Also, don't forget to install OpenCore on the EFI partition (a 200 MiB sized partition on the begin). I think you forgot the EFI (copy-pasting EFI/ folder into the EFI partition works).
Okay thank you.

Your EFI version is it OC 0.6.4 or 0.6.5. ?
 
Joined
Jul 30, 2020
Messages
19
Motherboard
ASUS UX431FA
CPU
i5 10210U
Graphics
Intel UHD Graphics 630 (Mobile)
Mac
  1. iMac
Mobile Phone
  1. Android
  2. iOS
Okay thank you.

Your EFI version is it OC 0.6.4 or 0.6.5. ?
0.6.4 at the moment of the commit if I remember correctly. Upgradable to 0.6.5 if using OpenCore Configurator (easy btw, open, edit something, save).
 
Joined
Dec 20, 2020
Messages
4
Motherboard
AsusTek
CPU
Intel Core i5
Graphics
Intel UHD Graphics 620
Mac
  1. MacBook Air
Classic Mac
  1. Portable
Mobile Phone
  1. Android
Thank you for your reply. everything went well. tell me when you have an update for EFI with the sd card reader work.

Because i can't use my sd card reader.
 
Joined
May 2, 2020
Messages
1
Motherboard
Intel
CPU
Intel Core i7 10th gen
Graphics
NVIDIA MX250
Mac
  1. MacBook Pro
Classic Mac
  1. Apple
Mobile Phone
  1. Android
Hey! Love your work on this. I have a similar Zenbook!(UX434FLC) I was wondering if my Intel WiFi AX201 works as well?
 
Top