Contribute
Register

Asus Z690 ProArt Creator WiFi (Thunderbolt 4) + i7-12700K + AMD RX 6800 XT

Joined
Oct 25, 2017
Messages
217
Motherboard
ProArt Z690-CREATOR WIFI
CPU
i7-12700K
Graphics
RX 6900 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Let’s start with the basics:
  • Which version of macOS?
  • Which GPU?
  • Are any Thunderbolt devices connected?
  • What devices are connected to *internal* USB 2 headers?
  • What is the make/model of the monitor?
  • Are you using a straight DisplayPort to DisplayPort cable (no adapters)?
  • Is this a brand new installation?
  • If so, was Migration Assistant used to import an older system?
  • Which version of macOS? 12.5
  • Which GPU? its the NITRO+ AMD Radeon™ RX 6900 XT. its an XTXH Variant which after research requires "The XTXH variant (Device ID: 0x73AF) is supported with WhateverGreen 1.5.2 and spoofing device-id to 0x73AE"


  • Are any Thunderbolt devices connected? No
  • What devices are connected to *internal* USB 2 headers? The Fenvi wifi/bluetooth
  • What is the make/model of the monitor? HP U32 4K HDR Display.
  • Are you using a straight DisplayPort to DisplayPort cable (no adapters)? Yes directly
  • Is this a brand new installation? Yes- I installed Big Sur and then upgraded to Monterey using software update.
  • If so, was Migration Assistant used to import an older system?
Edit : went over Bios again and PTT was enabled. Changed to disabled System still shuts down when sleeping on its own


Thanks for the fast response !
 
Last edited:

Feartech

Moderator
Joined
Aug 3, 2013
Messages
28,494
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
  • Which version of macOS? 12.5
  • Which GPU? Rx6900 Nitro XT
  • Are any Thunderbolt devices connected? No
  • What devices are connected to *internal* USB 2 headers? The Fenvi wifi/bluetooth
  • What is the make/model of the monitor? HP U32 4K HDR Display.
  • Are you using a straight DisplayPort to DisplayPort cable (no adapters)? Yes directly
  • Is this a brand new installation? Yes- I installed Big Sur and then upgraded to Monterey using software update.
  • If so, was Migration Assistant used to import an older system?
Thanks for the fast response !
As per rules, please update your hardware profile to allow others to help you easier
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
28,494
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
  • Which version of macOS? 12.5
  • Which GPU? NITRO+ AMD Radeon™ RX 6900 XT
  • Are any Thunderbolt devices connected? No
  • What devices are connected to *internal* USB 2 headers? The Fenvi wifi/bluetooth
  • What is the make/model of the monitor? HP U32 4K HDR Display.
  • Are you using a straight DisplayPort to DisplayPort cable (no adapters)? Yes directly
  • Is this a brand new installation? Yes- I installed Big Sur and then upgraded to Monterey using software update.
  • If so, was Migration Assistant used to import an older system?
Thanks for the fast response !
Asus Pro Art seems a little vague....
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
20,105
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
  • Which version of macOS? 12.5
  • Which GPU? its the NITRO+ AMD Radeon™ RX 6900 XT. its an XTXH Variant which after research requires "The XTXH variant (Device ID: 0x73AF) is supported with WhateverGreen 1.5.2 and spoofing device-id to 0x73AE"


  • Are any Thunderbolt devices connected? No
  • What devices are connected to *internal* USB 2 headers? The Fenvi wifi/bluetooth
  • What is the make/model of the monitor? HP U32 4K HDR Display.
  • Are you using a straight DisplayPort to DisplayPort cable (no adapters)? Yes directly
  • Is this a brand new installation? Yes- I installed Big Sur and then upgraded to Monterey using software update.
  • If so, was Migration Assistant used to import an older system?
Edit : went over Bios again and PTT was enabled. Changed to disabled System still shuts down when sleeping on its own


Thanks for the fast response !
The config.plist you posted indicates that it's not from the latest OC 0.8.3 EFI folder. So let's start with a new EFI folder as follows:
  • Download the ProArt Z690-Creator EFI folder from this post
  • Follow the screenshots in that post -- just copy and paste your PlatformInfo --> DataHub information into the new config.plist
  • Then copy the new EFI folder to EFI partition and reboot
  • While this alone may not fix the shutdown-on-sleep issue, it should be done anyway
Another Thought:
  • When you configured BIOS, do you remember selecting Load Optimized Defaults before configuring the various BIOS parameters?
 
Joined
Oct 25, 2017
Messages
217
Motherboard
ProArt Z690-CREATOR WIFI
CPU
i7-12700K
Graphics
RX 6900 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
The config.plist you posted indicates that it's not from the latest OC 0.8.3 EFI folder. So let's start with a new EFI folder as follows:
  • Download the ProArt Z690-Creator EFI folder from this post
  • Follow the screenshots in that post -- just copy and paste your PlatformInfo --> DataHub information into the new config.plist
  • Then copy the new EFI folder to EFI partition and reboot
  • While this alone may not fix the shutdown-on-sleep issue, it should be done anyway
Another Thought:
  • When you configured BIOS, do you remember selecting Load Optimized Defaults before configuring the various BIOS parameters?
Hi thanks for the tips - I updated the EFI, redid the BIOS and now it will not start. Fan turns on for a second. I also put in faster memory and the BIOS automatically updated the memory speed, etc. Is their a preferred core configuration, and also I assume it’s fine to leave resize bar off? the system wouldn't boot so I reset the motherboard and can now boot into bios . . Edit removed a stick of the ram and now boots


Also took a look inside of this build and noticed that this connector is bent - is this standard ? Micro center built this (see photo). I would assume connector should be perpendicular to board? The wire is taught so I can't really straighten it .
 

Attachments

  • CFC354B4-7024-405C-882A-A2915B54D4F9.jpeg
    CFC354B4-7024-405C-882A-A2915B54D4F9.jpeg
    2 MB · Views: 41
Last edited:
Joined
Oct 25, 2017
Messages
217
Motherboard
ProArt Z690-CREATOR WIFI
CPU
i7-12700K
Graphics
RX 6900 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hi thanks for the tips - I updated the EFI, redid the BIOS and now it will not start. Fan turns on for a second. I also put in faster memory and the BIOS automatically updated the memory speed, etc. Is there a way to reset the motherboard and try again? Is their a preferred core configuration, and also I assume it’s fine to leave resize bar off? Thanks.
I should also mention, before redoing the BIOS, I successfully booted with the new memory - but still had the sleep issue so step 2 was to modify BIOS from the start. Thanks.
 
Joined
Oct 25, 2017
Messages
217
Motherboard
ProArt Z690-CREATOR WIFI
CPU
i7-12700K
Graphics
RX 6900 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
I think there is an error in build guide - I assume it’s 1) load optimized defaults
2) change XMP

As loading optimized defaults disables XMP
 

Attachments

  • FD963692-D58B-44BC-87FE-0A2FE19597E2.png
    FD963692-D58B-44BC-87FE-0A2FE19597E2.png
    1.7 MB · Views: 25

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
20,105
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
I think there is an error in build guide - I assume it’s 1) load optimized defaults
2) change XMP

As loading optimized defaults disables XMP
You're right -- changing it now.

What is your current status?
  • System boots?
  • XMP Profile is enabled in BIOS?
  • What is the speed of your memory?
  • When you select Sleep, what happens?
 
Top