Contribute
Register

Asus Z690 ProArt Creator WiFi (Thunderbolt 4) + i7-12700K + AMD RX 6800 XT

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
20,107
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Hi CaseySJ.
Thanks for this great guide. I have just installed Monterey 12.4
My gpu is MSI Gaming Z Trio 6900XT other than almost identical to your setup.

Unfortunately my desktop is a laggy. I am getting full resolution and it says Online in System Profiler.
How can I fix this. I am adding my config.plist and also screenshot from profiler.

Thx in advance.
Hello @motionworks,

Your 6900XT has device ID 0x73af that is not natively supported in macOS. Fortunately we can spoof it to 0x73bf. Couple comments/questions:
  • Which motherboard are you using? Your profile says Asus X99-E WS, but I assume you've just built a new system around Asus ProArt Z690-Creator?
  • Because my board is currently under warranty repair, please download and run IORegistryExplorer then select File --> Save As... and post the saved file. After examining that, I can create a patch.
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
28,494
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Hi CaseySJ.
Thanks for this great guide. I have just installed Monterey 12.4
My gpu is MSI Gaming Z Trio 6900XT other than almost identical to your setup.

Unfortunately my desktop is a laggy. I am getting full resolution and it says Online in System Profiler.
How can I fix this. I am adding my config.plist and also screenshot from profiler.

Thx in advance.
please update your hardware profile to allow others to help you easier
 
Joined
Dec 11, 2010
Messages
81
Motherboard
Asus Z690 ProArt Creator Wifi
CPU
i9-12900K
Graphics
RX 6900 XT
Mac
  1. Mac Pro
Hello @motionworks,

Your 6900XT has device ID 0x73af that is not natively supported in macOS. Fortunately we can spoof it to 0x73bf. Couple comments/questions:
  • Which motherboard are you using? Your profile says Asus X99-E WS, but I assume you've just built a new system around Asus ProArt Z690-Creator?
  • Because my board is currently under warranty repair, please download and run IORegistryExplorer then select File --> Save As... and post the saved file. After examining that, I can create a patch.
Thanks for quick reply. I have just updated my info. It is my old board.
I have Asus ProArt Z690-Creator Wifi. My processor is i9-12900K

Here is the ioreg file. Thx.

ps. added Geekbench score.
 

Attachments

  • Motionworks’s Mac Pro.ioreg
    5.3 MB · Views: 18
  • Screen Shot 2022-06-22 at 3.12.50 PM.png
    Screen Shot 2022-06-22 at 3.12.50 PM.png
    126.6 KB · Views: 17
Last edited:

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
20,107
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Thanks for quick reply. I have just updated my info. It is my old board.
I have Asus ProArt Z690-Creator Wifi. My processor is i9-12900K

Here is the ioreg file. Thx.

ps. added Geekbench score.
Please try the attached SSDT:
  • Copy SSDT-Z690-GPU-SPOOF.aml to the EFI/OC/ACPI folder
  • Add an entry for it in config.plist --> ACPI --> Add
  • Reboot
 

Attachments

  • SSDT-Z690-GPU-SPOOF.aml
    186 bytes · Views: 20
Joined
Dec 11, 2010
Messages
81
Motherboard
Asus Z690 ProArt Creator Wifi
CPU
i9-12900K
Graphics
RX 6900 XT
Mac
  1. Mac Pro
Please try the attached SSDT:
  • Copy SSDT-Z690-GPU-SPOOF.aml to the EFI/OC/ACPI folder
  • Add an entry for it in config.plist --> ACPI --> Add
  • Reboot
Sorry but didn't work. Still laggy. Then i tried to minimize safari, osx freezed for a few minutes.
By the way I am using Macpro7,1 SMBIOS.
 
Last edited:

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
20,107
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Sorry but didn't work. Still laggy. Then i tried to minimize safari, osx freezed for a few minutes.
By the way I am using Macpro7,1 SMBIOS.
Let’s look at the boot log:
Bash:
log show --last boot | head -750 > ~/Documents/bootlog.txt
Please post “bootlog.txt”.
 
Joined
Dec 11, 2010
Messages
81
Motherboard
Asus Z690 ProArt Creator Wifi
CPU
i9-12900K
Graphics
RX 6900 XT
Mac
  1. Mac Pro
Let’s look at the boot log:
Bash:
log show --last boot | head -750 > ~/Documents/bootlog.txt
Please post “bootlog.txt”.
here it is. thx.
 

Attachments

  • bootlog.txt
    111.4 KB · Views: 16

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
20,107
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
here it is. thx.
Ah, please try this modified version -- it's a drop-in replacement (EFI/OC/ACPI folder). Reboot is of course necessary.
 

Attachments

  • SSDT-Z690-GPU-SPOOF.aml
    194 bytes · Views: 16
Joined
Oct 24, 2013
Messages
1,128
Motherboard
Asus ROG Z690 Formula
CPU
i9-13900K
Graphics
RX 6900 XT
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
Mobile Phone
  1. iOS
here it is. thx.
This may be a silly suggestion but I noticed your resolution is 3008 x 1586 which appears to be a non-standard resolution. I've heard some people say that certain macOS resolutions results in blurry text and/or laggy performance. I've never experienced it myself so I can't say whether this is true or not. But might your non-standard resolution be the cause of your troubles? What if you used say 2560x1440p?
 
Joined
Dec 11, 2010
Messages
81
Motherboard
Asus Z690 ProArt Creator Wifi
CPU
i9-12900K
Graphics
RX 6900 XT
Mac
  1. Mac Pro
This may be a silly suggestion but I noticed your resolution is 3008 x 1586 which appears to be a non-standard resolution. I've heard some people say that certain macOS resolutions results in blurry text and/or laggy performance. I've never experienced it myself so I can't say whether this is true or not. But might your non-standard resolution be the cause of your troubles? What if you used say 2560x1440p?
I have also tried full native resolution 4090x2160. Still laggy.
 
Top