Contribute
Register

Asus Z690 ProArt Creator WiFi (Thunderbolt 4) + i7-12700K + AMD RX 6800 XT

Joined
Dec 15, 2010
Messages
535
Motherboard
Asus ProArt Z690 Creator WiF
CPU
i9-12900K
Graphics
RX 6900 XT
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
Hi, anybody experience boot lag and lag in OpenCore Picker screen when Thunderbolt connected. I have my OWC Thunderbolt 3 dock connected. I see significant lag in the bot. but no lag when the dock is disconnected? I use @CaseySJ's EFI folder.
I have a CalDigit TS4 always connected, and I do not experience a lag in OpenCore Picker.
 
Joined
Jun 9, 2021
Messages
291
Motherboard
Gigabyte Z690 Aero G
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Same here. Works fine with Broadcom WiFi/BT module.
I have the Fenvi T919, does not work but I have the intel module still in PC but have HS14 turned off.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,774
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
I have the Fenvi T919, does not work but I have the intel module still in PC but have HS14 turned off.
  • Which version of iPadOS is installed on your iPad?
  • In macOS --> System Preferences --> Displays, have you enabled Universal Control?
  • Are your Mac and iPad both (a) on the same WiFi network and (b) on the same iCloud account?
Have you seen Apple's web page for setting up Universal Control?
 
Joined
Jun 9, 2021
Messages
291
Motherboard
Gigabyte Z690 Aero G
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
  • Which version of iPadOS is installed on your iPad?
  • In macOS --> System Preferences --> Displays, have you enabled Universal Control?
  • Are your Mac and iPad both (a) on the same WiFi network and (b) on the same iCloud account?
Have you seen Apple's web page for setting up Universal Control?
iPad is on 15.5 and Yes to the other questions. It connects via Universal control, iPad goes to a black screen and then disconnects with the below error.
screen-shot-2022-06-21-at-07-26-46-png.549953
Screen Shot 2022-06-21 at 07.27.19.png


Screen Shot 2022-06-21 at 07.27.04.png
 

Attachments

  • Screen Shot 2022-06-21 at 07.26.46.png
    Screen Shot 2022-06-21 at 07.26.46.png
    596.7 KB · Views: 279
  • Screen Shot 2022-06-21 at 07.27.04.png
    Screen Shot 2022-06-21 at 07.27.04.png
    815.1 KB · Views: 16

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,774
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
iPad is on 15.5 and Yes to the other questions. It connects via Universal control, iPad goes to a black screen and then disconnects with the below error.
screen-shot-2022-06-21-at-07-26-46-png.549953
View attachment 549955

View attachment 549956
Are you referring to SideCar or Universal Control?

SideCar will not work without a supported Intel iGPU. But Universal Control works for most of us.
 
Joined
Jun 9, 2021
Messages
291
Motherboard
Gigabyte Z690 Aero G
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Are you referring to SideCar or Universal Control?

SideCar will not work without a supported Intel iGPU. But Universal Control works for most of us.
Universal Control in Monterey
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
19,774
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Universal Control in Monterey
Some other things to try:
  • Shutdown and restart the iPad
  • If this alone does not help, then try this:
    • On the Hackintosh, open System Preferences --> AppleID --> Overview --> Sign Out
    • This will log out of iCloud -- macOS will ask you some questions about what information to retain or delete from the computer; carefully read and respond to each question
    • Reboot Hackintosh
    • Log back in and sign in to iCloud
 
Joined
Oct 24, 2013
Messages
1,091
Motherboard
Asus ROG Z690 Formula
CPU
i7-12700K
Graphics
RX 6900 XT
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
Mobile Phone
  1. iOS
Hi, anybody experience boot lag and lag in OpenCore Picker screen when Thunderbolt connected. I have my OWC Thunderbolt 3 dock connected. I see significant lag in the bot. but no lag when the dock is disconnected? I use @CaseySJ's EFI folder.
If you’re using a Thunderbolt 3 controller with modified firmware to enable Thunderbolt bus, there can be a boot lag when the controller is probed and initialized. But for Maple Ridge TB4, there’s no boot delay.

Also, there are finally non-Intel USB 4 solutions coming such as ASMedia ASM4242. As we know TB4 is an implementation of USB 4, with all the optional features like PCIe tunneling enabled.

The ASMedia chipset may eventually end up in discrete PCIe cards and possibly even some Ryzen motherboards. But I don’t know whether a USB 4 header will be necessary for the discrete cards, similar to the need for a Thunderbolt header on some motherboards. Would be interesting if an ASMedia controller can be used with the Mac to enable Thunderbolt bus. I doubt it but an interesting question nonetheless.
 
Joined
Jun 9, 2021
Messages
291
Motherboard
Gigabyte Z690 Aero G
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Some other things to try:
  • Shutdown and restart the iPad
  • If this alone does not help, then try this:
    • On the Hackintosh, open System Preferences --> AppleID --> Overview --> Sign Out
    • This will log out of iCloud -- macOS will ask you some questions about what information to retain or delete from the computer; carefully read and respond to each question
    • Reboot Hackintosh
    • Log back in and sign in to iCloud
Logging out and back into iCloud fixed that, Thanks mate
 
Joined
Dec 11, 2010
Messages
81
Motherboard
Asus Z690 ProArt Creator Wifi
CPU
i9-12900K
Graphics
RX 6900 XT
Mac
  1. Mac Pro
Hi CaseySJ.
Thanks for this great guide. I have just installed Monterey 12.4
My gpu is MSI Gaming Z Trio 6900XT other than almost identical to your setup.

Unfortunately my desktop is a laggy. I am getting full resolution and it says Online in System Profiler.
How can I fix this. I am adding my config.plist and also screenshot from profiler.

Thx in advance.
 

Attachments

  • config.plist
    37.4 KB · Views: 14
  • Screen Shot 2022-06-22 at 2.53.03 PM.png
    Screen Shot 2022-06-22 at 2.53.03 PM.png
    35.4 KB · Views: 24
Top