Contribute
Register

ASUS Z170 Pro Gaming, GTX 1070 High Sierra Success

Status
Not open for further replies.
Joined
Jun 3, 2017
Messages
10
Motherboard
asus z170 pro gaming
CPU
6700K
Graphics
gtx 1080
Thanks, I will see how it works!
 
Joined
Apr 17, 2017
Messages
12
Motherboard
Asus Z170 Pro
CPU
i7-6700K
Graphics
Gigabyte GeForce GTX 1070 G1 Gaming
Mac
  1. MacBook Pro
After many hours of going round in circles on this over the last 24 hours, I have finally found that the combination that works for me (alongside the OP's guide):
  • LILU.kext (1.1.7)
  • NvidiaGraphicsFixup.kext (1.1.3)
  • NVWebDriverLibValFix.kext (1.0.0)
I thought the NVWebDriverLibValFix was optional, but it was the clincher that finally made everything work and I reckon it would have saved me hours if I had put it in play sooner. I spent far too long messing around with SIP values to no avail! And a also I didn't use AGDPfix in the end.

FCPX 3D text now back and even the transparency problem in iBooks has gone, despite me not having the HD530 iGPU enabled yet.

UPDATE
-------------------------------------
Kext versions are now out of date. See later post.
 
Last edited:
Joined
Mar 2, 2011
Messages
1
Motherboard
GA-Z170X UD5
CPU
Intel Core i3
Graphics
nVidia GTX 1050
Mac
  1. MacBook Air
  2. MacBook Pro
Thanks for posting - is this with Intel GFX enabled or disabled in BIOS? (if you have onboard GFX)
 
Joined
Apr 17, 2017
Messages
12
Motherboard
Asus Z170 Pro
CPU
i7-6700K
Graphics
Gigabyte GeForce GTX 1070 G1 Gaming
Mac
  1. MacBook Pro
Thanks for posting - is this with Intel GFX enabled or disabled in BIOS? (if you have onboard GFX)
Yes, I have both the onboard HD530 and the GTX1070 (PEG set to default in BIOS) enabled. This is a more up-to-date list of the kexts I have installed:
  • Lilu 1.2.0
  • NvidiaGraphicsFixup 1.2.0
  • IntelGraphicsFixup 1.2.0
  • Shiki 2.1.0 (with shikigva=12 flag)
I am using VoodooHDA for audio. I can't claim to have a totally 100% working system though - iTunes video is still flaky, but otherwise sound and graphics acceleration is all there.
 
Joined
Nov 9, 2016
Messages
10
Motherboard
Asus Z170 Pro
CPU
i5 > Need model # > See Rules!
Graphics
GTX 970
Mac
  1. MacBook
  2. MacBook Pro
Yes, I have both the onboard HD530 and the GTX1070 (PEG set to default in BIOS) enabled. This is a more up-to-date list of the kexts I have installed:
  • Lilu 1.2.0
  • NvidiaGraphicsFixup 1.2.0
  • IntelGraphicsFixup 1.2.0
  • Shiki 2.1.0 (with shikigva=12 flag)
I am using VoodooHDA for audio. I can't claim to have a totally 100% working system though - iTunes video is still flaky, but otherwise sound and graphics acceleration is all there.

Thanks for sharing theses info! Helped me to fix the NVIDIA issue I had while following https://www.tonymacx86.com/threads/success-asus-z170-pro-gaming-i5-6500-gtx-970.233447/page-2 post.
 
Status
Not open for further replies.
Top