Contribute
Register

Asus X99 - Catalina Support

Joined
Feb 24, 2020
Messages
3
Motherboard
ASUS Rampage V Extreme
CPU
i7-6950x
Graphics
AMD Radeon VII
Hey guys! I upgraded my 5820k to a 6950x with everything else in my system being the same. I was already using the EFI from @shantonu and it worked fine for the 5820k but all I'm seeing is "++++++" now with the 6950x. Any ideas?
 
Joined
Apr 11, 2016
Messages
49
Motherboard
Gigabyte z390 Designare
CPU
9900k
Graphics
Vega 56
Mac
  1. iMac
Has anyone who's had the power management problems figured it out? I'm idling at max frequency, selecting kernelxcpm doesn't make any difference either. Didn't have this problem with Mojave, struggling to figure it out!

Sabertooth
5820k
 

Attachments

  • config.plist
    24.3 KB · Views: 58
  • kexts.zip
    1.5 MB · Views: 56
Last edited:
Joined
Sep 1, 2011
Messages
60
Motherboard
asus X99-a
CPU
i7-5820K
Graphics
Vega 56
Mac
  1. iMac
Hi there people. I would like to migrate my system to Opencore Boot Loader.
Does anyone have a fully working Opencore build based on the Asus x99-a I7 5820k.
I followed the Opencore vanilla guide, completed the config.plist and perform the sanity check with no errors.
Still, I´m locked. It panic before the kernel load. Nvram clean makes no difference. I´m missing something? maybe my DDST´s ?
I would greatly thank you for any information, advice or at least point me on the right direction to make this build work.
 

Attachments

  • X99-A EFI adn origin folder for Opencore.zip
    2.2 MB · Views: 54
  • IMG_20200328_194403.jpg
    IMG_20200328_194403.jpg
    2.4 MB · Views: 57
Joined
Nov 5, 2011
Messages
17
Motherboard
ASUS X99-E WS
CPU
Xeon E5-1660v3
Graphics
Radeon RX Vega 64 8 Go
Mac
  1. MacBook Pro
  2. Mac Pro
Classic Mac
  1. iBook
  2. iMac
  3. Power Mac
Mobile Phone
  1. iOS
Hi there people. I would like to migrate my system to Opencore Boot Loader.
Does anyone have a fully working Opencore build based on the Asus x99-a I7 5820k.
I followed the Opencore vanilla guide, completed the config.plist and perform the sanity check with no errors.
Still, I´m locked. It panic before the kernel load. Nvram clean makes no difference. I´m missing something? maybe my DDST´s ?
I would greatly thank you for any information, advice or at least point me on the right direction to make this build work.
Hi did you flash your motherboard for MSR 0xE2 register unlock for OSX Kernel Write
 
Joined
Sep 1, 2011
Messages
60
Motherboard
asus X99-a
CPU
i7-5820K
Graphics
Vega 56
Mac
  1. iMac
Hi did you flash your motherboard for MSR 0xE2 register unlock for OSX Kernel Write
Yes. My MB BIOS is patched And MSR 0xE2 is unlocked following the KGP guide.
 
Joined
Nov 5, 2011
Messages
17
Motherboard
ASUS X99-E WS
CPU
Xeon E5-1660v3
Graphics
Radeon RX Vega 64 8 Go
Mac
  1. MacBook Pro
  2. Mac Pro
Classic Mac
  1. iBook
  2. iMac
  3. Power Mac
Mobile Phone
  1. iOS

Attachments

  • config.plist
    67.4 KB · Views: 59
Joined
Sep 1, 2011
Messages
60
Motherboard
asus X99-a
CPU
i7-5820K
Graphics
Vega 56
Mac
  1. iMac
So. No luck over here.
I tried:
EFI as it is..................................................X
Snapshotting your EFI´s config.plist as it is......X
Different variations of kext...... .....................X
Compiling and sanity proofing .......................X
different USB Sticks and ports........................X
Nothing worked for me. I only get different kinds of kernel panics.
 

Attachments

  • IMG_20200329_155414.jpg
    IMG_20200329_155414.jpg
    896.4 KB · Views: 35
  • IMG_20200329_155416.jpg
    IMG_20200329_155416.jpg
    746.4 KB · Views: 42
  • IMG_20200329_155753.jpg
    IMG_20200329_155753.jpg
    761.7 KB · Views: 38
  • IMG_20200329_160709.jpg
    IMG_20200329_160709.jpg
    887.1 KB · Views: 38
  • IMG_20200329_161355.jpg
    IMG_20200329_161355.jpg
    782.9 KB · Views: 30
  • IMG_20200329_165930.jpg
    IMG_20200329_165930.jpg
    1.1 MB · Views: 35
Last edited:
Joined
Nov 5, 2011
Messages
17
Motherboard
ASUS X99-E WS
CPU
Xeon E5-1660v3
Graphics
Radeon RX Vega 64 8 Go
Mac
  1. MacBook Pro
  2. Mac Pro
Classic Mac
  1. iBook
  2. iMac
  3. Power Mac
Mobile Phone
  1. iOS
So. No luck over here.
I tried:
EFI as it is..................................................X
Snapshotting your EFI´s config.plist as it is......X
Different variations of kext...... .....................X
Compiling and sanity proofing .......................X
different USB Sticks and ports........................X
Nothing worked for me. I only get different kinds of kernel panics.
 
Top