Contribute
Register

Asus X99 - Catalina Support

Joined
Jul 23, 2012
Messages
225
Motherboard
ASUS X99 AII
CPU
E5-2696 v3
Graphics
RX 560
Mobile Phone
iOS
Hey guys I updated to 10.15.3 applied the kernel patches but if I don t check the . kernelxcpm checkbox my cpu will be on 70 degrees on idle .
When before I didn t had to check any boxes
 

Attachments

Joined
Nov 27, 2010
Messages
64
Motherboard
ASUS X99-A II
CPU
E5 2690v3
Graphics
RX 580
Mac
iMac
Mobile Phone
iOS
Hi Guys, I am running 10.14.6 on my Asus X99-A with RX580 and I based on KGP guide to make it. If I want to upgrade to Catalina, what is the best way to upgrade from my existing Mojave version to Catalina?
 
Joined
Jan 16, 2012
Messages
1
Motherboard
Asus X99-A
CPU
i7-5820k
Graphics
MSI RX580 4GB OC
Mac
iMac
Hi, since we have similar specs, I hope my EFI folder works for you. I'm on 10.15.2
Thanks a ton for the EFI folder you uploaded! It works on my Asus X99-A + i7-5820k + MSI RX580 4G OC + 10.15.3
 
Joined
Nov 1, 2014
Messages
167
Motherboard
Asus Rampage VI Apex
CPU
i9-9980XE
Graphics
Radeon VII
Mac
MacBook Pro, Mac Pro
Mobile Phone
iOS
Yes, My 3.0Ghz CPU I am constant OC to 4.2 in 10 core. Package temp on full load getting 67C.

Hey bro
You still have a 100% functioning system
x99 i7 6950x in 10.15.3 ?

Can you share a full efi folder with me?

For some reason I did not find any information about this platform for 10.15
 
Joined
Mar 9, 2011
Messages
11
Motherboard
Asus Rampage V Extreme
CPU
i7-6950X
Graphics
Vega 64
Mac
MacBook Pro, Mac Pro
Mobile Phone
iOS
Hey bro
You still have a 100% functioning system
x99 i7 6950x in 10.15.3 ?

Can you share a full efi folder with me?

For some reason I did not find any information about this platform for 10.15
EFI attached as you requested
 

Attachments

Joined
Feb 24, 2020
Messages
3
Motherboard
ASUS Rampage V Extreme
CPU
i7-6950x
Graphics
AMD Radeon VII
I have an Asus Rampage V Extreme and a 5820k and I've been trying to install 10.15.3. Does anyone have a working EFI that can assist? Please and thank you :)
 
Joined
Feb 24, 2020
Messages
3
Motherboard
ASUS Rampage V Extreme
CPU
i7-6950x
Graphics
AMD Radeon VII
@shantonu I tried your EFI and got it to start boot. I have my BIOS patched as described in other posts. But my USB ports are shutting off causing the forbidden sign to come up mid boot... did you ever encounter this?
 
Joined
Aug 19, 2012
Messages
11
Motherboard
ASUS X99-M WS
CPU
Xeon E5-2670v3
Graphics
5700XT
Mac
MacBook Pro
I was able to get up and running with Clover 5103 and I got everything going except my NVME Samsung 970 1TB hard drive. The drive is no longer orange, but the system profile calls it a "Generic SSD Controller", anyone have any ideas or direction for me to start going down? Any guidance would be greatly appreciated.

My setup is as follows:
ASUS X99-M WS
Xeon 12 core 2.2GHz Haswell E5-2670v3
Radeon 5700XT
32GB RAM
 
Last edited:
Joined
Apr 18, 2011
Messages
20
Motherboard
Asus X99-S
CPU
i7 5820k
Graphics
Nvidia GT-740
Mac
MacBook Pro, Mac mini, Mac Pro
Mobile Phone
iOS
Tried and failed miserably. After restart clover does not list the option to install the update. I´m still scratching my head

Ok. Updated to 10.15.3 Using a different definition and EFI folder borrowed from user (mangoicetea) Thank you very much, and upgrading - changing some kext for my MB. Remember to generate a Custom UUID, serial number, board serial SmUUID And rom. Hope this help someone. Have fun.
Are you sure the power management works for you? I tried your config and the cpu was on maximum frequency all the time. I have the same cpu as you.
 
Joined
Feb 17, 2020
Messages
1
Motherboard
Asrock x99 a ii
CPU
E5-2648L v4
Graphics
RX 580
Mac
Mac Pro
Mobile Phone
Android
of course !
Hi everyone I used the EFI that you shared (from joistik) since I have got the same motherboard although I get the following error message when booting.

I have an Asus x99 a ii so in theory the EFI should be fine.

Please advise if anyone has seen this before.
 

Attachments

Top