Contribute
Register

Asus X99 - Catalina Support

Joined
Sep 1, 2011
Messages
60
Motherboard
asus X99-a
CPU
i7-5820K
Graphics
Vega 56
Mac
  1. iMac
After much trouble i got past apfs_module_start 1683, then prohabition sign, now im stuck on gi0screenlockstate 3 which causes it to just reboot, attached is my clover folder. Any help would be greatly appreciated.

Specs:
MB: Asus X99-Pro
CPU: 5930k
GPU: rx 5700xt

Hi, since we have similar specs, I hope my EFI folder works for you. I'm on 10.15.2
 

Attachments

  • EFI.zip
    20.4 MB · Views: 215
Joined
Mar 29, 2011
Messages
852
Motherboard
ASRock X99 Extreme6
CPU
E5-2690 v4
Graphics
Radeon VII
Does anyone have any advice on enabling HEVC hardware-accelerated encoding, with a Radeon VII on 10.14.6?

I suppose I'd be willing to dual boot it with Catalina, if that would help. I need to have Mojave for 32-bit applications.

I found this post: https://www.tonymacx86.com/threads/...ld-extended-guide.255082/page-73#post-1866542

But those files didn't do anything for me. I still get "your system's hardware does not support hardware acceleration for the current settings" in Media Encoder, when I try to use HEVC. KGP said in his guide that this patch is unnecessary for Vegas, and works for enabling HEVC on RX 580, but no mention of Radeon VII. I guess it wasn't out yet. Does anyone have more info?

Anyway, I'm going to install Adobe on Windows, just to verify that it works there.

edited to add: I'm seeing some interesting results, Googling around for IOGVACodec + Radeon VII. It looks like maybe it's possible?
 
Last edited:

dez

Joined
Feb 2, 2014
Messages
124
Motherboard
Asus X299 Deluxe II
CPU
i9-9940X
Graphics
RX 5700XT
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. Android
  2. iOS
Does anyone have any advice on enabling HEVC hardware-accelerated encoding, with a Radeon VII on 10.14.6?

I suppose I'd be willing to dual boot it with Catalina, if that would help. I need to have Mojave for 32-bit applications.

I found this post: https://www.tonymacx86.com/threads/...ld-extended-guide.255082/page-73#post-1866542

But those files didn't do anything for me. I still get "your system's hardware does not support hardware acceleration for the current settings" in Media Encoder, when I try to use HEVC. KGP said in his guide that this patch is unnecessary for Vegas, and works for enabling HEVC on RX 580, but no mention of Radeon VII. I guess it wasn't out yet. Does anyone have more info?

Anyway, I'm going to install Adobe on Windows, just to verify that it works there.

edited to add: I'm seeing some interesting results, Googling around for IOGVACodec + Radeon VII. It looks like maybe it's possible?
Your GPU should appear under GFX0 in your ACPI tables. That’s a bare minimum requirement for this to work.

Assuming you have that setup, you should verify that the board and vendor id of your GPU is listed in the Info.plist of the respective kext loaded for your GPU. If it isn’t, you can use a dummy kext to add these two params to the kext so it loads the required properties.
 
Joined
Mar 7, 2011
Messages
52
Motherboard
Asus Rampage V Extreme
CPU
i7 5820K
Graphics
RX5700XT
Classic Mac
  1. Performa
Mobile Phone
  1. iOS
Does anyone have any advice on enabling HEVC hardware-accelerated encoding, with a Radeon VII on 10.14.6?

I suppose I'd be willing to dual boot it with Catalina, if that would help. I need to have Mojave for 32-bit applications.

I found this post: https://www.tonymacx86.com/threads/...ld-extended-guide.255082/page-73#post-1866542

But those files didn't do anything for me. I still get "your system's hardware does not support hardware acceleration for the current settings" in Media Encoder, when I try to use HEVC. KGP said in his guide that this patch is unnecessary for Vegas, and works for enabling HEVC on RX 580, but no mention of Radeon VII. I guess it wasn't out yet. Does anyone have more info?

Anyway, I'm going to install Adobe on Windows, just to verify that it works there.

edited to add: I'm seeing some interesting results, Googling around for IOGVACodec + Radeon VII. It looks like maybe it's possible?
I hope this is useful to you:
 
Joined
Mar 29, 2011
Messages
852
Motherboard
ASRock X99 Extreme6
CPU
E5-2690 v4
Graphics
Radeon VII
Your GPU should appear under GFX0 in your ACPI tables. That’s a bare minimum requirement for this to work.

Assuming you have that setup, you should verify that the board and vendor id of your GPU is listed in the Info.plist of the respective kext loaded for your GPU. If it isn’t, you can use a dummy kext to add these two params to the kext so it loads the required properties.

Yes, it's GFX0. As I said, it's a Radeon VII, so AMD10000Controller and AMDRadeonX5000 are loading.

I hope this is useful to you:

I'm using Whatevergreen, yeah.

Thank you both for the answers. They led me to reevaluate. I was attempting a 6k encode test, and the VCE 4.1 in Radeon VII has a max resolution of 4k. I used VideoProc, hardware info window, to verify.

Does anyone know what is the command that you can see running within that VideoProc window while it's collecting the information? I'd like to know how to check those details.
 

dez

Joined
Feb 2, 2014
Messages
124
Motherboard
Asus X299 Deluxe II
CPU
i9-9940X
Graphics
RX 5700XT
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. Android
  2. iOS
Yes, it's GFX0. As I said, it's a Radeon VII, so AMD10000Controller and AMDRadeonX5000 are loading.



I'm using Whatevergreen, yeah.

Thank you both for the answers. They led me to reevaluate. I was attempting a 6k encode test, and the VCE 4.1 in Radeon VII has a max resolution of 4k. I used VideoProc, hardware info window, to verify.

Does anyone know what is the command that you can see running within that VideoProc window while it's collecting the information? I'd like to know how to check those details.
Google VDADecoderChecker to find a precompiled binary. Source: https://github.com/cylonbrain/VDADecoderCheck/blob/master/VDADecoderChecker.cpp
 
Joined
Mar 29, 2011
Messages
852
Motherboard
ASRock X99 Extreme6
CPU
E5-2690 v4
Graphics
Radeon VII
Joined
Apr 1, 2011
Messages
141
Motherboard
Ignore me
CPU
I'm Ignoring
Graphics
Forum Rules !!!
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
anyone updated to 10.15.3 yet....?
 
Joined
Mar 28, 2013
Messages
12
Motherboard
ASUS X99 Deluxe
CPU
i7-5820K
Graphics
HD 7970
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
Hi everyone! I installed Catalina successfully, but I came back to Mojave because audio didn't work. Anyway, my PCIe window shows only 2 pieces, graphic card and audio. How can I make everything work in my build????

X99 Deluxe, i7-5820K, HD 7970, 16GB RAM
 
Joined
Sep 1, 2011
Messages
60
Motherboard
asus X99-a
CPU
i7-5820K
Graphics
Vega 56
Mac
  1. iMac
anyone updated to 10.15.3 yet....?
Tried and failed miserably. After restart clover does not list the option to install the update. I´m still scratching my head

Ok. Updated to 10.15.3 Using a different definition and EFI folder borrowed from user (mangoicetea) Thank you very much, and upgrading - changing some kext for my MB. Remember to generate a Custom UUID, serial number, board serial SmUUID And rom. Hope this help someone. Have fun.
 

Attachments

  • Screenshot 2020-02-02 at 21.28.30.png
    Screenshot 2020-02-02 at 21.28.30.png
    2.7 MB · Views: 128
  • EFI.zip
    8.8 MB · Views: 154
Last edited:
Top