Contribute
Register

ASUS X99 Boards - Big Sur (Not Compatible)

Joined
Jul 21, 2010
Messages
98
Motherboard
ASUS X99 Pro USB 3.1
CPU
i7-6800K
Graphics
RX480+HD5750
I have tried for three weeks on my asus x99. And i have no idea about this issue. I guess it will be fixed when the Big Sur release.
I've tried for 9 weeks on my x99. I was hoping for Clover to upgrade ability to boot Big Sur, but as of now they are using opencore guts and have not succeeded yet. As for opencore, the creators, vit and d-fritz have addressed us x99ers by saying the don't have plans to help fix booting Big Sur on x99. There also was someone saying they got the same KP on their x79. Now that could change, but as of now the fixers are us. We have @ITzTravelInTime on the front line doing systematic work, and we're left being the supporters and word spreaders. When Big Sur goes live we'll be able to post on reddit, as they don't allow beta support. reddit already deleted a Big Sur post I made. So if you want to go to any other hackintosh pages/forums and ask for help, that would be appreciated, as the more we talk it up, the more likely we are to get help. If we say nothing no one will help. and don't even count on opencore to help, they are reticent.
 
Last edited:
Joined
Jul 21, 2010
Messages
98
Motherboard
ASUS X99 Pro USB 3.1
CPU
i7-6800K
Graphics
RX480+HD5750
I git what you mean. I am trying and never give It up.
just now ,I saw some one success with his x299. I don't know if it can help us something. https://github.com/khronokernel/OpenCore-Asus-X299
X299 got help from the opencore folks, they added some ssdt, which we've already tried. x299 is a newer board, so that's probably why they got help and we didn't
 
Joined
Mar 18, 2017
Messages
1,007
Motherboard
ASUS ROG Rampage VI Extreme
CPU
i9-7940X
Graphics
2 X VEGA 56
Mac
  1. iMac
  2. Mac mini
Mobile Phone
  1. iOS
Unfortunately no help came from experimented X99 owners...
About the IOCPIFamily.kext they radically changed it for Big Sur
As you can see on the picture below :
Left side Catalina IOCPIFamily.kext and Right side Big Sur IOCPIFamily.kext
- The structure of the kext as changed
- The size of Unix exe fell from 302 KB to 80 KB
- The info.plist on Big Sur has no more references to IOPCI2PCIBridge-PCI, IOPCI2PCIBridge-i386 and at the end com.apple.kpi.mach

So obviously we can assume that it lacks an enumeration and compatibility with previous platforms.

I have no build with X99 and I only managed to install Big Sur on Asus H87-Plus i5 4460 which is totally different and not HEDT .
So unfortunately, my help should be limited.
Did someone tried to inject Catalina IOCPIFamily.kext with OC USB installer ?

Screenshot 2020-09-20 at 19.50.15.png
 
Last edited:
Joined
Nov 26, 2014
Messages
38
Motherboard
ASUS Sabertooth Z87
CPU
i7 4770k
Graphics
GTX 960
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. iOS
Unfortunately no help came from experimented X99 owners...
About the IOCPIFamily.kext they radically changed it for Big Sur
As you can see on the picture below :
Left side Catalina IOCPIFamily.kext and Right side Big Sur IOCPIFamily.kext
- The structure of the kext as changed
- The size of Unix exe fell from 302 KB to 80 KB
- The info.plist on Big Sur has no more references to IOPCI2PCIBridge-PCI, IOPCI2PCIBridge-i386 and at the end com.apple.kpi.mach

So obviously we can assume that it lacks an enumeration and compatibility with previous platforms.

I have no build with X99 and I only managed to install Big Sur on Asus H87-Plus i5 4460 which is totally different and not HEDT .
So unfortunately, my help should be limited.
Did someone tried to inject Catalina IOCPIFamily.kext with OC USB installer ?

Wiredly itr still worked with my socket 775 machine on various betas, probably the problems is the particular implementation x99 has with multiple pcie controllers.

About injecting i tought about that since we can still use the old kext from catalina, but i am afraid i can't work since this kext has dependecies which requires it to be installed in s/l/e and the lack of the references you mentioned can be a problem, but i will attempt at it if i can, we can always mod the system partition to replace iopcifamily and put back dependecyes, but your system will no longer be clean and upgradable and this can cause huge problems because in the future apple can remove system binaryes entirely and give us just the kernel collections as ways to boot the os and store those important system programs.
 
Joined
Nov 26, 2014
Messages
38
Motherboard
ASUS Sabertooth Z87
CPU
i7 4770k
Graphics
GTX 960
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. iOS
Some info i gathered about the kernel panic so far:

1) an x99 system has 4 pci device trees, and so the [PCI configuration beging] thing happens 4 times
2) the kernel panic happens after the first [PCI configuration begin] but before the second one, so it might probably be an issue with _SM.PCI1 (the 2nd pci device tree) or _SM.PCI0 (the first pci device tree)
3) reading the panic log with -keepsymbs=1 the function that are called into the stack (related to IOPCIFamily) before the system calls the panic are (in order):
IOPCIBridge.start
IOPCIBridge.probeBus
IOPCIBridge.extendedFindCapability (this one seems related to an address space)
IOPCIConfigurator.findPCICapability

The last one is the fucntion which triggers the panic, so this is a problem with information gathered by the APCI i think

4)AppleACPIPlatform is involved in all of this but it doesn't seem to be the issue
5) if the problem come from the 2nd pci device tree the pateches attempted by far are useless
 
Joined
Nov 26, 2014
Messages
38
Motherboard
ASUS Sabertooth Z87
CPU
i7 4770k
Graphics
GTX 960
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. iOS
About the IOCPIFamily.kext they radically changed it for Big Sur
As you can see on the picture below :
Left side Catalina IOCPIFamily.kext and Right side Big Sur IOCPIFamily.kext
- The structure of the kext as changed
- The size of Unix exe fell from 302 KB to 80 KB
- The info.plist on Big Sur has no more references to IOPCI2PCIBridge-PCI, IOPCI2PCIBridge-i386 and at the end com.apple.kpi.mach

What all of those changes tell me is that IOPCIFaily now has been kind of nerfed, because the IOKitPersonalityes basically tell IOKit what to do with the kext and so having that blank means that now the kext will be started anytime
and not initilized for specific devices like before, likely a lot of functionality has been mooved to other system programs like driver extensions leaving IOPCIFamily more bare-bones
 
Joined
Nov 26, 2014
Messages
38
Motherboard
ASUS Sabertooth Z87
CPU
i7 4770k
Graphics
GTX 960
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. iOS
What all of those changes tell me is that IOPCIFaily now has been kind of nerfed

I have to say that this makes a lot of sence since the transition to apple silicon demands that stuff like this is as generic as possible, so it makes sensto to moove x86 specific stuff to dedicated drivers and libraryes, and also AppleACPIPlatform is no longer a kext but ratehr a driver extensions, which again makes sense since apple is trying to use less kernel extensions as possible for security reasons
 
Joined
Apr 9, 2019
Messages
48
Motherboard
X79T 1.02
CPU
E5-1650v2
Graphics
RX 5700XT
I have to say that this makes a lot of sence since the transition to apple silicon demands that stuff like this is as generic as possible, so it makes sensto to moove x86 specific stuff to dedicated drivers and libraryes, and also AppleACPIPlatform is no longer a kext but ratehr a driver extensions, which again makes sense since apple is trying to use less kernel extensions as possible for security reasons
I have the same problem on x79t (Chinese board based on B75 chipset, LGA2011, Xeon e5-1650v2, 4-channel ddr3). The problem could not be resolved, but Catalina works with this bootloader. I am attaching my EFI folder and video log.
I need this update, so I want to help in solving the problem as much as I can. What is required of me? I apologize for poor knowledge of English.
We need someone from the developers to deal with this issue. Because such boards are not common in developed countries where developers are located. I am ready to test developments
 

Attachments

  • EFI_OC_X79T.zip
    2.9 MB · Views: 22
  • IMG_0135.MOV.zip
    47.4 MB · Views: 12
  • IMG_0135.png
    IMG_0135.png
    2.1 MB · Views: 39
Joined
Jul 23, 2011
Messages
6
Motherboard
GA-X99-UD5 WiFi
CPU
Intel Core i7 5930K
Graphics
AMD Radeon RX5700 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
I've started a bigsur installer. The time to find out what's made it work.
IMG_4255.jpeg
 
Joined
Nov 28, 2010
Messages
88
Motherboard
ASUS X99-E WS/USB3.1
CPU
E5-2696 v3
Graphics
Vega FE
I have the same problem on x79t (Chinese board based on B75 chipset, LGA2011, Xeon e5-1650v2, 4-channel ddr3). The problem could not be resolved, but Catalina works with this bootloader. I am attaching my EFI folder and video log.
I need this update, so I want to help in solving the problem as much as I can. What is required of me? I apologize for poor knowledge of English.
We need someone from the developers to deal with this issue. Because such boards are not common in developed countries where developers are located. I am ready to test developments
Try to choose the MacPro 6.1 model
 
Top