Contribute
Register

Asus X299 - Support

Joined
Apr 18, 2011
Messages
1,298
Motherboard
ASUS Pro WS X299 Sage II
CPU
i9-10980XE
Graphics
Radeon Pro W5500
Mac
  1. MacBook Air
  2. Mac Pro
Mobile Phone
  1. iOS
@djlild7hina I’ll give that a shot tonight. It’s really odd that it’s not booting from the EFI partition.

Could the partition be damaged even though it shows up ok after mounting?

Not sure to be honest, does your EFI partition show up as a bootable option in the BIOS?
 
Joined
Aug 4, 2011
Messages
309
Motherboard
ASUS WS Sage X299 / 10G
CPU
i9-10980XE
Graphics
Vega 64
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Not sure to be honest, does your EFI partition show up as a bootable option in the BIOS?
It doesn’t seem to. It was fine for the last year and then it just stopped booting off it last week. I thought the drive died at first so I had a small panic attack.
 
Joined
Aug 4, 2011
Messages
309
Motherboard
ASUS WS Sage X299 / 10G
CPU
i9-10980XE
Graphics
Vega 64
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
@djlild7hina did you have the Sage 10G by chance? I want to do the 10GbE flash but those instructions from the kgp post but it looks insanely overwhelming (the Linux boot/ flash) (my local ISP is install fibre next week and I can get 1.5-1.8 gbit, plus I’m going all 10GbE throughout the house so I’d love to activate both of those ports and aggregate the connection).
 
Joined
Apr 18, 2011
Messages
1,298
Motherboard
ASUS Pro WS X299 Sage II
CPU
i9-10980XE
Graphics
Radeon Pro W5500
Mac
  1. MacBook Air
  2. Mac Pro
Mobile Phone
  1. iOS
@djlild7hina did you have the Sage 10G by chance? I want to do the 10GbE flash but those instructions from the kgp post but it looks insanely overwhelming (the Linux boot/ flash) (my local ISP is install fibre next week and I can get 1.5-1.8 gbit, plus I’m going all 10GbE throughout the house so I’d love to activate both of those ports and aggregate the connection).

Yep I still have it although it's currently in a box since I'm using the Sage II.

I updated kgp's notes onto my github to hopefully make it easier to follow
 
Joined
Aug 4, 2011
Messages
309
Motherboard
ASUS WS Sage X299 / 10G
CPU
i9-10980XE
Graphics
Vega 64
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Joined
Apr 18, 2011
Messages
1,298
Motherboard
ASUS Pro WS X299 Sage II
CPU
i9-10980XE
Graphics
Radeon Pro W5500
Mac
  1. MacBook Air
  2. Mac Pro
Mobile Phone
  1. iOS
Wow that's a LOT easier to follow.

Hope it works, I'll attempt it tonight after work!

Good luck! It's a little daunting at first but it should be pretty straight forward. I'd recommend SmallTree drivers so you can skip step 8.
 
Joined
Aug 4, 2011
Messages
309
Motherboard
ASUS WS Sage X299 / 10G
CPU
i9-10980XE
Graphics
Vega 64
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Good luck! It's a little daunting at first but it should be pretty straight forward. I'd recommend SmallTree drivers so you can skip step 8.
Just did it quick, SUCCESS FOR BOTH PORTS!!!! You're a gem, thank you so much!!
 
Joined
Aug 4, 2011
Messages
309
Motherboard
ASUS WS Sage X299 / 10G
CPU
i9-10980XE
Graphics
Vega 64
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Great! Glad it worked :)
In a week or so, that download will go to 1.5ish and upload will be around 940 ... super excited and glad this wasn't potentially deadly LOL.

Thank you again!!
 

Attachments

  • Screen Shot 2021-08-27 at 3.04.44 PM.png
    Screen Shot 2021-08-27 at 3.04.44 PM.png
    358.9 KB · Views: 18
Joined
Aug 4, 2011
Messages
309
Motherboard
ASUS WS Sage X299 / 10G
CPU
i9-10980XE
Graphics
Vega 64
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
@djlild7hina You don't use a Keychron keyboard on your setup by chance do you? LOL ... I noticed something really interesting regarding a Bluetooth issue I'm having.

Mojave won't see the keyboard at all, but Ubuntu did when I booted into it to do the 10GbE procedure. Any ideas? Bluetooth in Mojave works for everything else.
 
Top