Contribute
Register

Asus X299 - Support

Joined
Apr 16, 2012
Messages
226
Motherboard
Asus X299 Prime Deluxe
CPU
i9-7960x
Graphics
Vega 56
Hello! I am finally ready to update to Catalina and wanted to ask if there are any special updates to my EFI that I need to make? I am on the latest Clover, Lilu, Whatevergreen, AppleALC.

Thank you!
 
Joined
Jul 16, 2010
Messages
62
Motherboard
Asus Prime X299 Deluxe
CPU
i7-7820X
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
Hello. I apologize, but I am having a very hard time getting this Hackintosh built. I have read and re read KGP's original post, then the supporting one for Catalina and I STILL can't get it built! I have never had this much trouble building a hackintosh, this is the first time I've had to post for help.

I have attached my EFI folder. (this EFI folder is from the Catalina X299 post, and it is the BASE efi folder.) My hardware is:

Asus Prime X299 Deluxe (It's the original one, I bought it within weeks of it coming out.)
BIOS is the latest (3006) patched
Intel I7-7820X
Saphire Nitro Plus Radeon 5700XT Graphics card.
Samsung 960 Pro NvME drive.

What am I missing?

THank you!
 

Attachments

  • EFI.zip
    57.8 MB · Views: 126
Last edited:
Joined
Apr 18, 2011
Messages
1,469
Motherboard
ASUS Pro WS X299 Sage II
CPU
Intel i9-10980XE
Graphics
AMD Radeon Pro W5500
Mac
  1. MacBook Air
  2. Mac Pro
Mobile Phone
  1. iOS
Hello! I am finally ready to update to Catalina and wanted to ask if there are any special updates to my EFI that I need to make? I am on the latest Clover, Lilu, Whatevergreen, AppleALC.

Thank you!

If you’re already on latest then you should be good. Just remember to have a backup in case something happens.
 
Joined
Mar 19, 2020
Messages
4
Motherboard
Asus X299
CPU
i9-9820X
Graphics
GTX 970/RX580
Mac
  1. Mac mini
Mobile Phone
  1. iOS
Just want post a successful install on Asus X299 pro/10 core/RX 580(was GTX 970) was able to install Hi Sierra on r5110 GTX 970 but later update to UniBeast r5107 Mojave but need the RX 580. Everything looks to be working AirDrop, Bluetooth, WiFi, Thunderbolt, etc. I won't update to Catalina for some reason. I will have to try another time.
Have I taken the easy route of installing UniBeast. I keep on hearing OpenCore?
 
Joined
Apr 18, 2011
Messages
1,469
Motherboard
ASUS Pro WS X299 Sage II
CPU
Intel i9-10980XE
Graphics
AMD Radeon Pro W5500
Mac
  1. MacBook Air
  2. Mac Pro
Mobile Phone
  1. iOS
Hello. I apologize, but I am having a very hard time getting this Hackintosh built. I have read and re read KGP's original post, then the supporting one for Catalina and I STILL can't get it built! I have never had this much trouble building a hackintosh, this is the first time I've had to post for help.

I have attached my EFI folder. (this EFI folder is from the Catalina X299 post, and it is the BASE efi folder.) My hardware is:

Asus Prime X299 Deluxe (It's the original one, I bought it within weeks of it coming out.)
BIOS is the latest (3006) patched
Intel I7-7820X
Saphire Nitro Plus Radeon 5700XT Graphics card.
Samsung 960 Pro NvME drive.

What am I missing?

THank you!


You need SSDT-AWAC.aml on patched firmware as mentioned in my github. Also make sure to enable 4G Encoding in the BIOS and disable CSM. You didn't have a usb kext so I temporarily enabled the xchi port limit with USBInjectAll. I highly recommend you make your own usb kext as mentioned in the Dortania OpenCore guide.

I've updated the EFI with the following changes:
1. Added SSDT-AWAC.aml
2. Changed TSCAdjustReset.kext to '15' instead of '31' (7820x has 16 threads)
3. Added bootflag agpdmod=pikera for 5700XT
4. Enabled XchiPortLimit under Kernel->Quirks
5. Added USBInject.kext
6. Added Ethernet kexts (IntelMausiEthernet.kext and SmallTree-Intel-211VA-PCIe-GBE.kext)

Remember to create a MacPro7,1 serial number and input the info in the PlatformInfo section.
 

Attachments

  • EFI.zip
    58 MB · Views: 175
Last edited:
Joined
Apr 18, 2011
Messages
1,469
Motherboard
ASUS Pro WS X299 Sage II
CPU
Intel i9-10980XE
Graphics
AMD Radeon Pro W5500
Mac
  1. MacBook Air
  2. Mac Pro
Mobile Phone
  1. iOS
Just want post a successful install on Asus X299 pro/10 core/RX 580(was GTX 970) was able to install Hi Sierra on r5110 GTX 970 but later update to UniBeast r5107 Mojave but need the RX 580. Everything looks to be working AirDrop, Bluetooth, WiFi, Thunderbolt, etc. I won't update to Catalina for some reason. I will have to try another time.
Have I taken the easy route of installing UniBeast. I keep on hearing OpenCore?

Maybe on an older version of Clover or something is missing in your EFI. OpenCore is a new bootloader that will eventually replace Clover.
 
Joined
Apr 19, 2020
Messages
60
Motherboard
ASUS Prime X299-A II
CPU
i9-10940X
Graphics
Sapphire Pulse Radeon RX 580
Mac
  1. MacBook Pro
Hey folks,

I am looking for a X299 board that works without any problems and isn't that costy. As I will replace Thunderbolt and WiFi anyways, it doesn't need to have this features on board. Just a minimum of 128GB RAM and maybe at least two or more M.2 slots would be great. Any ideas? :)
 
Joined
Mar 19, 2020
Messages
4
Motherboard
Asus X299
CPU
i9-9820X
Graphics
GTX 970/RX580
Mac
  1. Mac mini
Mobile Phone
  1. iOS
Hey folks,

I am looking for a X299 board that works without any problems and isn't that costy. As I will replace Thunderbolt and WiFi anyways, it doesn't need to have this features on board. Just a minimum of 128GB RAM and maybe at least two or more M.2 slots would be great. Any ideas? :)
How about this one? I was thinking of doing another hack; it looks like a decent price as everything has gone up.
 
Joined
Jul 16, 2010
Messages
62
Motherboard
Asus Prime X299 Deluxe
CPU
i7-7820X
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
You need SSDT-AWAC.aml on patched firmware as mentioned in my github. Also make sure to enable 4G Encoding in the BIOS and disable CSM. You didn't have a usb kext so I temporarily enabled the xchi port limit with USBInjectAll. I highly recommend you make your own usb kext as mentioned in the Dortania OpenCore guide.

I've updated the EFI with the following changes:
1. Added SSDT-AWAC.aml
2. Changed TSCAdjustReset.kext to '15' instead of '31' (7820x has 16 threads)
3. Added bootflag agpdmod=pikera for 5700XT
4. Enabled XchiPortLimit under Kernel->Quirks
5. Added USBInject.kext
6. Added Ethernet kexts (IntelMausiEthernet.kext and SmallTree-Intel-211VA-PCIe-GBE.kext)

Remember to create a MacPro7,1 serial number and input the info in the PlatformInfo section.


djlild7hina - THANK YOU! THANK YOU!
I got further than before.... the USB appeared to boot, but then just went to a black screen to not progress any further. I am using an apple display monitor (mini display port) to display port adapter and into the display port on the 5700 XT.
It appeared to me as though the installer should have launched and showed up on my screen, but again, it was just a black screen.

I turned on 4G encoding and turned off CSM like you suggested in the BIOS.

Where and how do I create a MacPro7,1 serial number?
Thank you again! I feel like this might actually happen now!
 
Joined
Apr 18, 2011
Messages
1,469
Motherboard
ASUS Pro WS X299 Sage II
CPU
Intel i9-10980XE
Graphics
AMD Radeon Pro W5500
Mac
  1. MacBook Air
  2. Mac Pro
Mobile Phone
  1. iOS
djlild7hina - THANK YOU! THANK YOU!
I got further than before.... the USB appeared to boot, but then just went to a black screen to not progress any further. I am using an apple display monitor (mini display port) to display port adapter and into the display port on the 5700 XT.
It appeared to me as though the installer should have launched and showed up on my screen, but again, it was just a black screen.

I turned on 4G encoding and turned off CSM like you suggested in the BIOS.

Where and how do I create a MacPro7,1 serial number?
Thank you again! I feel like this might actually happen now!

Refer to the Dortonia OpenCore guide and create a Serial Number using GenSMBIOS.

The guide suggests to just use Generic and Automatic but the processor doesn't properly show in 'About This Mac' so that's why in the config.plist there are additional things to fill out.

When you say it appeared to boot, did you see the OpenCore GUI selection and could you pick install macOS? Which version of Catalina are you trying to install?
 
Top