Contribute
Register

Asus X299 - Support

djlild7hina

Retired
Joined
Apr 18, 2011
Messages
914
Motherboard
ASUS ROG Rampage VI Extreme Encore
CPU
i9-10980XE
Graphics
AMD RX 580
Hello,

I plan to upgrade my CPU from i9-7900X to i9-10940X, and I’m wondering what I have exactly to do on a X299 Mark 1 with Clover last version.

Here is what I have already been able to gather about this. Correct me if I’m wrong.
  • Upgrade to BIOS 2002 and avoid like the plague the last version 3006.
  • In bios, enable Above4GDecoding.
  • Change IOCPUNumber in TSCAdjustReset.kext according to the number of my cores, and insert it in Kext/Others (in my case 19 > 27)
  • Add Cascade-Lake X fix in Clover/ACPI/patched. Tonzone had given me SSDT-X299-CascadeLakeFix.aml at post #2,157, it should be good for my config.
So, people who have already jump to 10th gen, is it enough?

Thank in advance for your help. I’m pretty sure it will interest a lot of people to have all the necessary advice put together in one post.

Please, no OpenCore advice.

Yes, that sounds about right. You may not even need the Cascade Lake fix since your board is a pre Cascade Lake X refresh board and you're using BIOS 2002 and not 3006.

I would update your Clover first with the 7900x and make sure everything works then swapping to 10940x
 
Last edited:
Joined
Jan 29, 2020
Messages
64
Motherboard
WS X299 Sage/10G -3001 - OpenCore
CPU
i9-7980XE
Graphics
Pro WX 8200
Mac
  1. iMac
  2. MacBook Pro
  3. Mac Pro
Mobile Phone
  1. iOS
No worries! I’d actually recommend 2002 and use BIOS flashback (refer to the manual) you can also refer to kgp’s guide on how to patch Ethernet in order for the built in 10g ports to work.
You can look at the open core thread or the Catalina thread for more open core support.

There’s the vanilla OpenCore guide linked in post one and a github for efis to get you started. Good luck!
I'm really happy to see the organization and explanations in the OpenCore guide, this is what I've been looking for.

Am I correct that if I format the system SSD and follow the guide from the beginning I shouldn't need to worry about the Clover Conversion stuff?
Thank you again.
 

djlild7hina

Retired
Joined
Apr 18, 2011
Messages
914
Motherboard
ASUS ROG Rampage VI Extreme Encore
CPU
i9-10980XE
Graphics
AMD RX 580
I'm really happy to see the organization and explanations in the OpenCore guide, this is what I've been looking for.

Am I correct that if I format the system SSD and follow the guide from the beginning I shouldn't need to worry about the Clover Conversion stuff?
Thank you again.

Yes that's correct.
 
Joined
Sep 6, 2013
Messages
42
Motherboard
Asus X299 Mark 2
CPU
i9-7900X
Graphics
RX 570
Mac
  1. iMac
Yes, that sounds about right. You may not even need the Cascade Lake fix since your board is a pre Cascade Lake X refresh board and you're using BIOS 2002 and not 3006.
I would update your Clover first with the 7900x and make sure everything works then swapping to 10940x
Thanks :thumbup:
 
Joined
Nov 13, 2010
Messages
53
Motherboard
Asus X299 Prime Deluxe II
CPU
i9-10980XE
Graphics
Radeon VII
Mac
  1. MacBook Pro
Classic Mac
  1. 128K
  2. 512K
  3. Apple
  4. Classic
  5. iBook
  6. Performa
  7. Power Mac
  8. PowerBook
  9. SE
Mobile Phone
  1. iOS
Hello! Can you share you EFI file with me. My hardware is similar to yours.

I am basically running the same as @dez from his repo with the exception of the Radeon VII which you don't need to do anything for. He has the file for the 5700 XT in this folder, just remove it.

Everything works, including TB3.
 
  • Like
Reactions: dez
Joined
Aug 16, 2012
Messages
383
Motherboard
Asus X299 DELUXE II
CPU
i9-10940X
Graphics
Vega 56
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. iOS
I am basically running the same as @dez from his repo with the exception of the Radeon VII which you don't need to do anything for. He has the file for the 5700 XT in this folder, just remove it.

Everything works, including TB3.
Hi, could you share your EFI please? Because I tried many times the Daze's EFI but my Thunderbolt Hotplug doesn't work. First, cold boot too, Thunderbolt doesn't mount. Do you confirm?
Many thanks.
 
Joined
Jun 30, 2018
Messages
9
Motherboard
ASUS X299 Gaming E II
CPU
i9-10900X
Graphics
Vega 64
hello... I read through most of it and got a bit concerned. I just bought a ASUS X299 Gaming E II with an i9-10900k and I can't get it booting from clover/opencore. I applied the patch to my bios and used the EFI from:

@kusakusa Try this EFI Folder.

and changed the number of cores in the TSCAdjustReset.kext. Still won't see anything else then "++++++++++++++++++++++++++" on my screen.... Has anybody seen this configuration working ??!

Hope you could point me into some directions how to continue... Also: Is there a way to verify the BIOS got flashed correctly? I am using version 0603 - should I downgrade (which version)? Thanks!


Figured it out using open core. Can confirm the combination works with most features. Having still some sleep problems but will continue there: https://www.tonymacx86.com/threads/asus-x299-catalina-support.279556/

Thx anyway and keep up the great work!
 
Last edited:
Joined
May 24, 2020
Messages
3
Motherboard
Prime Del II
CPU
7980XE
Graphics
Radeon VII
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
  4. Mac mini
  5. Mac Pro
Classic Mac
  1. 128K
  2. Apple
  3. Centris
  4. Classic
  5. Color Classic
  6. iMac
  7. LC
  8. Performa
  9. Plus
  10. Power Mac
  11. PowerBook
  12. SE/30
Mobile Phone
  1. Other
thx
 
Last edited:
Joined
Aug 16, 2012
Messages
383
Motherboard
Asus X299 DELUXE II
CPU
i9-10940X
Graphics
Vega 56
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. iOS
Good evening. Somebody confirmed that the Wifi doesn't works since 10.15.5 updated ?
 
Top