Contribute
Register

Asus X299 - Support

Joined
Mar 19, 2017
Messages
21
Motherboard
Asus X299 WS PRO
CPU
i9-9940X
Graphics
Vega 64
Mac
MacBook Pro, Mac Pro
Mobile Phone
iOS
I successfully booted and installed Catalina! Finally!! I stole a EFI folder from one of the users in the x299 Mojave thread, and it worked with a different Catalina USB installer. without flashing bios. Means my BOIS is unlocked? (I did add the kernel patch in clover configurator though)

Guess I need to continue reading some more in KGP’s guide.. also to get native NVRAM running.. right?

EDIT:

Got a BSD kernel panic when typing my previous message :/
 
Last edited:
Joined
Apr 28, 2018
Messages
202
Motherboard
Asus Dominus Extreme
CPU
3175X
Graphics
Radeon VII
Mac
iMac
Nope, you just go an other route via patch... You just work around the problem. It would be better to implement it correctly in order to use a better solution permanently, but I will not persuade anybody to his luck. Everything you need, I've provided. That's all I can do.
 
Joined
Mar 19, 2017
Messages
21
Motherboard
Asus X299 WS PRO
CPU
i9-9940X
Graphics
Vega 64
Mac
MacBook Pro, Mac Pro
Mobile Phone
iOS
Yeah, I will try. But do I then remove the kernel patch?

BTW think the kernel panic was due to the fact the system went to sleep. Still need to configure that.

NOPE: System just restarts when idle. Removed the other .aml patches that the user had and now it seems stable. Although when I check system report I have a lot less PCI entries compared to before..

NOPE: just randomly freezes and restarts. Weird. Gonna try a re-install with my own custom EFI etc.
 
Last edited:

RuleBreaker01

Banned
Joined
May 31, 2018
Messages
368
Anyone upgraded to 10.15.5 without issues?

First I did the upgrade like I've always done, not reading notes here about it. Didn't upgrade Clover nor any of the kext.

Rebooted, selected the upgrade partition and it crashed after a while with a crossed-circle.
Rebooted restarted, and it just hang there. After over 45 minutes I rebooted and attempted to restart in the standard partition.

Now when it boots I see lots of crashes like:
AMFI: SIP is off, allowing core dump for 110
AMFI: SIP is off, allowing core dump for 137
AMFI: SIP is off, allowing core dump for 141
Process[141] crashed : coresymbolicatio. Too many corpses being corrupted.

And it goes on and on and on :(

any ideas?
Thanks
 

Attachments

RuleBreaker01

Banned
Joined
May 31, 2018
Messages
368
Right, after lots of hassles, I've managed to boot.
Updated clover to 5107,AppleALC,LiLu and installed WhateverGreen

I could boot, but got to a black screen.

Turned out, none of my DP ports are working now, only the HDMI one :(
 

RuleBreaker01

Banned
Joined
May 31, 2018
Messages
368
Alright, I got audio working again by using the latest AppleALC.kext (version 1.4.8 not the one found here in the download section) with Lilu 1.4.3

I recovered my DP ports (2x 5K screen) using this kext necessary with amd cards (Whatevergreen.kext didn't work for me unfortunately)
 

Attachments

Joined
Mar 14, 2020
Messages
6
Motherboard
Gigabyte Designare x299 ex
CPU
i9-7940x
Graphics
Radeon VII
I'm working on getting Mojave working on an ASUS x299 Prime Deluxe ii. Is there a specific BIOS version that is recommended? The latest one (3006) didn't seem to work very well for hackintosh, but I flashed back to 0802 and it's a bit better. Is there a bios version that is known to work the best?
 
Joined
Mar 4, 2020
Messages
4
Motherboard
Asus Prime X299 Deluxe II
CPU
i9-7960X
Graphics
Radeon VII
I successfully built 15.4 on my deluxeii and 7960x, everything works fine, including sleep, I also customized the truncated usb driver, the problem now is that my Thunderbolt 3 , and during cold boot, Everything is working fine, but hotplug is not supported. I have tried all the ssdt I can find about Thunderbolt 3 hotplug, but it has no effect. This is my ioreg and my efi file. My original ssdt file, can someone help me see it,thanks!!
 

Attachments

Joined
Mar 4, 2020
Messages
4
Motherboard
Asus Prime X299 Deluxe II
CPU
i9-7960X
Graphics
Radeon VII
And my Thunderbolt device is always loaded under DSB1 and 4, and now ssdt defines xhc under DSB2, I guess whether it is related to this, so I modified my ssdt, but it did not work
 
Joined
Jan 4, 2020
Messages
11
Motherboard
PRIME X299 DELUXE
CPU
10940x
Graphics
vega64
Mac
MacBook Pro, Mac Pro
Hello

I am a beginner.
I bought ROG STRIX X299-E GAMING II.
Currently, can't this be boot by Mojave yet?
CPU is 10940x

Thanks so much
 
Last edited:
Top