Contribute
Register

Asus X299 - Support

Joined
Mar 29, 2011
Messages
857
Motherboard
ASRock X99 Extreme6
CPU
E5-2690 v4
Graphics
Radeon VII
Also, I'm only booting up if my Mojave system disc is plugged into a USB 2.0 port. It won't boot if plugged into USB 3.0 or the Serial ATA connectors.

That'd be the reason the boot is slow. So, when you try to use SATA, does it install? Or just not show the disk as an option in the installer?
 
Joined
Jul 20, 2014
Messages
816
Motherboard
Asus ProArt B550 Creator
CPU
Ryzen 9 5900X
Graphics
RX 6800 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Attention: none of the refreshed X299 boards (Cascade Lake X with up to 256 GB RAM and 48 PCIe-Lanes with 109xx-CPU´s) are working at the moment, and this concerns all refreshed boards from Asus, GB, Asrock, MSI.
I have tested with Asus Prime X299 A-II, MSI X299 Pro and Asus Prime X299 Edition 30, and there are a few more users with Asus A-II, Asrock Taichi CLX and MSI Creator X299. The new CPU´s (109xx) are fine, but there seems a big problem with the extended PCIe-lanes... I hope this is not the end of X299 for us.
Big news for me :(
What about These refresh motherboard with older 44 PCIe lanes CPU ?
Thanks
 
Joined
May 15, 2018
Messages
63
Motherboard
Asus X299 Deluxe
CPU
i9-7940X
Graphics
Vega 64
That'd be the reason the boot is slow. So, when you try to use SATA, does it install? Or just not show the disk as an option in the installer?
Ahh, that makes sense. I already have the operating system installed with Mojave (I used my laptop to update High Sierra to Mojave). When I have my system drive plugged into SATA on my Hackintosh, it shows up and will begin to boot, but then it will freeze along the way. But plugged into USB 2.0, it boots slowly but it all works.
 
Joined
Mar 29, 2011
Messages
857
Motherboard
ASRock X99 Extreme6
CPU
E5-2690 v4
Graphics
Radeon VII
If you post a screenshot of where it freezes, we can probably figure it out. An ioregexplorer export, from the system running off the USB, would also be helpful.
 
Joined
Feb 5, 2013
Messages
1,303
Motherboard
Gigabyte Z490 Vision D
CPU
i9-10850K
Graphics
6800 XT
Mac
  1. iMac
I've made a lot of progress. I've got Mojave up and running and no crashes, Thunderbolt working, ethernet working (though doesn't seem very smooth/responsive), and iMessages working. I copied @Loloflatsix's EFI folder for the Deluxe II (see below).

Why might booting be taking so long (about 2 minutes)? There's a video of verbose-mode booting here.

Also, I'm only booting up if my Mojave system disc is plugged into a USB 2.0 port. It won't boot if plugged into USB 3.0 or the Serial ATA connectors.

Don't load FakeSMC and VirtualSMC at the same time. Also true of HFSPlus.efi and VBoxHFS.efi. Pick one and go with it. Probably FakeSMC for Mojave.....I don't see any USB kexts of any type......you could start USBInjectAll.kext, and that will work for a time, but eventually you're going to need some type of USB kext......there are lots of good posts on this site on how to create your own USB kext for your motherboard.

Here's one that's not on this site, but it seems pretty good: https://www.travelertechie.com/2019/02/create-ssdt-to-fix-usb-rehabmans-way.html
 
Last edited:
Joined
May 15, 2018
Messages
63
Motherboard
Asus X299 Deluxe
CPU
i9-7940X
Graphics
Vega 64
If you post a screenshot of where it freezes, we can probably figure it out. An ioregexplorer export, from the system running off the USB, would also be helpful.

When I plug into the SATA bus, it gets frozen at "HID: Legacy Shim 2." I've read that it might just be that whatever is following it is getting stuck. Attached is a picture and also my IORegistryExplorer file. There's also a video of the verbose boot up (when plugged into a USB 2 slot) in my last post.

Don't load FakeSMC and VirtualSMC at the same time. Also true of HFSPlus.efi and VBoxHFS.efi. Pick one and go with it. Probably FakeSMC for Mojave.....I don't see any USB kexts of any type......you could start USBInjectAll.kext, and that will work for a time, but eventually you're going to need some type of USB kext......there are lots of good posts on this site on how to create your own USB kext for your motherboard.

Here's one that's not on this site, but it seems pretty good: https://www.travelertechie.com/2019/02/create-ssdt-to-fix-usb-rehabmans-way.html
Great to know. I took out the VirtualSMC Kect and the VBoxHFS.efi. I also tried replacing the USBInjectAll.kext (which had been in there) with the AsEvil-iMacPro-ASUS-PX299D2-XHCI.kext. KGP had posted a bunch of USB kexts and that one was there for my motherboard. I'll plan on making my own as you suggest.
 

Attachments

  • IMG_8334.jpeg
    IMG_8334.jpeg
    2.7 MB · Views: 42
  • IMG_8335.jpeg
    IMG_8335.jpeg
    2.5 MB · Views: 45
  • ioregistry.ioreg
    19.4 MB · Views: 49
Joined
Mar 29, 2011
Messages
857
Motherboard
ASRock X99 Extreme6
CPU
E5-2690 v4
Graphics
Radeon VII
Use ioregistryexplorer 2.1. I got a corrupted file error, and I think that's what happens with the newer versions.

USB 3 ports not working is pretty much expected - you're reaching the port limit. Why the SATA wouldn't work, though, I'm not sure.
 
Joined
Dec 31, 2013
Messages
731
Motherboard
Huawei Matebook D
CPU
i5-8250U
Graphics
UHD 620
Mobile Phone
  1. iOS
I have a question about what it would be the most elegant way to pass through USB 2.0 to the WiFI+Bluetooth native internal PCIe module for the Asus Sage that DOESN'T have any internal USB 2.0 header.

Both the USB 3.0 Type A and USB 3.1 Gen 2 Type C headers of the Sage are busy with the front I/O panel of the case, leaving the board without any other header.

To pass through cables from the external to the internal fo this purpose is pretty inelegant.

Another solution would be to add an USB 3.0 PCie card with internal header BUT the question is:
Once the internal bluetooth USB 2.0 module is connected to such card, would sleep work?

I searched the old KGP thread but didn't find how he actually used to connect bluetooth.
Any help is welcome, thanks!!
 
Joined
Apr 21, 2010
Messages
63
Motherboard
ASUS Prime X299-A
CPU
i9-7900X
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
  3. Mac Pro
Big news for me :(
What about These refresh motherboard with older 44 PCIe lanes CPU ?
Thanks
The problem is not to be caused by the refreshed CPU´s... they all work fine with the older boards (requirement: newest BIOS). The boards are the problem... let´s hope there is an expert who find a solution, otherwise it´s sadly the end of X299 as a custom Mac.
 
Top