Contribute
Register

Asus X299 - Support

Joined
Feb 5, 2013
Messages
1,272
Motherboard
Gigabyte Z490 Vision D
CPU
i9-10850K
Graphics
6800 XT
Mac
  1. iMac
When I was using an Asus X99 Prime, I had to reset my BIOS when adjusting the 4g Encoding. That was of course with a different CPU, though the same model of RAM. I think the BIOS is there, but I just can't see it because of the Graphics card issue. Might it be that changing the 4g encoding setting to Off doesn't work with my graphics card for some reason?

Well, not sure. I've had AMD graphics card for quite a while now, even with High Sierra, and I didn't hit any issues like that. So could it be your GTX 1060? Maybe, I just don't know. Your BIOS graphics needs are very basic, it doesn't need any special configuration, not usually. What if you were running Windows 10? Would you expect this to happen then? I just wouldn't think so.

And, btw, for Mojave and Catalina, you're going to need an AMD card of some sort - RX580s are pretty cheap right now......

Really, someone who has an Asus PD II should be your best bet to work with.....
 
Last edited:
Joined
Mar 29, 2011
Messages
855
Motherboard
ASRock X99 Extreme6
CPU
E5-2690 v4
Graphics
Radeon VII
Would you expect this to happen then? I just wouldn't think so.

Yeah, that's true. @garbage914, after you reset CMOS, flip that setting again and see if it happens again. That would confirm it's not because of a combination with some other BIOS setting that had been changed.
 
Joined
May 15, 2018
Messages
63
Motherboard
Asus X299 Deluxe
CPU
i9-7940X
Graphics
Vega 64
Yeah, that's true. @garbage914, after you reset CMOS, flip that setting again and see if it happens again. That would confirm it's not because of a combination with some other BIOS setting that had been changed.

I cleared the CMOS and got back to BIOS. When I turned Above 4G encoding off again (without altering any other BIOS setting), it went right back to the 8 beeps and wouldn't get to the BIOS. I found another forum where it sounds like some people have had that issue with the GTX 1060.

And, btw, for Mojave and Catalina, you're going to need an AMD card of some sort - RX580s are pretty cheap right now......

If I'm using my computer mainly for recording music (heavy sessions that max the CPU, and a 4k monitor) but also sometimes do video editing. I don't do gaming. From what I just read, the RX580 doesn't do well with 4k. Any other suggestions? Sounds like I should stay away from Nvidia and go AMD. Do the VEGA cards work well with Hackintosh? Or I see you guys have the Radeon VII? Will too powerful a graphics card get in the way of fast CPU processing in some way?
 
Joined
Mar 29, 2011
Messages
855
Motherboard
ASRock X99 Extreme6
CPU
E5-2690 v4
Graphics
Radeon VII
Ok sounds like it's from that graphics card then. Yeah it's good to switch over to AMD - it has to be done eventually. Maybe one of the Vega cards, but others might have suggestions for you too. (So far only my main machine has made the switch, and I just decided to max it out)
 
Joined
Jun 13, 2018
Messages
691
Motherboard
Prime X299-A II
CPU
i9 9980XE
Graphics
RX 6800 XT
Mac
  1. iMac
  2. MacBook Pro
Classic Mac
  1. iMac
  2. Power Mac
Mobile Phone
  1. Android
  2. iOS
I cleared the CMOS and got back to BIOS. When I turned Above 4G encoding off again (without altering any other BIOS setting), it went right back to the 8 beeps and wouldn't get to the BIOS. I found another forum where it sounds like some people have had that issue with the GTX 1060.



If I'm using my computer mainly for recording music (heavy sessions that max the CPU, and a 4k monitor) but also sometimes do video editing. I don't do gaming. From what I just read, the RX580 doesn't do well with 4k. Any other suggestions? Sounds like I should stay away from Nvidia and go AMD. Do the VEGA cards work well with Hackintosh? Or I see you guys have the Radeon VII? Will too powerful a graphics card get in the way of fast CPU processing in some way?

You'll be ok with Polaris (RX 570/580/590) Vega (Vega 56 / 64) Vega 2 (Radeon VII) Navi (RDNA) (RX 5500 and up). Basically every GPU with any of these chips will be fine, but AMD cards should be totally hassle free. IT depends on your needs, if you just need to drive your monitor for basic stuff go with Polaris or some cheap Navi (Catalina is required for Navi and Polaris is older technology so better supported but hotter and power hungry). Vega 56/64 or more expensive Navi cards are ok for pretty much everything, gaming QHD and video editing included. If you want the best of the best right now, go for Radeon VII which is the same GPU in the new Mac Pro (just a couple of compute unit less).

Hope this will help
 
Joined
Feb 5, 2013
Messages
1,272
Motherboard
Gigabyte Z490 Vision D
CPU
i9-10850K
Graphics
6800 XT
Mac
  1. iMac
I cleared the CMOS and got back to BIOS. When I turned Above 4G encoding off again (without altering any other BIOS setting), it went right back to the 8 beeps and wouldn't get to the BIOS. I found another forum where it sounds like some people have had that issue with the GTX 1060.



If I'm using my computer mainly for recording music (heavy sessions that max the CPU, and a 4k monitor) but also sometimes do video editing. I don't do gaming. From what I just read, the RX580 doesn't do well with 4k. Any other suggestions? Sounds like I should stay away from Nvidia and go AMD. Do the VEGA cards work well with Hackintosh? Or I see you guys have the Radeon VII? Will too powerful a graphics card get in the way of fast CPU processing in some way?

So, don't underestimate the RX 580, especially if you get a good one. I know of another Audio engineer on this board who used one with his Gigabyte X299 and he was happy with it. Don't know if he had a 4k monitor or not though. For Mojave a Vega 56/64 is a great choice and they work well with Catalina, and they both drive 4k monitors just fine. AMD 5700s only work in Catalina, so far as I can tell.....

I would not use a Radeon VII with your motherboard. Numerous users (including myself) have reported scratchy audio with it, and the Prime Deluxe I and II. One of the reasons I changed to a Sage was to get away from that issue. It's pretty well documented here in this forum so you'd have to do a search but you can find the posts about that issue if you look.
 
Joined
May 15, 2018
Messages
63
Motherboard
Asus X299 Deluxe
CPU
i9-7940X
Graphics
Vega 64
Thank you for all the ideas, everyone. And great to know about steering away from the Radeon VII with the Deluxe II. It sounds like the Vega makes the most sense for my uses. Is there a lot of difference between the different models of Vegas, or are they all pretty close in terms of build/features/specs/Hackintosh functionality? Does this model look ok to you guys?: Ebay Vega 56
 
Joined
Feb 5, 2013
Messages
1,272
Motherboard
Gigabyte Z490 Vision D
CPU
i9-10850K
Graphics
6800 XT
Mac
  1. iMac
Thank you for all the ideas, everyone. And great to know about steering away from the Radeon VII with the Deluxe II. It sounds like the Vega makes the most sense for my uses. Is there a lot of difference between the different models of Vegas, or are they all pretty close in terms of build/features/specs/Hackintosh functionality? Does this model look ok to you guys?: Ebay Vega 56

What you're looking at is called a blower card - it has one fan. I prefer non-blower cards from vendors like Sapphire, or Power Color. The most important thing if you're buying from e-Bay is to buy from a seller with lots of feedback and good ratings. No way for me to know how good this unit is or how responsible the seller is......trust is very very important when you buy from e-Bay.

If you have a few extra bucks, try a Sapphire Pulse 56 (it has better cooling).....and btw, you, as the buyer, should not have to pay for return shipping in case something goes wrong.....
 
Last edited:
Joined
Aug 4, 2011
Messages
309
Motherboard
ASUS WS Sage X299 / 10G
CPU
i9-10980XE
Graphics
Vega 64
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
If I'm using my computer mainly for recording music (heavy sessions that max the CPU, and a 4k monitor) but also sometimes do video editing. I don't do gaming. From what I just read, the RX580 doesn't do well with 4k. Any other suggestions? Sounds like I should stay away from Nvidia and go AMD. Do the VEGA cards work well with Hackintosh? Or I see you guys have the Radeon VII? Will too powerful a graphics card get in the way of fast CPU processing in some way?

I’m running a Vega 64 in my hack with dual LG 4K monitors at 60hz running smooth.

In Ableton, I have a project with 95 tracks all with plugin chains (nothing frozen or rendered) and it’s butter smooth....

Mind you .... I also have a 9900x 10 core processor and 128 gigs of RAM in this thing ... but it runs smooth- minus my Thunderbolt 3 woes :headbang:

Also, editing 4K/ 8K timelines with Prores 4444XQ multicam in Final Cut Pro is fine- that aspect has been flawless as well.
 
Joined
Sep 7, 2014
Messages
37
Motherboard
Asus X299 Deluxe
CPU
i9 7980XE
Graphics
2x VEGA FE
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. iOS
What's the difference between AGPMEnabler.kext and AGPMInjector.kext, or do they both provide the same solution? This are the kexts I have enabled for my Asus X299 Deluxe 7980XE on Mojave 10.14.6.
 

Attachments

  • Screen Shot 2020-01-16 at 12.11.38 AM.jpg
    Screen Shot 2020-01-16 at 12.11.38 AM.jpg
    87.7 KB · Views: 47
Top