Contribute
Register

ASUS X299 Monterey Support

Joined
Apr 18, 2011
Messages
1,298
Motherboard
ASUS Pro WS X299 Sage II
CPU
i9-10980XE
Graphics
Radeon Pro W5500
Mac
  1. MacBook Air
  2. Mac Pro
Mobile Phone
  1. iOS
Looks like OC 0.7.5 will support Resizable bar :) I'll probably release a BASE-EFI for that

Here is a Prerelease version (I have not tested this yet so YMMV)

Bootloader / Kexts:
  • WhateverGreen 1.5.5
  • AppleALC 1.6.6
 

Attachments

  • DJ7-OC075-BASEEFI-PreRelease.zip
    8.9 MB · Views: 8
Last edited:
Joined
Jul 4, 2021
Messages
13
Motherboard
ASUS Rampage VI Apex
CPU
i9-7960X
Graphics
AMD RX6900XT
Mobile Phone
  1. iOS
Hello big brother,me again,using your 0.7.5or 0.7.4,I stuck at "applenvme assert failed'',GOD save me(7960x+asus x299 R6A+6900xt),tried to replace cputsc to tscadjustreset,didn't work
 
Joined
Jul 4, 2021
Messages
13
Motherboard
ASUS Rampage VI Apex
CPU
i9-7960X
Graphics
AMD RX6900XT
Mobile Phone
  1. iOS
Glad to hrear that you are back again!!
 

Attachments

  • -v.jpg
    -v.jpg
    7.6 MB · Views: 5

Feartech

Moderator
Joined
Aug 3, 2013
Messages
23,695
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
my previous posts 0.7.3 can boot ,but usbmap lose,
 
Joined
Jul 4, 2021
Messages
13
Motherboard
ASUS Rampage VI Apex
CPU
i9-7960X
Graphics
AMD RX6900XT
Mobile Phone
  1. iOS
i had mapped,but didn't work now
 
Joined
Jul 4, 2021
Messages
13
Motherboard
ASUS Rampage VI Apex
CPU
i9-7960X
Graphics
AMD RX6900XT
Mobile Phone
  1. iOS
with out seeing your files, hard to help...
I turn off tpm2.0,my 0.7.3 efi and USBMap.kext work again, thank u! but 0.7.5still don't work, could you please help me?
 

Attachments

  • 归档.zip
    17.7 MB · Views: 4

Feartech

Moderator
Joined
Aug 3, 2013
Messages
23,695
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
I turn off tpm2.0,my 0.7.3 efi and USBMap.kext work again, thank u! but 0.7.5still don't work, could you please help me?
your 0.7.5 config.plist has:
Code:
<key>Arch</key>
                <string>x86_64</string>
                <key>BundlePath</key>
                <string>USBInjectAll.kext</string>
                <key>Comment</key>
                <string></string>
                <key>Enabled</key>
                <true/>
                <key>ExecutablePath</key>
                <string>Contents/MacOS/USBInjectAll</string>
                <key>MaxKernel</key>
                <string></string>
                <key>MinKernel</key>
                <string></string>
                <key>PlistPath</key>
                <string>Contents/Info.plist</string>

and your working 0.7.3 one has:
Code:
<dict>
                <key>Arch</key>
                <string>x86_64</string>
                <key>BundlePath</key>
                <string>USBMap.kext</string>
                <key>Comment</key>
                <string></string>
                <key>Enabled</key>
                <true/>
                <key>ExecutablePath</key>
                <string></string>
                <key>MaxKernel</key>
                <string></string>
                <key>MinKernel</key>
                <string></string>
                <key>PlistPath</key>
                <string>Contents/Info.plist</string>
            </dict>
 
Top