Contribute
Register

ASUS X299 Monterey Support

Joined
Apr 18, 2011
Messages
1,299
Motherboard
ASUS Pro WS X299 Sage II
CPU
i9-10980XE
Graphics
Radeon Pro W5500
Mac
  1. MacBook Air
  2. Mac Pro
Mobile Phone
  1. iOS
Introduction
The X299 Monterey Support thread is meant for support/discussion of ASUS X299 motherboards running on OpenCore. Since most user builds are on ASUS motherboards, other manufacturer systems (Gigabyte, MSI, ASRock, EVGA) may not receive as much support. Although this thread does not include a full guide, I have setup a github repo based on my personal build that ASUS users can use as a reference.


Guide
Github Files/Guide
  • ASUS X299 Hackintosh
    • ASUS BASE-EFI- Pre-built EFI using the MacPro7,1 SMBIOS that should be valid for all ASUS X299 motherboards. It is built using my personal build as a baseline with the OpenCanopy GUI. NOTE: Some config settings are different than the Skylake-X section of the Dortania OpenCore Vanilla Guide to be compatible with ASUS motherboards.
      • Recommended BIOS Settings
      • config.plist Configuration
      • Post-Install
    • Custom BIOS Collection - Modified BIOS .CAP files that have custom boot logos and/or other modifications.
    • Personal Build - Information about personal build using the ASUS Pro WS X299 Sage II
    • Thunderbolt - Information about configuring Thunderbolt 3/4 for macOS
    • USB Kexts - Mapped motherboard USB kexts
    • GUIDE: Intel 10 Gigabit NICs with Small Tree macOS Drivers
Personal Build
Personal build running on macOS Monterey. More info located here
aboutthismac.png


What Works
  • Sleep / Wake
  • Wifi and Bluetooth
  • Handoff, Continuity, AirDrop, Continuity Camera, Universal Control, and Unlock with Apple Watch
  • iMessage, FaceTime, App Store, iTunes Store
  • 2.5G Ethernet
  • 10G Ethernet
  • HEVC, H.264
  • Onboard audio
  • TRIM
  • USB 2.0
  • USB 3.2 Gen 1
  • USB 3.2 Gen 2
  • DRM
  • Native NVRAM
  • CPU Power Management
  • USB Power
  • Thunderbolt 3/4 hot-plug
What Doesn't Work
  • SideCar
    • Due to some T2 chip dependancies on MacPro7,1 and iMacPro1,1 SMBIOS
Extras
 

Attachments

  • DJ7-OC074-BASEEFI.zip
    10.1 MB · Views: 17
Last edited:
Joined
Apr 18, 2011
Messages
1,299
Motherboard
ASUS Pro WS X299 Sage II
CPU
i9-10980XE
Graphics
Radeon Pro W5500
Mac
  1. MacBook Air
  2. Mac Pro
Mobile Phone
  1. iOS
Changelog
2021.10.13 - Added BASE-EFI for OpenCore 0.7.4.
2021.09.08 - Added BASE-EFI for OpenCore 0.7.3.
2021.08.02 - Added BASE-EFI for OpenCore 0.7.2
2021.07.05 - Added BASE-EFI for OpenCore 0.7.1
2021.07.01 - Initial post for macOS Monterey Public Beta 1 Support.
 
Last edited:
Joined
Jun 10, 2021
Messages
174
Motherboard
Gigabyte Z490 Vision D
CPU
i7-10700K
Graphics
RX6800XT
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Very nice. This Public Bet 1 worked on my Z370 but refuses to install on my B560-F. It does the reboot a few times and goes to a dead screen after 3rd reboot.
 
Joined
Jan 29, 2011
Messages
97
Motherboard
Asus WS X299 Sage 10G
CPU
i9-7980XE
Graphics
RX 580
Mac
  1. Mac mini
Mobile Phone
  1. iOS
I installed Monterey by way of the Apple upgrade. It was far from perfect, perhaps because I was using OC 067. The main issues were startup times, huge delay before getting to the Monterey GUI. And then a further lag waiting for the desktop icons to load.Seemed like a memory issue but I didn't have time to troubleshoot I went back to Big Sur. I suspected that the Titan Ridge Tb card may have been the problem but it requires time to sort out. I will get to it when I have more time and I can 'enjoy' spending all night tearing my hair out :crazy:
 
Joined
Apr 18, 2011
Messages
1,299
Motherboard
ASUS Pro WS X299 Sage II
CPU
i9-10980XE
Graphics
Radeon Pro W5500
Mac
  1. MacBook Air
  2. Mac Pro
Mobile Phone
  1. iOS
I installed Monterey by way of the Apple upgrade. It was far from perfect, perhaps because I was using OC 067. The main issues were startup times, huge delay before getting to the Monterey GUI. And then a further lag waiting for the desktop icons to load.Seemed like a memory issue but I didn't have time to troubleshoot I went back to Big Sur. I suspected that the Titan Ridge Tb card may have been the problem but it requires time to sort out. I will get to it when I have more time and I can 'enjoy' spending all night tearing my hair out :crazy:

Hmm bootup times are normal for me although the first beta was about 2-3 mins. Surprised they released the first pb this earlier since it's usually after the 3rd one.
 
Joined
Jan 29, 2011
Messages
97
Motherboard
Asus WS X299 Sage 10G
CPU
i9-7980XE
Graphics
RX 580
Mac
  1. Mac mini
Mobile Phone
  1. iOS
Hmm bootup times are normal for me although the first beta was about 2-3 mins. Surprised they released the first pb this earlier since it's usually after the 3rd one.
I think I had CpuTscSync.kext added and also I didn't use the argument -lilubetaall. I was also on 0.6.7. If you've had success I will try again at some point for sure.
 
Joined
Apr 18, 2011
Messages
1,299
Motherboard
ASUS Pro WS X299 Sage II
CPU
i9-10980XE
Graphics
Radeon Pro W5500
Mac
  1. MacBook Air
  2. Mac Pro
Mobile Phone
  1. iOS
I think I had CpuTscSync.kext added and also I didn't use the argument -lilubetaall. I was also on 0.6.7. If you've had success I will try again at some point for sure.

I'd recommended switching to TSCAdjustReset (adjusted for amount of cores) and 0.7.1 Dev or release on Monday
 
Joined
Jul 4, 2021
Messages
13
Motherboard
ASUS Rampage VI Apex
CPU
i9-7960X
Graphics
AMD RX6900XT
Mobile Phone
  1. iOS
Hello! My pc=7960x+ Asus r6a +6900 XT, BIOS 3404 replaced with Apple icon, BIOS set as guide except above 4g disabled. I have trouble installing 11.4 with your Asus X299 base EFI. I had replaced cputscsync to tscadjustreset, and fill the SMBIOS, but it always stuck at ’pci configuration begin’, even if add’ncpi=0x2000. When I enabled above 4g, stuck at “APFS module start”
 
Joined
Feb 26, 2011
Messages
126
Motherboard
ASUS PRIME X299-A II
CPU
i9 10940X
Graphics
AMD RX 560 | Nvidia RTX 3070
Mac
  1. MacBook
  2. MacBook Pro
Mobile Phone
  1. iOS
Nice one @djlild7hina i wondered when we’d start the next X299 thread. :)

Sadly (or excitingly) my X299 is currently on board a container ship making its way towards Australia so I’ll be out of action for a couple of months until it arrives, but I’ll be following along with interest until then anyway.
 
Joined
Jun 13, 2018
Messages
696
Motherboard
Prime X299-A II
CPU
i9 9980XE
Graphics
RX 6800 XT
Mac
  1. iMac
  2. MacBook Pro
Classic Mac
  1. iMac
  2. Power Mac
Mobile Phone
  1. Android
  2. iOS
Nice one @djlild7hina i wondered when we’d start the next X299 thread. :)

Sadly (or excitingly) my X299 is currently on board a container ship making its way towards Australia so I’ll be out of action for a couple of months until it arrives, but I’ll be following along with interest until then anyway.
Hello, how would you judge your X299-A II? I've the first model and it served me well, now I could swap it for the new one like yours for like 50€ or less. Is it good? have you mapped your USBs? Issues?
 
Top