Contribute
Register

Asus X299 - Catalina Support

Joined
Feb 24, 2013
Messages
2,456
Motherboard
ASUS WS X299 SAGE/10G
CPU
i9-9980XE
Graphics
Radeon VII
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hey guys, any tips on the Mac Pro 7,1 SMBIOS? I think I have it mostly configured, curious about any fixes for the memory module error or PCI slot GUI in About this Mac.

Try this for memory error.
 

Attachments

  • MacProMemoryNotificationDisabler.kext.zip
    18.2 KB · Views: 92
Joined
Jul 13, 2019
Messages
16
Motherboard
Asrock X299E-ITX/ac
CPU
i9-10980XE
Graphics
AMD VEGA VII
Mac
  1. iMac
Mobile Phone
  1. iOS
i9 10900X
Gigabyte x299 Extreme 3 Pro
DDR4 64GB
VEGA 64 8GB
RX 5700 XT 8GB (test)
macOS 10.15.2
 

Attachments

  • Screen Shot 2020-01-16 at 21.49.10.png
    Screen Shot 2020-01-16 at 21.49.10.png
    2 MB · Views: 194
  • Screen Shot 2020-01-16 at 21.52.24.png
    Screen Shot 2020-01-16 at 21.52.24.png
    391.6 KB · Views: 208
  • Screen Shot 2020-01-16 at 22.03.28.png
    Screen Shot 2020-01-16 at 22.03.28.png
    778.9 KB · Views: 178
Joined
Jul 24, 2010
Messages
19
Motherboard
Asus Prime X299-A II
CPU
i9-10920x
Graphics
RX 5700 XT
Mac
  1. Mac Pro
i9 10900X
Gigabyte x299 Extreme 3 Pro
DDR4 64GB
VEGA 64 8GB
RX 5700 XT 8GB (test)
macOS 10.15.2
Any chance you can share your EFI? I have a very similar setup. Thank you!
 
Joined
Jan 20, 2011
Messages
93
Motherboard
Asus X299 TUF Mark 1
CPU
i7-7800X
Graphics
NITRO+ RX 590 8G G5 SE
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
  4. Mac Pro
Classic Mac
  1. iMac
Mobile Phone
  1. Android
  2. iOS
Try this for memory error.
Awesome, this worked for me. Any idea how to get the Memory and PCI cosmetics in "About This Mac" right?
 
Joined
Feb 24, 2013
Messages
2,456
Motherboard
ASUS WS X299 SAGE/10G
CPU
i9-9980XE
Graphics
Radeon VII
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Joined
Nov 25, 2014
Messages
15
Motherboard
MSI Z170
CPU
i5-6600K
Graphics
GTX 970
Mac
  1. iMac
I have
Delar i dator
Corsair Obsidian 750D (Svart/Transparent)
Intel Core i9 7900X 3,3GHz
Asus Prime X299-A
Plus Radeon vega 64 8gb
EVGA SuperNOVA G2 1000W
32 gb ddr4 ram. 250 Gb ssd
Watercool
And my try end with filé in attach. Then i must force reboot
Any idea.
 

Attachments

  • IMG_20200119_152917.jpg
    IMG_20200119_152917.jpg
    2.5 MB · Views: 66
  • IMG_20200119_152857.jpg
    IMG_20200119_152857.jpg
    3.5 MB · Views: 69
Joined
Aug 2, 2011
Messages
27
Motherboard
I still didn't read
CPU
the RULES
Graphics
so ignore me
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
I have the same problem whit the memory RAM on SMBIOS 7.1..!! Any ideas???
 
Joined
Jan 28, 2010
Messages
223
Motherboard
ASUS X99-E WS
CPU
E5-2697 V3
Graphics
GTX 760
I have a weird OC/Turbo issue that I am curious if anyone else has. I'm on 2002 on a SAGE/10G with a 10980XE, and if I manually specificy Sync All Cores to any value other than Auto then the boot proceeds at about 1/20th normal speed and has graphic distortion at desktop and frozen.

If I change back to Auto on Sync All Cores, then I'm fine again. Anyone else have this issue and have a workaround so I can still overclock to 4.2 or 4.3?

I've tried different methods of TSCSync, removed it entirely, removed XCPM plugin from config.plist, used the XCPM from SSDT instead, and tried OpenCore (which had the same exact symptom).

I can only assume there is a stock SSDT that is causing this issue and perhaps I can drop it, but not sure which one to drop.
 
Top