Contribute
Register

Asus X299 - Catalina Support

Joined
Dec 31, 2012
Messages
555
Motherboard
Asus Sage 10/G X299
CPU
i9-9980XE
Graphics
GTX 680
Mac
iMac, Mac mini
Mobile Phone
iOS
Strange network issue when using istats menu with Catalina....if i enable net menu while with Mojave and previous osx rel i had the right download or upload speed shown, with Catalina download speed (ex 200MB) is not shown correctly...but always max 120kb. Anyone has tried?
 
Joined
Mar 28, 2011
Messages
218
Motherboard
Asus Tuf X299 Mark 1
CPU
i9-7900X
Graphics
RX 5700 XT
Mobile Phone
iOS
You could try the following, open your .plist with CC, go to graphics and enable "Inject ATI", save and close CC, open your .plist with Xcode or PlistEditor Pro and instead of removing the "Inject ATI", select NO, (should be on YES)... Save your .plist and give it a try.

For some reason Clover seems to load the Inject ATI by default, and setting it to NO has made the trick for me. Give it a try.
I have reviewed and made a test, using xcode, without weg and with inject ati in YES and NO,

It didn't work in any of the ways, I don't know if I'm doing something wrong
 
Joined
Mar 18, 2017
Messages
579
Motherboard
Asus Prime X299 Deluxe
CPU
i9-7940X
Graphics
2x Vega 56
Mac
iMac, Mac mini
Mobile Phone
iOS
I use Clover 5100, but I'm still with FakeSMC. I tried not to use WEG but I got a black screen.

Will it be to use FakeSMC? or to use SMBIOS iMacPro1,1? I use DisplayPort.
Here is a screenshot from my EFI Folder :
- In drivers64UEFI : SMCHelper.efi
- In kexts/Other/ : VirtualSMC.kext , VegaGraphicsFixup.kext (No WEG.kext)

Capture d’écran 2019-12-13 à 18.43.24.png
 
Joined
Mar 28, 2011
Messages
218
Motherboard
Asus Tuf X299 Mark 1
CPU
i9-7900X
Graphics
RX 5700 XT
Mobile Phone
iOS
Here is a screenshot from my EFI Folder :
- In drivers64UEFI : SMCHelper.efi
- In kexts/Other/ : VirtualSMC.kext , VegaGraphicsFixup.kext (No WEG.kext)

View attachment 440297
Hello @Loloflatsix , the USBs work now.
I just did a test. I have returned to the BIOS 1503 of ASUS. I have put WEG 1.3.5 and now it works. Before version 1.3.5 did not work.

In Graphics do you use Inject ATI?

What is eficheckdisabler.kext? Speed up the load?

In the photos I show you what I use.

With VirtualSMC, see temps 5700 XT?

Very thanks.
 

Attachments

Joined
Mar 18, 2017
Messages
579
Motherboard
Asus Prime X299 Deluxe
CPU
i9-7940X
Graphics
2x Vega 56
Mac
iMac, Mac mini
Mobile Phone
iOS
Hello @Loloflatsix , the usbs work now,
I just did a test, I have returned to the bios 1503 of asus and I have put weg 1.3.5 and now it works, before version 1.3.5 did not work.

in graphics do you use inject ati?

what is eficheckdisabler.kext? speed up the load?

in the photos I show you what I use.

With virtualsmc see temps 5700xt?

very thanks
In Graphics No Inject :

Capture d’écran 2019-12-13 à 19.12.43.png



eficheckdisabler.kext : just to prevent MacOs to check EFI Folder and return errors.

You can try if with virtualsmc, you can see temps for 5700xt according you have the sensors.kext.
 
Joined
Apr 18, 2011
Messages
499
Motherboard
ASUS WS X299 SAGE/10G
CPU
i9-10980XE
Graphics
RX 5700 XT
Mac
MacBook Pro
Mobile Phone
iOS
No, I tried the DTPG ssdt and some known for X299 but nothing works..
I would assume for the Designare 10G Thunderbolt would be under PCIO.RP05. Do you have a copy of your IOReg?
Aside from Thunderbolt, does everything work on the 10G board? Seems like a decent alternative to the Sage
 
Joined
Feb 25, 2013
Messages
20
Motherboard
Asus X299 Prime Deluxe
CPU
i9 7940X
Graphics
RX Vega 64
Mac
MacBook Air, Mac Pro
Mobile Phone
Android, iOS
Hi everyone. Does anyone has a fix for this?:( .
Screen Shot 2019-12-15 at 10.24.14 PM.png
Screen Shot 2019-12-15 at 10.39.43 PM.png
Screen Shot 2019-12-14 at 1.51.40 PM.png
 
Joined
Mar 18, 2017
Messages
579
Motherboard
Asus Prime X299 Deluxe
CPU
i9-7940X
Graphics
2x Vega 56
Mac
iMac, Mac mini
Mobile Phone
iOS
Last edited:
Joined
Feb 25, 2013
Messages
20
Motherboard
Asus X299 Prime Deluxe
CPU
i9 7940X
Graphics
RX Vega 64
Mac
MacBook Air, Mac Pro
Mobile Phone
Android, iOS
Not yet, if you set your memory to 2667 MHz maximum, you have no warning if you configure above 2667 MHz, you have warnings, tested with:
- Corsair Vegeance LPX 2666 MHz running at 2667 MHz
- Corsair Vegeance LPX 3000 MHz
- Corsair Dominator Platinum 3600 MHz


3000 MHz
Thanks. I’m using G.SKILL TridentZ RGB Series 64GB 288-Pin DDR4 SDRAM DDR4 3200 Memory if helps.
 
Last edited:
Top