Contribute
Register

Asus X299 - Catalina Support

Joined
Feb 5, 2013
Messages
1,092
Motherboard
Asus X299 WS Sage
CPU
i9-7980XE
Graphics
Radeon VII
Mac
iMac, Mac Pro
So, Beta 2 of 10.15.1 is out, and for me, and some other users, there's an issue with Whatevergreen. The solution is: don't use it, meaning delete it from you Clover or Opencore EFI (or just zip it up, and then it won't be used). My system works just fine without it, but can't say how that will affect others.....

This is just the nature of beta software.....there are glitches in the road sometimes....
 
Joined
Feb 24, 2013
Messages
2,252
Motherboard
ASUS WS X299 SAGE/10G
CPU
i9-9980XE
Graphics
Radeon VII
Mac
MacBook Pro
Mobile Phone
iOS
So, Beta 2 of 10.15.1 is out, and for me, and some other users, there's an issue with Whatevergreen. The solution is: don't use it, meaning delete it from you Clover or Opencore EFI (or just zip it up, and then it won't be used). My system works just fine without it, but can't say how that will affect others.....

This is just the nature of beta software.....there are glitches in the road sometimes....
Try
Code:
agdpmod=pikera
as boot arg for WEG.
 
Joined
Feb 24, 2013
Messages
2,252
Motherboard
ASUS WS X299 SAGE/10G
CPU
i9-9980XE
Graphics
Radeon VII
Mac
MacBook Pro
Mobile Phone
iOS
Also apparently Radeon VII has improvements and now the MHz is read correctly and score in Luxmark is above 49k.

[not my image]

Screenshot_2019-10-18_at_6.png
 
Joined
Feb 5, 2013
Messages
1,092
Motherboard
Asus X299 WS Sage
CPU
i9-7980XE
Graphics
Radeon VII
Mac
iMac, Mac Pro
Try
Code:
agdpmod=pikera
as boot arg for WEG.
Thanks, but I already tried that, didn't work. Other users have tried that too, and it didn't work for them either. But, it's good you posted it, because it's possible it might work for others....

As I stated before, my system on beta 2 of 10.15.1, and no WEG, works just fine. No issues so far. If I don't need to load WEG, that's good.....we'll see.....it's a beta, after all....
 
Last edited:
Joined
Dec 31, 2012
Messages
552
Motherboard
Asus Sage 10/G X299
CPU
i9-9980XE
Graphics
GTX 680
Mac
iMac, Mac mini
Mobile Phone
iOS
Hi! I've had a new crash today (Yes! Another one..), and I want to share it with you to see if someone is having the same issue.

Maybe is a coincidence, but I have the "Automatic" change to dark mode, and I was working with Music app (on Clear mode) and the system crashed. After the crash, i reset the computer (force reset) and after start it, it was in dark mode.

I guess (not 100% sure) it happened the same yesterday at more or less the same time. Is someone having the same issue?
I'm on BIOS 1201, and I'm experiencing same problems....at random PC freezes with Catalina and Windows 10. I'm trying to restore 0905 BIOS but I don't know if it's a BIOS related problem. Let's try new 2002..
 
Joined
Jan 18, 2012
Messages
107
Motherboard
Asus WS x299 Sage/10G
CPU
i9 9980XE
Graphics
Radeon VII
Mac
MacBook Air
Mobile Phone
iOS
I'm on BIOS 1201, and I'm experiencing same problems....at random PC freezes with Catalina and Windows 10. I'm trying to restore 0905 BIOS but I don't know if it's a BIOS related problem. Let's try new 2002..
I tried 1201 and 0905 and it freezed on both. After macOS Catalina update, it froze again and without doing anything. It's working well for the last 5-6 days. So don't know exactly what's happening. :(
 
Joined
Feb 5, 2013
Messages
1,092
Motherboard
Asus X299 WS Sage
CPU
i9-7980XE
Graphics
Radeon VII
Mac
iMac, Mac Pro
I tried 1201 and 0905 and it freezed on both. After macOS Catalina update, it froze again and without doing anything. It's working well for the last 5-6 days. So don't know exactly what's happening. :(
Over the weekend, for my Sage, I tried the firmware 2002 (again, that firmware is just for my Sage CEB). So, while 1201 has been okay, 2002 was not good. Now, my Sage is slightly different from yours.

If you upgrade to 2002, I would be very interested to see if yours is better after the change of bios firmware.

I am on Beta 2 of 10.15.1, so that might make a difference. Should be interesting to see if yours is better on 2002.
 
Last edited:
Joined
Jan 18, 2012
Messages
107
Motherboard
Asus WS x299 Sage/10G
CPU
i9 9980XE
Graphics
Radeon VII
Mac
MacBook Air
Mobile Phone
iOS
Over the weekend, for my Sage, I tried the firmware 2002 (again, that firmware is just for my Sage CEB). So, while 1201 has been okay, 2002 was not good. Now, my Sage is slightly different from yours.

If you upgrade to 2002, I would be very interested to see if yours is better after the change of bios firmware.

I am on Beta 2 of 10.15.1, so that might make a difference. Should be interesting to see if yours is better on 2002.
Mine is working well with 1201 now with final version of Catalina (with latest update). But as soon as I have time I will test new 2002 version and will tell you about it. ;)
 
Top