Contribute
Register

Asus - UX430UA - Kaby Lake i7-7500U Intel HD Graphics 620

Joined
Apr 21, 2012
Messages
269
Motherboard
Asus UX430UA (Clover)
CPU
i7-7500U
Graphics
HD 620
Mac
iMac, MacBook Air, MacBook Pro
Mobile Phone
iOS
Hello everyone, thank you gulios for the post, it helped me a lot, however I have a little problem. The sound works at home I have AppleALC.kext Lilu.kext (ID: 14/ALC295), I installed ALCPlugFIx but when I plug in a jack I have some very small crackles, and unfortunately the sound no longer works, I have to sleep to put it back on the speakers.

Thank you!
Read this https://github.com/insanelydeepak/cloverHDA-for-Mac-OS-Sierra-10.12/issues/51

You have to have https://github.com/insanelydeepak/cloverHDA-for-Mac-OS-Sierra-10.12/blob/master/Laptop/ALC295_v2 Asus UX430UA.zip
installed as daemon to fix crackling sound.

or
https://github.com/hieplpvip/ASUS-ZENBOOK-HACKINTOSH/blob/master/src/alcplugfix/alc295/install.sh

After that my sound works fine.
If you still have a problems, maybe create issue for @InsanelyDeepak on github
 
Joined
Jan 16, 2019
Messages
1
Motherboard
Asus UX430UA
CPU
i7-7500U
Graphics
HD 620
Please, First of all thank you so much for your post ... I'm wondering if we have to buy the "Broadcom BCM94352Z M.2 NGFF 802.11AC 867Mbps BT 4.0 DW1560" or we don't have to ...
Hi,
After almost 3 months of searching, reading, fixing etc my Asus ZenBook works great :headbang:
CPU, SSD M.2 and WIFI is native supported in new High Sierra.
PM works great(battery around 7hours in normal usage).
Generally i can say that it's perfect model for hackintosh laptop nowdays ;)

Model: Asus UX430UA
OS: 10.14.2
Clover: 4813
FileSystem: APFS
SMBIOS: MacBookPro14,1
BIOS: 305
Wifi: replaced to "Broadcom BCM94352Z M.2 NGFF 802.11AC 867Mbps BT 4.0 DW1560 for Mac Hackintosh"
CPU: Kaby Lake i7-7500U
GPU: Intel HD Graphics 620
Display: 14`
RAM: 8GB 2133MHz DDR4
HDD: 512GB SATA3 M.2 SSD
More info https://www.asus.com/Laptops/ASUS-ZenBook-UX430UA/Tech-Specs/

Benchmarks:
CPU: https://browser.geekbench.com/v4/cpu/3590954
Compute: https://browser.geekbench.com/v4/compute/981634

So far so good, laptop works like a charm :cool:

working:
- wifi 2,4/5Ghz
- BlueTooth 4.0
- eth USB 10/100/1000 LAN
- USB2/3/C works fine - generate custom SSDT for USBInjectAll.kext
- AirDrop
- GPU/CPU full acceleration(used ssdtPRGen.sh for PM) - "Intel HD Graphics 620 1536 MB"
- all sensors, cpu, gpu, fans without any problems(average temperature 35-39' in normal usage)
- m.2 Sandisk, trim(turned off with APFS)
- USB-C/3/2
- battery, cycle count etc, battery life ~7h with regular use and ~2,5h with external display 4K video
- sleep/wake (on charger and battery)
- brightness, slider, auto change level(battery/charger) 16 levels
- FN keys, keyboard backlight 3 levels AsusNBFnKeys.kext + AsusFnKeysDaemon for FN+F1 (sleep), FN+F2 (airplane mode)
FN+F1 go sleep
FN+F2 airplane mode
FN+F3/4 keyboard backlight
FN+F5/6 display brightness
FN+F7 display off
FN+F8 switch displays
FN+F9 turn off trackpad
FN+F10, 11/12 mute, volume level
https://github.com/hieplpvip/AsusFnKeys
- HDMI external display(4K) on micro hdmi(NvidiaGraphicsFixup.kext)
- HDMI audio
- audio(speakers, microphone, headphones) - AppleALC.kext Lilu.kext inject id = 14 ALC295 + ALCPlugFix @InsanelyDeepak
- Chime startup sound - "Carillon-AppleALC-Version"
- imessage, facetime, hand-off
https://www.tonymacx86.com/threads/an-idiots-guide-to-imessage.196827/
- camera USB2.0 HD UVC WebCam
- card reader(in system pref "This computer doesn't contain any Apple Internal Memory Card Readers." but in USB "Flash Card Reader/Writer") so it works as regular pendrive
- touchpad horizontal/vertical scrolling, 3 fingers(mission control etc), zoom, notifications, swipe full screen etc - ELAN 1200
https://github.com/hieplpvip/VoodooI2C
- fingerprint sensor ELAN:Fingerprint - device is recognised in Sytem Info but now port HS09 is disabled (in new BIOS disabled option)

not working:
- fingerprint sensor and never will. Disabled in BIOS.

TODO:
- ALS sensor - works with https://github.com/acidanthera/VirtualSMC + SMCLightSensor.kext - testing

Very useful links(must read):
RehabMan guides:
https://www.tonymacx86.com/threads/readme-common-some-unsolved-problems-in-10-12-sierra.202316/
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
https://www.tonymacx86.com/threads/guide-patching-laptop-dsdt-ssdts.152573/
https://www.tonymacx86.com/threads/guide-patching-dsdt-ssdt-for-laptop-backlight-control.152659/
https://www.tonymacx86.com/threads/guide-native-power-management-for-laptops.175801/
https://www.tonymacx86.com/threads/guide-laptop-backlight-control-using-applebacklightinjector-kext.218222/

Other(must read)
https://www.tonymacx86.com/threads/installing-sierra-on-asus-zenbook-ux410ua.223811/
https://www.tonymacx86.com/threads/guide-asus-zenbook-ux310uak-macos-sierra-installation-guide.224591/
https://www.tonymacx86.com/threads/solved-bcm94352z-ux430ua-sierra-10-12-6-wifi-not-working.227506/page-3#post-1547302
https://www.tonymacx86.com/threads/asus-ux430ua-external-display-hdmi-not-working.227721/
https://www.tonymacx86.com/threads/wip-voodooi2c-i2c-trackpad-limited-support.204227
https://www.tonymacx86.com/threads/asus-ux430ua-kaby-lake-hd-620-hdmi-audio-not-working.228018/
https://www.tonymacx86.com/threads/asus-ux430ua-alc295-audio-headphones-crackling.228992/
https://www.tonymacx86.com/threads/asus-ux430ua-keyboard-backlighting.226619/page-2
https://www.tonymacx86.com/threads/an-idiots-guide-to-imessage.196827/
https://www.tonymacx86.com/threads/wip-voodooi2c-i2c-trackpad-limited-support.204227/page-80#post-1571791
https://www.tonymacx86.com/threads/asus-ux430ua-fingerprint-trackpad-touch-id.230671/
https://github.com/insanelydeepak/cloverHDA-for-Mac-OS-Sierra-10.12/issues/51

Useful stuff:
https://github.com/vit9696/AppleALC
https://github.com/RehabMan/Laptop-DSDT-Patch
https://github.com/KernCheh/UX303LA/tree/master/EFI kexts/Asus DSDT patches
https://www.tonymacx86.com/threads/wip-voodooi2c-i2c-trackpad-limited-support.204227/
https://github.com/acidanthera/VirtualSMC

The best (as i know) example for Asus Zenbooks
https://github.com/hieplpvip/ASUS-ZENBOOK-UX410-DSDT-PATCH

Useful apps:
Clover -> https://sourceforge.net/projects/cloverefiboot/
Clover Configurator -> http://mackie100projects.altervista.org/download-clover-configurator/
MaciASL -> https://bitbucket.org/RehabMan/os-x-maciasl-patchmatic/downloads/
DPCIManager -> https://sourceforge.net/projects/dpcimanager/
IORegistryExplorer -> https://www.tonymacx86.com/threads/guide-how-to-make-a-copy-of-ioreg.58368/
patchmatic -> https://bitbucket.org/RehabMan/os-x-maciasl-patchmatic/downloads/
debug tool -> https://www.tonymacx86.com/threads/tool-generate-proper-problem-reporting-files.235953/

Brightness Slider(if you have a problems with fn keys) -> https://itunes.apple.com/pl/app/brightness-slider/id456624497?mt=12
First of all thank you so much for your post ...
I'm wondering if we have to buy the "Broadcom BCM94352Z M.2 NGFF 802.11AC 867Mbps BT 4.0 DW1560" or we don't have to ...
 
Joined
Apr 21, 2012
Messages
269
Motherboard
Asus UX430UA (Clover)
CPU
i7-7500U
Graphics
HD 620
Mac
iMac, MacBook Air, MacBook Pro
Mobile Phone
iOS
Please, First of all thank you so much for your post ... I'm wondering if we have to buy the "Broadcom BCM94352Z M.2 NGFF 802.11AC 867Mbps BT 4.0 DW1560" or we don't have to ...


First of all thank you so much for your post ...
I'm wondering if we have to buy the "Broadcom BCM94352Z M.2 NGFF 802.11AC 867Mbps BT 4.0 DW1560" or we don't have to ...
If you want wifi working, then yes
Off course you can use Eth via usb without wifi, but it's laptop so...
 
Joined
Jan 26, 2011
Messages
115
Motherboard
MSI Z68A-GD80
CPU
i7-2600K
Graphics
GTX 1060
Mobile Phone
Android
Did you do anything special to get through the installer? I'm trying this on a UX461UA. Not the same hardware but possibly some similarities.

I can get to the installer just fine but keyboard, trackpad, UHD and 620 graphics acceleration are not working. I can use a USB mouse to get through the installer. A few minutes in, the laptop instantly restarted - no countdown or anything. I rebooted into the partition (now on the SSD), and I've been stuck at a black screen that says "less than a minute remaining" for over 15 minutes.


It was actually trying to restart itself but since it wasn't working properly it just got stuck at that screen. Was able to get to the desktop but of course with no QE/CI and keyboard & trackpad support. Will work on getting those to work.
 
Last edited:
Top