Contribute
Register

Asus TUF H370 Pro Gaming | i5 8400 | UHD630 Graphics | 10.15.3 | Install and Setup

Joined
Jul 29, 2012
Messages
5
Motherboard
Asus TUF H370 Pro Gaming
CPU
Intel i5 8400
Graphics
HIS RX580
Mac
iMac
Classic Mac
iBook
Mobile Phone
Android
I've been in and out of the hackintosh community for a while and i wanted to share some details on my current setup incase anyone had the same hardware and was getting a little lost.

I don't know what 100% defines a "Gold" build but i have to say, my current setup, everything works like it should as if it was a real mac.

First of the hardware details:
CPU: i5 8400
GPU: Intel 630 UHD Graphics
MB: Asus TUF H370 Pro Gaming (i know there's a wifi model but mines the one without)
RAM: 16GB Corsair Vengeance
SSD: Kingston 240GB

I'm not going to share images of all the bios settings but I'm just using the normal bios settings for any UEFI hackintosh build, nothing special.

1. Disable CSM
2. Disable Secure Boot
3. Set OS Type to Other OS
4. Set SATA as AHCI
5. Disable CFG Lock
6. Disable VT-D
7. Enable XHCI Hand-off

Only thing i had to make sure i changed was to use a "read only RTC" otherwise you will run into issues booting

Booting the Install USB:
Nothing fancy, using a install USB made on my MBP, and setup with a copy of the latest clover, i was able to boot to the USB and load the 10.15.3 install with no fancy boot args, i always boot with -v when I'm setting up to make sure there's no issues but there isn't anything major.

From there just install macOS onto your SSD or hard drive and reboot. Boot back into your install USB and then load the new install of 10.15.3. Once you go though basic setup, out of the box most things will work, be it with no GPU acceleration because of incorrect system definition etc. If you use my attached EFI it will already have all the correct kext's and system definition set correctly and you can just drop that into your EFI partition on your SSD or hard drive.

From there make sure you use clover configurator to generate a new SN and Board ID so you can get icloud and other apple services working correctly.

In the provided EFI, note the audio is set up to inject the correct id for the AppleALC kext to work with the ALC887 audio codec, System is set to iMac18,1.

If you guys have any questions let me know and ill do my best to answer them.

Note i am adding a RX580 to the system in a few days but pretty much everything is staying the same in terms of setup and config.
 

Attachments

Joined
Apr 15, 2020
Messages
4
Motherboard
Asus Tuf H370 Pro Gaming
CPU
Intel I5 8400
Graphics
RX 580
Hello my friend! thank you so much for sharing your work
I have exactly the same configuration
I have everything working except USB 3.0 and 3.1

help me

Thank you
 
Joined
Jun 30, 2020
Messages
2
Motherboard
TUF H370-PRO GAMING
CPU
Intel Core i5 8400 Coffee Lake
Graphics
HD 630
Mobile Phone
Android
Hello,
I have the same your pc, using your EFI folder and showing error, pls help me...
Thank you.
I'm using SSD Samsung 970 EVO Plus PCIe NVMe V-NAND M.2
 

Attachments

Top