Contribute
Register

Asus Rog Zephyrus M GM501 Issues

Joined
Apr 4, 2022
Messages
1
Motherboard
ASUS ROG GM501GS - 317 - Clover UEFI
CPU
Intel Core i7 8750H
Graphics
HD 630 1920 x 1080
Hey, I recently turned an Asus Rog Zephyrus M GM501GS into a Clover hackintosh MacOS Mojave machine. I was lucky enough to find a github repo (https://github.com/danikpanik/Asus_Zephyrus_M_GM501GS_Monterey) where someone with my exact laptop (with the exception that they changed their WiFi chip and added 16GB of RAM) made their Clover EFI public. I use the D-Link DWA121 N150 WiFi USB adapter with the WirelessAdapterCloverBigSur driver. After installing Clover and adding my own SMBIOS everything worked fine except three things:
  • Some USB devices
  • The speakers work, but not the audio jack
  • Hibernation
I got the USB problem fixed by removing some drivers that no longer worked with Monterey, and got my USB WiFi device working as well.

I still have no clue why the audio jack isn't working but it's not very important to me, but i think i know why the laptop wakes up from hibernation after a few seconds. I found this guide (https://github.com/dortania/clover-...power-management/correcting-sleep-problems.md) to Clover hibernation fixing on github, and after testing out some of the diagnosing from the guide I found that I have the 'Wake on XHCI' issue. The guide then says I need a patch, but I don't know/understand how to actually patch Clover. I just want to know how to actually apply the patch so I can finally hibernate my laptop and use it wherever I go. I don't take offense (and would probably appreciate) if you explain it to me like I'm five, or just point me in the right direction :). Any help with the audio jack issue would also be appreciated.

I also have some small problems with the touchpad where it randomly stops working for a minute, but I usually have a USB mouse connected, so it isn't a problem as much as confusing.
 

Attachments

  • EFI.zip
    28.8 MB · Views: 40
Last edited:
Top