Contribute
Register

ASUS ROG STRIX Z390-I Gaming Motherboard specs

Joined
Jan 4, 2019
Messages
17
Boot with the usb and set it to boot from the hard drive on the boot menu. Once in mount the usb and hd efi, copy the efi from the usb to the efi on the hd. Remove the usb afterwards.
So copy only the EFI folder to the HD? Sorry if this is dumb this is my very first hackintosh/PC build.
 
Joined
Jan 27, 2019
Messages
5
Motherboard
Asus Rog Strix Z390-I
CPU
i9-9900K
Graphics
RX 580
So copy only the EFI folder to the HD? Sorry if this is dumb this is my very first hackintosh/PC build.
You need to mount the HD efi folder and then copy the efi folder from the usb to it.

I used this to mount both efi drives:
 

soh

Joined
Feb 15, 2019
Messages
4
Motherboard
ASUS ROG STRIX Z390-F GAMING
CPU
i7 9700K
Graphics
Vega 56
Hi!

I'm using Hackintosh with this setup.

MB: ASUS ROG Strix Z390-F Gaming
CPU: Intel Core i7 9700K
GPU: ASUS DUAL-RX580-O8G

It can be booted, however, only sleep is not functional.

When the display connected to HDMI Port on RX580 with 4K60Hz, it shows nothing (display cannot recognise the Hackintosh) after computer sleeps and wakes.

Do you have any ideas?

(Sorry for my bad English)
 
Joined
Jan 10, 2019
Messages
23
Motherboard
ASUS ROG Strix Z390-I Gaming
CPU
i9-9900K
Graphics
Vega 64
Hey guys, I got some question,

How did you guys get through the installation?
I followed this guide:


But I got stuck after I boot into the installer. The Apple logo will appear. Then, after the loading bar gets to 60%, it will change from the Apple logo to error symbol instead. What should I do?

thx
 
Joined
Aug 31, 2018
Messages
1,413
Motherboard
Asus ROG Strix Z390 I-Gaming
CPU
i7-8700K
Graphics
Vega 64
Mac
MacBook
Classic Mac
512K, iMac
Mobile Phone
iOS
I want to be able to download or have Time Machine run backups during sleep. What dark mode should I use? I found a list of settings but no explanation as to what each does. I got these from this post but summarized here for easy reference:

Darkwake modes available in Clover configurator:

Code:
darkwake=0 -
darkwake=1 HIDTickleEarly
darkwake=2 HIDTickleLate
darkwake=3 HIDTickleNone
darkwake=4 IgnoreDiskIOInDark
darkwake=8 IgnoreDiskIOAlways
darkwake=10 HIDTickleLate | IgnoreDiskIOAlways

Other modes:

darkwake=5 HIDTickleEarly | IgnoreDiskIOInDark
darkwake=6 HIDTickleLate | IgnoreDiskIOInDark
darkwake=7 HIDTickleNone | IgnoreDiskIOInDark
darkwake=9 HIDTickleEarly | IgnoreDiskIOAlways
darkwake=11 HIDTickleNone | IgnoreDiskIOAlways
darkwake=12 * IgnoreDiskIOInDark | IgnoreDiskIOAlways
darkwake=13 * HIDTickleEarly | IgnoreDiskIOInDark | IgnoreDiskIOAlways
darkwake=14 * HIDTickleLate | IgnoreDiskIOInDark | IgnoreDiskIOAlways
darkwake=15 * HIDTickleNone | IgnoreDiskIOInDark | IgnoreDiskIOAlways
* Likely not valid
Thanks!

Edit: I figured out my USB issue so I shortened the post to reflect the remaining issue.
 
Last edited:
Joined
Feb 18, 2019
Messages
1
Motherboard
ASUS ROG Strix Z390-I
CPU
I9-9900K
Graphics
RTX 2080 Ti
I'm an ASUS motherboard fan boy, but I hear very good things about the Gigabyte. You really don't have to do much; it's pretty automated.

I would recommend getting a used Dell DW1560 WiFi card on Amazon to replace the one on the motherboard. The Intel one that comes with the motherboard isn't compatible. On the ASUS motherboard it was an easy and perfect fit. There are plenty of new Chinese ones available but I preferred to go with known used one and not wait 3 weeks to get it. I paid half what they are asking now so look around.

The only issue I initially had was that after the install was complete, Clover would not install on the SSD for some reason. I needed to do a manual install, and it was pretty much clear sailing from there. I had a few minor issues but the forum was great, especially @pastrychef and a few others.

If you get the ASUS feel free to ping me for help. In fact I wouldn't mind doing a Golden Build post a la @pastrychef so we could validate the install steps.

Edit: The only intricate part was getting continuity and messaging to work. Lot's of steps but it worked.
Hey Guys,

Thanks for all the great info.

Is it possible to install this WiFi card if both M.2 slots already have drives in them?

Also, was anyone able to get Sleep/Shutdown/Reboot working properly? I don't know where to start with this.
 
Last edited:
Joined
Aug 31, 2018
Messages
1,413
Motherboard
Asus ROG Strix Z390 I-Gaming
CPU
i7-8700K
Graphics
Vega 64
Mac
MacBook
Classic Mac
512K, iMac
Mobile Phone
iOS
Here's my SSDT for USB, put it in EFI/Clover/ACPI/patched, which will limit USB ports within 15 ports.
Notice: Due to 15 ports limits, one of the Front USB Port can only read USB3.0.
@dmdacc Just finished going through the SSDT and it was perfect, nice work. Everything is working great but I have a few last questions on USB.

1) Do we still need the following entries in the DSDT:

388286


2) How do I get USB 3.1 to work? Do I need an additional kext such as XHCI-unsupported.kext for the 300 series controller or is USBInjectAll.kext all I need?

Thanks!
 
Last edited:
Joined
Apr 30, 2018
Messages
42
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K
Graphics
RX 5700 XT
Mac
iMac
Classic Mac
iMac
Mobile Phone
iOS
@dmdacc Just finished going through the SSDT and it was perfect, nice work. Everything is working great but I have a few last questions on USB.

1) Do we still need the following entries in the DSDT:

View attachment 388286

2) How do I get USB 3.1 to work? Do I need an additional kext such as XHCI-unsupported.kext for the 300 series controller or is USBInjectAll.kext all I need?

Thanks!
I keep XHC name changing in DSDT, and you need add SS02 to SSDT to make USB 3.1 work.
 
Joined
Aug 31, 2018
Messages
1,413
Motherboard
Asus ROG Strix Z390 I-Gaming
CPU
i7-8700K
Graphics
Vega 64
Mac
MacBook
Classic Mac
512K, iMac
Mobile Phone
iOS
I keep XHC name changing in DSDT, and you need add SS02 to SSDT to make USB 3.1 work.
Seeing as we are at the 15 port limit, it means I need to sacrifice something else correct? Isn't there a kext that gets rid of the 15 port limit?
 
Top