Contribute
Register

ASUS ROG STRIX Z390-I Gaming Motherboard specs

Joined
Jan 4, 2019
Messages
17
I didn't because everything wasn't ironed out. But, if you get the ASUS, I will write the post, and you can validate the steps. I will write each one out, and you can validate them as you go along.
@ModMike just ordered the CPU, should have everything for my build by end of next week by the latest.
 
Last edited by a moderator:
Joined
Jan 4, 2019
Messages
17
Just got everything in. Was able to boot to BIOS. Now just need help with installing Mojave.
 
Joined
Jan 20, 2019
Messages
1
Motherboard
Asus Z390-I Gaming
CPU
I7 9700k
Graphics
Rtx 2070
Hey guys , looking for a success. I've got...
ASUS Z390 I Gaming motherboard
Intel i9-9900K CPU
EVGA RTX 2060 XC Ultra (I know drivers are not out yet)
If anyone can help this is my first build.
 
Last edited:
Joined
Jan 4, 2019
Messages
17
Hey guys , looking for a success. I've got...
ASUS Z390 I Gaming motherboard
Intel i99-900K CPU
EVGA RTX 2060 XC Ultra (I know drivers are not out yet)
If anyone can help this is my first build.
Likewise except cheaper CPU and gonna use internal graphics.
 
Joined
Jan 31, 2019
Messages
4
Motherboard
Asus ROG Z390-I Gaming
CPU
i7-9700K
Graphics
RX 580
Mac
MacBook Pro, Mac Pro
Mobile Phone
iOS
Hi, I'm also really hoping for this golden build guide.
I'm an ASUS motherboard fan boy, but I hear very good things about the Gigabyte. You really don't have to do much; it's pretty automated.

I would recommend getting a used Dell DW1560 WiFi card on Amazon to replace the one on the motherboard. The Intel one that comes with the motherboard isn't compatible. On the ASUS motherboard it was an easy and perfect fit. There are plenty of new Chinese ones available but I preferred to go with known used one and not wait 3 weeks to get it. I paid half what they are asking now so look around.

The only issue I initially had was that after the install was complete, Clover would not install on the SSD for some reason. I needed to do a manual install, and it was pretty much clear sailing from there. I had a few minor issues but the forum was great, especially @pastrychef and a few others.

If you get the ASUS feel free to ping me for help. In fact I wouldn't mind doing a Golden Build post a la @pastrychef so we could validate the install steps.

Edit: The only intricate part was getting continuity and messaging to work. Lot's of steps but it worked.
My Hardware is:
  • ASUS ROG Strix z390-I Gaming
  • i7-9700k
  • Samsung Evo 970 500 GB
  • Saphire + RX 580
I followed the original Install OSX 10.14 Guide so far, got stuck in Step 4.8
"8. Upon completion, the system will automatically restart."

Got into these Problems so far:
- Install Mojave freezes at 2 min left
-> fixed deleting the AptioMemoryFix-64.efi
- Install Mojave crashed while rebooting the 2nd time
-> fixed placing Lilu.kext and WhateverGreen.kext in the EFI/CLOVER/kext/other

With that fixed i can go a step further by choosing different Boot options in Clover:

- Clover shows me 5 Options at the moment i can boot to:
1. "External" Boot macOS from Install macOS Mojave -> brings me back to step 4.4
2. "APFS" Boot FileVault Prebooter from Preboot -> gets stuck at Apple Logo and about 60% loaded bar
3. "APFS" Boot macOS Install Prebooter from Preboot -> striked through circle
4. "APFS" Boot macOS from Mojave -> gets stuck at Apple Logo and 75% loaded bar
5. "Recovery" Boot Recovery from Recovery -> brings me back to Step 4.4 (but now i even have a 6th option)
-> 6. "APFS" Boot macOS Install from Mojave -> gets stuck on Apple Logo and 60% loaded bar

- My Memory is Corsair Vengance DDR4 3000Mhz but in Bios it shows as DDR4 2150Mhz
-> I can manually change this, but i haven't noticed any difference...


Things I also tryed:
  • Installing from 64GB or 16 GB USB stick
  • some different Bios Settings
  • Creating a Install macOS drive with UniBeast 9.1.0 and the settings from above
so, if you have any Idea of what I am doing wrong or what i should try next pls reply.

Or if you have the same / similar Hardware and got it working and are really awesome post some guide what you did in order t get it working


Thanks in advance
 
Last edited:
Joined
Jan 31, 2019
Messages
4
Motherboard
Asus ROG Z390-I Gaming
CPU
i7-9700K
Graphics
RX 580
Mac
MacBook Pro, Mac Pro
Mobile Phone
iOS
Sorry I was in Houston for a week, just got back. Do you still need help?
So glad to hear from you, yes please! i’m still stuck on the posted problem.
Meanwhile i got Win 10 running of the second ssd, but that’s only for games...

can you post yor efi folder and bios settings that worked for you?
 
Joined
Aug 31, 2018
Messages
1,413
Motherboard
Asus ROG Strix Z390 I-Gaming
CPU
i7-8700K
Graphics
Vega 64
Mac
MacBook
Classic Mac
512K, iMac
Mobile Phone
iOS
I followed Pastry Chefs guide for Bios and pretty much everything else:

.

I believe that was the exact same issue I had. I could not get the full install to work with Unibeast. The install would complete but the machine would freeze at the apple when booting. I later figured out that Unibeast was not installing to the EFI partition so I booted with usb into clover, and manually installed clover to the EFI partition using the clover installer. I can't exactly remember how I did it, but that was what I had to do.

I'm not sure if I can post the link but do a search for Clover EFI and it will bring you their Sourceforge page. Download the latest version. I was already banned once for linking to Amazon so if I do not answer for a few days I may have been banned :)
 
Last edited:
Top