Contribute
Register

ASUS ROG STRIX Z390-I Gaming Motherboard specs

Joined
Sep 21, 2018
Messages
191
Motherboard
ASUS WS X299 Sage 10G
CPU
i9-9980XE
Graphics
RX 5700 XT
Mac
MacBook Pro
Mobile Phone
iOS
You are using the Z390-I?

I'm very surprised Wi-Fi is working for you. This is great news.

Try fixing your USB using this guide. Once USB is fixed, Bluetooth should work.
Just followed the guide, and it seems like the only file that resembles the one in the guide is called `SSDT-4-xh_cfsd4.aml`. It looks very different than the example. I've attached it, if it helps I can also attach the entire folder.
 

Attachments

Joined
Sep 21, 2018
Messages
191
Motherboard
ASUS WS X299 Sage 10G
CPU
i9-9980XE
Graphics
RX 5700 XT
Mac
MacBook Pro
Mobile Phone
iOS
Ok I was able to get Bluetooth working with FacePCIID + Mux + USBInjectAll! I'll compile a patch soon to enable only the ports I need and removing the usb limit patch.
 
Joined
Sep 21, 2018
Messages
191
Motherboard
ASUS WS X299 Sage 10G
CPU
i9-9980XE
Graphics
RX 5700 XT
Mac
MacBook Pro
Mobile Phone
iOS
Here is the patched SSDT-4 that enables all the usb ports in the back + the usb3 front header + bluetooth.

Now the only thing left that doesn't work is Audio, for some reason AppleALC isn't working properly with the S1220A.
 

Attachments

pastrychef

Moderator
Joined
May 29, 2013
Messages
15,102
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
Here is the patched SSDT-4 that enables all the usb ports in the back + the usb3 front header + bluetooth.

Now the only thing left that doesn't work is Audio, for some reason AppleALC isn't working properly with the S1220A.
Did you test the USB 3.1 gen 2?
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
15,102
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
I haven't yet, need to find a device that supports it :D
You can test with any USB device to see if it's at least functional.
 
Joined
Sep 21, 2018
Messages
191
Motherboard
ASUS WS X299 Sage 10G
CPU
i9-9980XE
Graphics
RX 5700 XT
Mac
MacBook Pro
Mobile Phone
iOS
You can test with any USB device to see if it's at least functional.
I did test every port with a usb2 device, it shows up and it's fully working.
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
15,102
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
I did test every port with a usb2 device, it shows up and it's fully working.
Wow! That's awesome! So the only things left to work out are shutdown/restart and whether or not USB 3.1 gen 2 works at full speed. I was very surprised the M.2 for Wi-Fi worked. There were reports from B360 (I think) users who could not get the to work with non-CNVi Wi-Fi cards.
 
Joined
Sep 21, 2018
Messages
191
Motherboard
ASUS WS X299 Sage 10G
CPU
i9-9980XE
Graphics
RX 5700 XT
Mac
MacBook Pro
Mobile Phone
iOS
Wow! That's awesome! So the only things left to work out are shutdown/restart and whether or not USB 3.1 gen 2 works at full speed. I was very surprised the M.2 for Wi-Fi worked. There were reports from B360 (I think) users who could not get the to work with non-CNVi Wi-Fi cards.
Yep, and the audio. Which I can't get to work.
re:wifi/bt I also have a AW-CB160H/BCM94360HMB coming today, which it fits the enclosure perfectly so I can reattach the i/o enclosure.

In ioreg, nothing shows up under HDEF, only the displayport/igpu one.
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
15,102
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
Yep, and the audio. Which I can't get to work.
re:wifi/bt I also have a AW-CB160H/BCM94360HMB coming today, which it fits the enclosure perfectly so I can reattach the i/o enclosure.

In ioreg, nothing shows up under HDEF, only the displayport/igpu one.
How are you going to connect the half mini PCI to M.2?

Looking at the spec page on the Asus site, this motherboard uses Realtek S1220A which is the same as what I have on my motherboard. It should work fine. Look for HDAS in IORegistryExplorer. Use AppleALC (along with Lilu) to get it working. Audio-id 1, 2, or 3 should work. I use 2.
 
Top