Contribute
Register

ASUS ROG STRIX Z390-I Gaming Motherboard specs

Joined
Aug 31, 2018
Messages
1,414
Motherboard
Asus ROG Strix Z390 I-Gaming
CPU
i7-8700K
Graphics
Vega 64
Mac
MacBook
Classic Mac
512K, iMac
Mobile Phone
iOS
So I am at what I hope to be the last stage, Installing Windows 10. Unfortunately it fails. I was wondering if someone can look at post#5 and give me some tips.

Thanks!

Solved: Delete partition while in windows setup.
 
Last edited:
Joined
May 9, 2010
Messages
219
Motherboard
ASUS Prime Z390-A
CPU
i5-9600K
Graphics
Vega 56
Mobile Phone
Android
Are you doing anything with WEG - WhatEverGreen kext? Understand it's helpful for IGPU.
Hi, sorry for the very late reply (more about this later). I've tried using the WEG kext (which has just been updated) but, although I can get a picture using the iGPU on my motherboard, graphics acceleration doesn't work under macOS (my UHD 630 shows up as a generic 14MB display adapter).

I tried following this guide on framebuffer patching by headkaze: using an ig-platform-id of 0x3E9B0007, and trying out various device-ids for my UHD 630, but with no luck. I've also been following another thread about UHD 630 graphics which, unfortunately, ended with no resolution.
...sorry for the very late reply (more about this later).
[Off-topic] Regarding this, I had a spare SSD, so decided to install Ubuntu Linux on it. If you have an extra SSD (and enjoy tinkering), I can recommend trying out Ubuntu (or a Linux distro) on it. I also found a useful boot manager called rEFInd, that installs under Ubuntu.

With regards to Hackintoshing, you can set up rEFInd to boot your Windows, Ubuntu or macOS/Hackintosh drive on startup, just like Clover (its macOS option piggybacks off Clover). It also remembers your last selected boot volume next time you startup.

It can be installed under Windows, but I don't know how easy it is to do this. It's fairly easy to get up & running (with a comprehensive user-guide on its web site). I'm currently using a theme I've customised - based on this one (see attached pic). And it's been working well for me.
 

Attachments

Last edited:
Joined
Dec 16, 2014
Messages
324
Motherboard
ASUS TUF Z390M-PRO Gaming
CPU
i5-9600K
Graphics
RX 580
Mac
MacBook Pro, Mac mini, Mac Pro
Classic Mac
Power Mac
Mobile Phone
iOS
Joined
Dec 16, 2014
Messages
324
Motherboard
ASUS TUF Z390M-PRO Gaming
CPU
i5-9600K
Graphics
RX 580
Mac
MacBook Pro, Mac mini, Mac Pro
Classic Mac
Power Mac
Mobile Phone
iOS
With regards to Hackintoshing, you can set up rEFInd to boot your Windows, Ubuntu or macOS/Hackintosh drive on startup
Yes, Ubuntu comes in handy for things like retrieving an audio codec dump .... part of an ongoing project with toleda to unravel the mysteries of the Realtek S1200A codec - the one you spotted as being a problem on my Z390M-PRO board.

Speaking of Ub...., is it really necessary to use Terminal to install a (browser) update. Can't believe it's that difficult.
 
Joined
Nov 5, 2018
Messages
9
Motherboard
Asus STRIX Z390-I GAMING
CPU
Intel I5-9600K
Graphics
Intel UHD630
@ModMike, may I ask that which side USB port you use to install.
I use the front USB port to install, it stuck at the Apple logo after I chose install macOS.

update: I use verbose mode and find out it stuck after 'end randomsedd ++++++++++++'.
My step to create USB boot device:
1.use UniBeast to create USB boot device;
2.replace the EFI folder with @dmdacc 's EFI;
My UniBeast version is 9.0.0 and I use macOS 10.14.2 dmg to install.
Is there any ideas about it?

--------------------------------------------------
Update: after I switched my memory from b1 to a1, I finally installed Mojave into my hard drive.
But when I step by step to complete the installation I found my keyboard did not work.
I use a USB keyboard and a USB wireless mouse any of you know about it.
Thank you!
 
Last edited:
Joined
Apr 30, 2018
Messages
36
Motherboard
Asus Z390-i
CPU
i9-9900K
Graphics
RX 580
Mac
iMac
Mobile Phone
iOS
@ModMike, may I ask that which side USB port you use to install.
I use the front USB port to install, it stuck at the Apple logo after I chose install macOS.

update: I use verbose mode and find out it stuck after 'end randomsedd ++++++++++++'.
My step to create usb boot device:
1.use UniBeast to create usb boot device;
2.replace the EFI folder with @dmdacc 's EFI;
My UniBeast version is 9.0.0 and I use mac os 10.14.2 dmg to install.
Is there any ideas about it?

--------------------------------------------------
Update: after i switch my memory from b1 to a1, i finally installed mojave into my hard drive.
But when I step by step to complete the installation I found my keyboard did not work.
I use a USB keyboard and a usb wireless mouse any of you know about it.
Thank you!
Try usb 2.0 port
 
Joined
Nov 5, 2018
Messages
9
Motherboard
Asus STRIX Z390-I GAMING
CPU
Intel I5-9600K
Graphics
Intel UHD630
Try usb 2.0 port
I finally find out it’s my keyboard(ducky zero) firmware need to be upgrade to work with mac.
Now it works.

And there is another problem I’m using igpu, i find when i open launchpad, the animation seems to be very slow. (I had change machine name to 18.1)

Thank you!
 
Last edited:
Joined
Apr 30, 2018
Messages
36
Motherboard
Asus Z390-i
CPU
i9-9900K
Graphics
RX 580
Mac
iMac
Mobile Phone
iOS
I finally find out it’s my keyboard(ducky zero) firmware need to be upgrade to work with mac.
Now it works.

And there is another problem I’m using igpu, i find when i open launchpad, the animation seems to be very slow. (I had change machine name to 18.1)

Thank you!
Try set
  • Advanced/System Agent (SA) Configuration/Graphics Configuration/DVMT Pre-Allocated - 512M or 1024M
 
Joined
Nov 5, 2018
Messages
9
Motherboard
Asus STRIX Z390-I GAMING
CPU
Intel I5-9600K
Graphics
Intel UHD630
Try set
  • Advanced/System Agent (SA) Configuration/Graphics Configuration/DVMT Pre-Allocated - 512M or 1024M
It does not work.
My VRAM is still 14MB.
 
Top