Contribute
Register

ASUS PRIME Z690-P D4 LGA Motherboard I9 12900K Asus AMD Radeon 6900XT MacOS12.1 Monterey install and support thread

Joined
Dec 28, 2021
Messages
25
Motherboard
Asus Z690 Prime P D4
CPU
i9-12900K
Graphics
RX 6900 XT
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
  4. Mac Pro
Classic Mac
  1. iMac
Mobile Phone
  1. Android
Hi Everyone This thread is for Troubleshooting the ASUS PRIME Z690-P D4 motherboard with the 12th Generation Intel CPUs
 
Joined
May 11, 2011
Messages
2,319
Motherboard
Gigabyte B550 Vision D
CPU
Ryzen 5900X
Graphics
RX 6800
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
  6. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
@joshuame149, it's great that you've set this page up.

For anyone who is interested, I have attached the EFI for my build of this board using OC 0.7.4 and external AMD dGPU (just add your own UUID and board system serial and ROM serials). For BIOS settings:

Firmware version: 0407 or later

Main > XMP Profile 1 > Enabled
Advanced > Software Guard Xtentions (SGX) > Disabled
Advanced > Active Cores > All
Advanced > Hyperthreading > Enabled
Advanced settings > System Agent > Graphics Configuration > Primary Display > PCIe
Advanced > System Agent Configuration > VT-d > Disabled (may need to be enabled for Windows)
Above 4G Decoding > Enabled
Re-sizeable bar > Enabled
Graphics Configuration > DVMT Pre-allocated > 1024M
USB Configuration > Legacy USB > Enabled
XHCI-Handoff > Enabled
Boot > CSM > Launch CSM > Disabled
Secure Boot > OS Type > Other OS
Boot Configuration > Fast Boot > Disabled
CFG Lock > Disable
Power Management > PEG ASPM > Enabled
PCH ASPM > Disabled
DMI ASPM > Enabled
S3 > Enabled
ErP > Disabled
PTT > Enabled

It is recommended to boot from either the M.2 sockets, SATA or USB using the F8 key.
 

Attachments

  • EFI copy.zip
    18.9 MB · Views: 238
Joined
Dec 28, 2021
Messages
25
Motherboard
Asus Z690 Prime P D4
CPU
i9-12900K
Graphics
RX 6900 XT
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
  4. Mac Pro
Classic Mac
  1. iMac
Mobile Phone
  1. Android
@joshuame149, it's great that you've set this page up.

For anyone who is interested, I have attached the EFI for my build of this board using OC 0.7.4 and external AMD dGPU (just add your own UUID and board system serial and ROM serials). For BIOS settings:

Firmware version: 0407 or later

Main > XMP Profile 1 > Enabled
Advanced > Software Guard Xtentions (SGX) > Disabled
Advanced > Active Cores > All
Advanced > Hyperthreading > Enabled
Advanced settings > System Agent > Graphics Configuration > Primary Display > PCIe
Advanced > System Agent Configuration > VT-d > Disabled (may need to be enabled for Windows)
Above 4G Decoding > Enabled
Re-sizeable bar > Enabled
Graphics Configuration > DVMT Pre-allocated > 1024M
USB Configuration > Legacy USB > Enabled
XHCI-Handoff > Enabled
Boot > CSM > Launch CSM > Disabled
Secure Boot > OS Type > Other OS
Boot Configuration > Fast Boot > Disabled
CFG Lock > Disable
Power Management > PEG ASPM > Enabled
PCH ASPM > Disabled
DMI ASPM > Enabled
S3 > Enabled
ErP > Disabled
PTT > Enabled

It is recommended to boot from either the M.2 sockets, SATA or USB using the F8 key.
So Just For me off the bat, the EFI file you provided does not work with my system, doesn't boot and give me a bunch of OC and apple verbose errors after I put -v and My Boards BIOS Settings does not have SGX, GFG Lock and maybe a few others latter ones. I currently cannot get into the computer so I'm retracing my steps. One issue I had when I did get it running was that I could not view my connected Sata drives, I've learned alot about opencore but am still having issue pinpointing the exact problem and area. I've tried a bunch of different configurations to no avail and did save the one closest to the one I was at when I lost access. Can you suggest anything?
 
Joined
May 11, 2011
Messages
2,319
Motherboard
Gigabyte B550 Vision D
CPU
Ryzen 5900X
Graphics
RX 6800
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
  6. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
So Just For me off the bat, the EFI file you provided does not work with my system, doesn't boot and give me a bunch of OC and apple verbose errors after I put -v and My Boards BIOS Settings does not have SGX, GFG Lock and maybe a few others latter ones. I currently cannot get into the computer so I'm retracing my steps. One issue I had when I did get it running was that I could not view my connected Sata drives, I've learned alot about opencore but am still having issue pinpointing the exact problem and area. I've tried a bunch of different configurations to no avail and did save the one closest to the one I was at when I lost access. Can you suggest anything?
First to use the EFI you need to add your own UUID and serial numbers into the EFI. Secondly the setting is called CFG Lock not GFG Lock. It is usually found under the boot config section and is a vital setting. For the serials if you've already generated a set you must use the same UUID and serials you had from your previous booting EFI otherwise it may not boot. Either that or you may need to generate a new set and possibly reinstall your macOS installation.

If your current EFI config is not booting I'd suggest to use my EFI and re-update it to say OC 0.7.6 from scratch and use each required version of OCValidate to check. That way should help eliminate most of the problems.

As to the SATA issue if it is not working you may need to add SATA-unsupported.kext into your EFI/OC/Kexts folder.
 
Joined
Dec 28, 2021
Messages
25
Motherboard
Asus Z690 Prime P D4
CPU
i9-12900K
Graphics
RX 6900 XT
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
  4. Mac Pro
Classic Mac
  1. iMac
Mobile Phone
  1. Android
First to use the EFI you need to add your own UUID and serial numbers into the EFI. Secondly the setting is called CFG Lock not GFG Lock. It is usually found under the boot config section and is a vital setting. For the serials if you've already generated a set you must use the same UUID and serials you had from your previous booting EFI otherwise it may not boot. Either that or you may need to generate a new set and possibly reinstall your macOS installation.

If your current EFI config is not booting I'd suggest to use my EFI and re-update it to say OC 0.7.6 from scratch and use each required version of OCValidate to check. That way should help eliminate most of the problems.

As to the SATA issue if it is not working you may need to add SATA-unsupported.kext into your EFI/OC/Kexts folder.
Is AppleXPMCFGLock what you are talking about? we should make a list that separates Bios Configs vs Open Core Config Settings to make this easier for people who try to make this motherboard setup
 

Attachments

  • Screen Shot 2022-01-20 at 9.27.18 AM.png
    Screen Shot 2022-01-20 at 9.27.18 AM.png
    1.4 MB · Views: 122
  • Screen Shot 2022-01-20 at 9.27.54 AM.png
    Screen Shot 2022-01-20 at 9.27.54 AM.png
    918.2 KB · Views: 123
Joined
May 11, 2011
Messages
2,319
Motherboard
Gigabyte B550 Vision D
CPU
Ryzen 5900X
Graphics
RX 6800
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
  6. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
Is AppleXPMCFGLock what you are talking about? we should make a list that separates Bios Configs vs Open Core Config Settings to make this easier for people who try to make this motherboard setup
No, but it is related. A lot of the newer motherboards have an option called CFG Lock in the BIOS which needs to be disabled for Opencore to work. For those without them the AppleXPMCFGLock needs to be enabled in Opencore.
 
Joined
Dec 28, 2021
Messages
25
Motherboard
Asus Z690 Prime P D4
CPU
i9-12900K
Graphics
RX 6900 XT
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
  4. Mac Pro
Classic Mac
  1. iMac
Mobile Phone
  1. Android
No, but it is related. A lot of the newer motherboards have an option called CFG Lock in the BIOS which needs to be disabled for Opencore to work. For those without them the AppleXPMCFGLock needs to be enabled in Opencore.
So Ive Finally Remade A working Asus Z690 Prime p d4 with MacOS 12.1 EFI file i originally had no internet but regained it by enabling DisableLOmapper in the Kernal in Opencore configurator, I still have no USB-C or internal Sata support with the sata-unsupported.kext installed and enabled. im sure there are other issues to fix but will upload benchmarks and efi file here. let me know if you have any other ideas to get the system more stable
 

Attachments

  • EFI working 1:23:22.zip
    16.7 MB · Views: 153
  • Mac Pro.ioreg
    6.2 MB · Views: 52
  • Screen Shot 2022-01-24 at 7.59.16 PM.png
    Screen Shot 2022-01-24 at 7.59.16 PM.png
    137.8 KB · Views: 171
  • Screen Shot 2022-01-24 at 7.58.43 PM.png
    Screen Shot 2022-01-24 at 7.58.43 PM.png
    136.9 KB · Views: 129
  • Screen Shot 2022-01-24 at 8.00.42 PM.png
    Screen Shot 2022-01-24 at 8.00.42 PM.png
    139.5 KB · Views: 158
  • Screen Shot 2022-01-24 at 7.57.46 PM.png
    Screen Shot 2022-01-24 at 7.57.46 PM.png
    72.5 KB · Views: 168
Joined
May 11, 2011
Messages
2,319
Motherboard
Gigabyte B550 Vision D
CPU
Ryzen 5900X
Graphics
RX 6800
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
  6. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
So Ive Finally Remade A working Asus Z690 Prime p d4 with MacOS 12.1 EFI file i originally had no internet but regained it by enabling DisableLOmapper in the Kernal in Opencore configurator, I still have no USB-C or internal Sata support with the sata-unsupported.kext installed and enabled. im sure there are other issues to fix but will upload benchmarks and efi file here. let me know if you have any other ideas to get the system more stable
Alright! Good going. :thumbup: With regards to the USB, have you mapped your USB ports at all? If you haven't done already you can try using Corpnewt's USB mapping tool here. You will need to have both USB 2 & USB 3 devices attached to all the ports to create a map. >https://github.com/corpnewt/USBMap

As for the USB-C, are you referring to the extra Thunderbolt ports on the rear of the board? If you want to enable those you must have a Thunderbolt 4 ACPI driver enabled (plus the Maple Ridge card installed) plus TB function enabled in BIOS. I haven't enabled it on mine yet despite SSDT-TB3 installed in the EFI - that's because Maple Ridge support is not yet available on macOS officially despite there being SSDT-TB4 drivers used by others on some hackintosh builds lately. If you're not after Thunderbolt functionality, the USBMap.kext map should suffice and allow the single USB-C port to be used for USB use only.
 
Joined
Aug 18, 2014
Messages
92
Motherboard
Gigabyte Z490 Vision D
CPU
i7 10900K
Graphics
Vega VII
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
  4. Mac Pro
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
@joshuame149, it's great that you've set this page up.

For anyone who is interested, I have attached the EFI for my build of this board using OC 0.7.4 and external AMD dGPU (just add your own UUID and board system serial and ROM serials). For BIOS settings:

Firmware version: 0407 or later

Main > XMP Profile 1 > Enabled
Advanced > Software Guard Xtentions (SGX) > Disabled
Advanced > Active Cores > All
Advanced > Hyperthreading > Enabled
Advanced settings > System Agent > Graphics Configuration > Primary Display > PCIe
Advanced > System Agent Configuration > VT-d > Disabled (may need to be enabled for Windows)
Above 4G Decoding > Enabled
Re-sizeable bar > Enabled
Graphics Configuration > DVMT Pre-allocated > 1024M
USB Configuration > Legacy USB > Enabled
XHCI-Handoff > Enabled
Boot > CSM > Launch CSM > Disabled
Secure Boot > OS Type > Other OS
Boot Configuration > Fast Boot > Disabled
CFG Lock > Disable
Power Management > PEG ASPM > Enabled
PCH ASPM > Disabled
DMI ASPM > Enabled
S3 > Enabled
ErP > Disabled
PTT > Enabled

It is recommended to boot from either the M.2 sockets, SATA or USB using the F8 key.
Hi! I tried this EFI with this motherboard but the audio setup does not work.
What about the Intel Graphics? Is that correct?
 
Joined
Aug 18, 2014
Messages
92
Motherboard
Gigabyte Z490 Vision D
CPU
i7 10900K
Graphics
Vega VII
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
  4. Mac Pro
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
Hi! I tried this EFI with this motherboard but the audio setup does not work.
What about the Intel Graphics? Is that correct?
By the away, I got audio working only with boot-arg "alcid=11"
 
Top