Contribute
Register

Asus PRIME Z490-P Catalina 10.5.5

Joined
Oct 18, 2012
Messages
128
Motherboard
Gigabyte Z390 Designare
CPU
i5-8400
Graphics
RX 560
Mac
MacBook Air
Mobile Phone
iOS
Update 19-06-2020.
See Post 19.

Update 22-09-2020.
See Post 83.



Hi everyone.
As the title suggests I installed Catalina 10.5.5 on this motherboard, and the system works quite well.

Hardware:
Asus PRIME Z490-P
I5 10400
MSI Radeon 560
Opencore 0.59

I have a few problems to solve ...
I dumped the DSDT with Ubuntu Live USB, and then I used SSDTTime to generate the SSDT that I needed.
I got some SSDTs from Opencore's guide.
When I boot on verbose mode I see that there are a few ACPI errors and also an OCS error.
I can't activate the UHD630 in Headless mode.
I don't understand if it's a BIOS error, because this BIOS only allows you to choose which video card to boot from.
So if I choose PEG, I don't understand if the IGPU is activated.

Audio works.
Ethernet works.
USB ports work.
Sleep Work

I ask the experts if they have any ideas on how to fix ACPI and OCS errors.
And fix the UHD630 in Headless mode.

A big thank to CaseySJ, because I started to do this installation from his files ...

Thank You.

Max


UPDATE 16-06-2020
OCS Error Solved.
Renamed Delete to Block in Kernel section.

UPDATE 17-06-202
With new SSDT-EC.aml the HS13 error is gone!

Update 19-06-2020.
See Post 19.

Update 22-09-2020.
See Post 83.
 

Attachments

Last edited:

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
11,150
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
MacBook Air, MacBook Pro, Mac Pro
Classic Mac
Quadra
Mobile Phone
iOS
@maxtools11,

Nice to see another Z490 adventurer. Let's address the various issues:
  • iGPU
    • There is no mention of iGPU in IORegistryExplorer. This suggests that it's disabled in BIOS.
    • Are you sure the Asus BIOS does not have an explicit setting to enable iGPU independent of "initial display output"?
    • If there really isn't such a setting, please switch boot video to iGPU and check or post IOReg. We're looking for iGPU@2.
    • WhateverGreen is enabled properly as we can see at the end of IOReg, so iGPU is most likely disabled in BIOS.
  • ACPI Errors
    • These may be due to other SSDTs. Please run Hackintool and export the entire ACPI table set as follows:
      Screen Shot 2020-06-15 at 4.23.13 PM.png
    • After choosing a destination folder, please zip up only the .aml files (not .dsl) and post.
    • Also run this command in Terminal: log show --last boot | grep ACPI > ~/Documents/acppi.txt
      • This will create a file in Documents folder called acpi.txt
      • Post that file.
    • macOS is complaining about a missing USB device HS13. You've removed this device from USBPorts.kext. It may also be a good idea to temporarily re-enable HS13 and grab an IOReg dump just in case something is connected there. A built-in RGB lighting controller (Aura Sync RGB) might be using that port.
  • "OCS Error" in 3rd screenshot suggests a syntax error in the <kernel> section of config.plist. OpenCore 0.5.9 renamed <block> to <delete> for the ACPI, DeviceProperties, and NVRAM sections only. So if you had accidentally renamed it in the <kernel> section, then that would be an error. In the <kernel> section it's still called <block>.
 
Joined
Oct 18, 2012
Messages
128
Motherboard
Gigabyte Z390 Designare
CPU
i5-8400
Graphics
RX 560
Mac
MacBook Air
Mobile Phone
iOS
@maxtools11,
  • After choosing a destination folder, please zip up only the .aml files (not .dsl) and post.
  • Also run this command in Terminal: log show --last boot | grep ACPI > ~/Documents/acppi.txt
    • This will create a file in Documents folder called acpi.txt
    • Post that file.
Here the file.
 

Attachments

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
11,150
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
MacBook Air, MacBook Pro, Mac Pro
Classic Mac
Quadra
Mobile Phone
iOS
Some updates:
  • It would be good to use the attached SSDT-EC.aml
  • RHUB.H13 is original defined in DSDT.aml and subsequently referenced in SSDT-4.aml
    Screen Shot 2020-06-16 at 1.53.52 PM.png
  • This is the only device for which an ACPI error is being generated in the logs. And it is also the only one that defines child devices.
    • Is there a USB 2.0 hub at HS13?
  • There are a number of Unsupported module-level executable opcode 0x70 at table offset warnings, but since they're warnings, it might be okay (for now) to ignore them. But something is fishy.
 

Attachments

Joined
Oct 18, 2012
Messages
128
Motherboard
Gigabyte Z390 Designare
CPU
i5-8400
Graphics
RX 560
Mac
MacBook Air
Mobile Phone
iOS
USB:

Hi Casey
I have had many difficulties to map USB ports.
I have tried with USBInjectAll.kext + with XHCI Port limit Patch.
Result, no working USB port, and therefore I built a map by inserting all the ports (I hope) and especially the HS13 ...
and you were right there is the Aura Led Controller.
Do I have to leave it operational?
I can eliminate other USB ports obviously ...
 

Attachments

Joined
Oct 18, 2012
Messages
128
Motherboard
Gigabyte Z390 Designare
CPU
i5-8400
Graphics
RX 560
Mac
MacBook Air
Mobile Phone
iOS
UHD 630:

As for the UHD630, unfortunately, the "IGPU Multi Monitor" parameter is missing from the BIOS Menu, and therefore in my opinion it does not activate when I use the AMD 560.
I tried with (HDMI), but as we know with Catalina 10.5.5, HDMI doesn't work.
In the next few days I try with a DP monitor.
(I'm not very happy with this ASUS choice ...).
In the attached image an example of how it should be. (for example in my ASUS X99 Prime-A, that parameter is there)

However, apart from the VDA Decoder that doesn't work, the graphics part works well.
 

Attachments

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
11,150
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
MacBook Air, MacBook Pro, Mac Pro
Classic Mac
Quadra
Mobile Phone
iOS
USB:

Hi Casey
I have had many difficulties to map USB ports.
I have tried with USBInjectAll.kext + with XHCI Port limit Patch.
Result, no working USB port, and therefore I built a map by inserting all the ports (I hope) and especially the HS13 ...
and you were right there is the Aura Led Controller.
Do I have to leave it operational?
I can eliminate other USB ports obviously ...
Asus has done something pretty clever:
  • They have indeed put a 4-port USB 2.0 hub at HS13.
  • They have hijacked port #3 of the hub for Aura LED controller.
Reason this is nice is that HS13, despite having 4 USB 2.0 ports behind the hub, counts as only one USB port in macOS. So they give you the Aura LED controller without sacrificing a port.

So HS13 should be kept ON. It should be set to Type 255 (0xFF) which means Internal.

We might even be able to create a liquidctl driver for Asus Aura. But that will require some "wire sharking" by someone sufficiently motivated!

So:
  • Enable HS13
  • Open IORegistryExplorer, scroll down to XHC section
  • Then plug a USB 3.x device into each USB port and note which one turns Green in IORegistryExplorer
  • Then plug a USB 2.0 device (must be USB 2) into each port and note which port turns Green in IORegistryExplorer
When you're done, you will have a list of all the active ports. All other ports (that did not light up in green) can be removed, except for HS13.
 
Top