Contribute
Register

ASUS Prime Z490-A Motherboard - Photos

tonymacx86

Administrator
Staff member
Joined
Nov 18, 2009
Messages
8,568
Motherboard
PRIME Z490-A
CPU
i5 10600K
Graphics
Vega 56
Mac
  1. MacBook Air
Classic Mac
  1. Apple
  2. PowerBook
Mobile Phone
  1. iOS
Just got this guy in the mail- gonna install and test this weekend! :geek: :thumbup:

ASUS Prime Z490-A ATX
Form:ATX
Audio:ALC1220
Video:HDMI, DP
Network:Intel I225-V
Amazon US
(CA UK DE ES FR IT)


Some photos:

IMG_2493.jpeg
IMG_2494.jpeg
IMG_2495.jpeg
IMG_2496.jpeg


Related:
 
Last edited:
Joined
Mar 7, 2011
Messages
6
Motherboard
GA Z390 ud
CPU
i7-9900KS
Graphics
Vega-64
Mobile Phone
  1. Other
I've just successfully built another shmuckintosh with this exact MB(asus prime z490a) + i9-10900k + 5700xt and everything works fine
 

Attachments

  • config.plist
    24.5 KB · Views: 501
Last edited:
Joined
Sep 14, 2017
Messages
4
Motherboard
ASUS PRIME Z490-A
CPU
i7 10700K
Graphics
EVGA GTX Titan Black
Mac
  1. Mac Pro
Regards! I bought this motherboard recently due to a hardware change in the computer and I have to say that it works perfectly in OS X Catalina 10.15.6 but I can't get the OS X Mojave 10.14.6 installer to work, it stops at (End RandomSeed) Any help is appreciated, as I want to go back to OS X Mojave 10.14.6 due to incompatibility of some sound hardware devices that I have. Thank you! If someone has this board and needs help installing OS X Catalina through the OpenCore method, I can also help them.
 

Attachments

  • 638EB007-34EF-4A39-AD9F-2B5054A29237.jpeg
    638EB007-34EF-4A39-AD9F-2B5054A29237.jpeg
    2.7 MB · Views: 153
Joined
Sep 30, 2016
Messages
16
Motherboard
MSI Z490-A Prime
CPU
i9-10900K
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
  2. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Willie, I recently purchased exact same MB, cpu, and video card!

I see SSDT-TBOLT3-RP21-ASUS-TB-EX3.aml enabled in your config, did you get thunderbolt 3 successfully working?

Any chance you can post full config EFI and also any USB port mapping discovery you have done? Might save me some time when all my parts arrive :)
 
Joined
Sep 30, 2016
Messages
16
Motherboard
MSI Z490-A Prime
CPU
i9-10900K
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
  2. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Hey all, so I got this combo working fine, trying to setup USB mappings now but see one issue. I have an Apple Broadcom BCM94360CD bluetooth/wifi card which worked great in my previous MSI Z270 setup. With the ASUS Prime Z490-A there are only 2 USB2 headers on the motherboard, and for both it shows up under a USB2.0 Hub (see attached screenshot). I set this to internal type as per the USBMap docs, but then Bluetooth doesn't work at all. Did you guys do USB mapping and what did you do with this port?

Thanks!
 

Attachments

  • Screen Shot 2020-09-29 at 6.16.35 PM.png
    Screen Shot 2020-09-29 at 6.16.35 PM.png
    681 KB · Views: 143
Joined
Nov 22, 2016
Messages
21
Motherboard
Asus Z490-A Prime
CPU
i9-10850K
Graphics
RX 570
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Hi All,

I just got this same board with a I9-10850K, where you able to get hackintosh working on yours?

Also, did you use opencore or clover? I have more experience with Clover, I have not touched opencore yet.

Thank you!
 
Joined
Sep 30, 2016
Messages
16
Motherboard
MSI Z490-A Prime
CPU
i9-10900K
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
  2. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Hi All,

I just got this same board with a I9-10850K, where you able to get hackintosh working on yours?

Also, did you use opencore or clover? I have more experience with Clover, I have not touched opencore yet.

Thank you!

Hello, yes mine is working fine using Opencore, let me know if you have any specific questions and I will try to help.
 
Joined
Nov 22, 2016
Messages
21
Motherboard
Asus Z490-A Prime
CPU
i9-10850K
Graphics
RX 570
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Thank you! Right now I used an EFI folder I found online and it is not working (It boots into the install screen but when I click install, it just goes back to the beginning menu). I thought since someone already did it, their EFI should work fine for me to.

Like I said earlier I have a lot more experience with Clover, so I am starting over with Opencore.

I am starting with a basics tutorial on Opencore now, if you have any tips that would be greatly appreciated!!

Thank you!
 
Joined
Feb 4, 2011
Messages
185
Motherboard
ASUS Prime Z490-A
CPU
i7-10700K
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
This is the board I am using and the only issue I am having is with the T919 wifi card. It is slower than it should be.

I was looking to see if anyone has put a m.2 wifi card on the board as it has a spot for one.
 
Joined
Jan 13, 2021
Messages
1
Motherboard
asus prime z490A
CPU
i7 10700k
Graphics
nvidia
Hy everyone, I am so new here... I have bought right now this motherboard, where is the guide to setup the bio? I have read Nitrix88 that is difficult to install mojave, I want to work with protools... please I need some help, thanks
 
Top