Contribute
Register

ASUS Prime Z490-A, Intel Core i9-10850K, 64GB RAM, RX 5700 XT GPU

Joined
Nov 17, 2015
Messages
59
Motherboard
Asus Prime Z490-A
CPU
i9-10900K OC @ 5.4 GHz
Graphics
Radeon VII + RX 580
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. iOS
Excuse me. Yes.
I haven't done it yet. I was able to modify my USB ports in 11.3.1 with Hackintool though. I'll probably go to 11.4 later this week...
 
Joined
May 27, 2021
Messages
2
Motherboard
Asus Prime Z490 A
CPU
i9-10850k
Graphics
RX570
Mac
  1. MacBook Pro
Thanks for sharing the build. Works very well for me.

As a newbie, would anyone be able to share some hints on how to update to latest open core? Any pitfalls or things to watch out for?

Cheers
 
Joined
Nov 17, 2015
Messages
59
Motherboard
Asus Prime Z490-A
CPU
i9-10900K OC @ 5.4 GHz
Graphics
Radeon VII + RX 580
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. iOS
Thanks for sharing the build. Works very well for me.

As a newbie, would anyone be able to share some hints on how to update to latest open core? Any pitfalls or things to watch out for?

Cheers
I've only updated once so far. I went from OC 6.5 to 6.8 and didn't have any issues. I think it's important to backup your files before doing any update. Just FYI.

I followed the instructions on the OpenCore website - https://dortania.github.io/OpenCore-Post-Install/universal/update.html#_2-mount-your-efi

I got to step 4 and was confused about how to use OCConfigCompare, but this video helped me.
 
Joined
Jun 11, 2011
Messages
72
Motherboard
Asus Prime Z490-A
CPU
i9-10850K
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Maniamax36, could you share your Efi folder, please? without personal information an sn, of course. Thanks in advance.
 
Last edited:
Joined
Jun 1, 2021
Messages
2
Motherboard
ASUS Z490 > Need full model name > See Rules!
CPU
i9 > Need full model name > See Rules!
Graphics
RX 570XT
I'm attempting a build very similar to this and am currently able to get the installer to come up but it won't seem to detect the NVMe drive. Does it have to be in the slot that's under the x16 slot heatsink for the installer to see it?

Update: It needed to be GPT, I set that up with a live Ubuntu installer, and was good to go. The disk utility was able to see it and format to apfs. Slowly progressing!
 
Last edited:
Joined
Jun 11, 2021
Messages
1
Motherboard
ASUS Prime 7490-A
CPU
Intel i9
Graphics
GEFORCE GT 710
I believe that I followed all the instructions but when I went to initially boot my system I get a black screen and: Reboot and select proper boot device or insert boot media in selected boot device and press a key. I have the exact build requirements as yours. Help?
 
Joined
Jun 1, 2021
Messages
2
Motherboard
ASUS Z490 > Need full model name > See Rules!
CPU
i9 > Need full model name > See Rules!
Graphics
RX 570XT
I believe that I followed all the instructions but when I went to initially boot my system I get a black screen and: Reboot and select proper boot device or insert boot media in selected boot device and press a key. I have the exact build requirements as yours. Help?

When you boot to the BIOS, do you see "OpenCore EFI" or "UEFI OS" as an option? If not, it sounds like it's not detecting your EFI partition. I accidentally caused the same symptom, and rendered my system only able to boot to Windows by clearing the NVRAM. I was attempting to migrate from the SSD I installed on externally, to the internal NVMe drive, and could only get it to detect OpenCore on the SSD. I had to boot to an OpenCore shell via a USB and run a command to point it to the EFI partition on the drive I wanted, following this guide: https://nxw.name/2020/opencore-uefi-disappers-from-boot-options-after-5cbeea65

If the partitions look good, the EFI structure is there, etc, I'd probably start there. I'm still not sure what initially populates the menu normally, but maybe this can help get you unstuck.
 
Joined
Aug 1, 2012
Messages
45
Motherboard
ASUS PRIME Z490-A
CPU
i9 10850k
Graphics
Sapphire RX 470
Create a bootable macOS USB installer
@shilohh Hi, I'm following your guide, but with no luck so far...
I've checked and rechecked everithing I could, but I still stuck at installation script and not getting through to Big Sur install. I'm using OpenCore 0.6.5

I have:
ASUS PRIME Z490-A LGA 1200
Intel Core i9-10850K Comet Lake 10-Core

Crucial Ballistix 2666 (2x16GB)​

graphic card is RX 470, but it's not installed into mb and Graphics Configuration is set to CPU in Bios
no network or wi-fi card installed

That's where I get stuck:
photo_2021-06-27 11.42.10.jpeg


I've just no idea how to fix this and to make it work :(
 

Attachments

  • config.plist
    25.8 KB · Views: 4
  • EFI.zip
    2.5 MB · Views: 3
Joined
Jan 7, 2014
Messages
39
Motherboard
Z490-A Prime
CPU
i9-10850k
Graphics
MSI RX 6800 xt Trio
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
@shilohh Hi, I'm following your guide, but with no luck so far...
I've checked and rechecked everithing I could, but I still stuck at installation script and not getting through to Big Sur install. I'm using OpenCore 0.6.5

I have:
ASUS PRIME Z490-A LGA 1200
Intel Core i9-10850K Comet Lake 10-Core

Crucial Ballistix 2666 (2x16GB)​

graphic card is RX 470, but it's not installed into mb and Graphics Configuration is set to CPU in Bios
no network or wi-fi card installed

That's where I get stuck:
View attachment 523004


I've just no idea how to fix this and to make it work :(
Hey uniM!

Are you getting stuck at the OS install or at boot after installing OS?
First I would try disabling your eGPU and installing the RX 470 instead of the opposite.
Also you seem to have too many drivers in your EFI folder, too many useless drivers might mess up your installation or boot. Check out this awesome guide from Acidanthera about our specific Comet Lake builds.


BTW I found that OC 0.7.0 was much better than 0.6.5. But be careful not to mix OC versions,
your plist, drivers and kexts all have to be of the same OC version.

Here's a screen grab of my EFI folder.
 

Attachments

  • Screen Shot 2021-06-30 at 10.37.12.png
    Screen Shot 2021-06-30 at 10.37.12.png
    381.9 KB · Views: 14
  • config-06-30.plist
    24.4 KB · Views: 9
Top