Contribute
Register

ASUS P9X79 PRO - I7-3970 + THUNDERBOLT + OpenCore

Joined
Nov 23, 2016
Messages
52
Motherboard
ASUS Prime X299-DELUXE-3105
CPU
i9-7920X
Graphics
Vega 56
Mac
  1. iMac
This motherboard is unfortunately not very common here. Since I still had a fully functional computer sitting around, I finally wanted to try building a Hackintosh out of it.

With the excellent tips from "Dortania's OpenCore Install Guide" and some research in the relevant forums (credit: @kostrovoy), I created an OpenCore EFI folder and installed Catalina. The good piece runs as MacPro6,1

Hardware:
  • CPU: i7-3970X Sandy Bridge E
  • GPU: Sapphire Pulse RX 560
  • RAM: Corsair 32GB 1866 Mhz
  • GC-Titan Ridge Thunderbolt

Works:
  • USB2
  • LAN
  • Audio - Onboard
  • Audio - HDMI
  • Thunderbolt*
  • CPU-PowerManagement
No or limited function
  • USB3**
  • Bluetooth***
Not testet:
  • wake / sleep

* A flashed Gigabyte Thunderbolt card even helps the Granny to two TB3 ports. Unfortunately, however, no HotPlug works so far even with a corresponding SSDT. To run two UAD Apollo interfaces and one UAD Satellite, you have to reboot the hack, with the devices connected and powered on, three times. :mrgreen:

** The USB3 ports on the board only work as USB2, unless on a cold boot, then they have full USB3 bandwidth. Same behavior as the USB controller on the TB card.

*** I disabled Bluetooth in the BIOS because the onboard controller is not recognized at all.
 

Attachments

  • oc_068_rx560_p9x79pro_EFI.zip
    8.6 MB · Views: 122
Last edited:
Joined
May 1, 2021
Messages
7
Motherboard
<< need model # >> See Forum Rules !!
CPU
i7 << need model # >> See Forum Rules !!
Graphics
rx570
Hello! can you help me build an EFI for the asus P9x79 LE?
 
Joined
Nov 23, 2016
Messages
52
Motherboard
ASUS Prime X299-DELUXE-3105
CPU
i9-7920X
Graphics
Vega 56
Mac
  1. iMac
Hello! can you help me build an EFI for the asus P9x79 LE?
I would need a bit more information for this.
  • Is the computer already running clover?
  • if yes, please upload the EFI folder (without serial number)

  • What hardware is installed
  • CPU
  • Graphics card
 
Joined
May 1, 2021
Messages
7
Motherboard
<< need model # >> See Forum Rules !!
CPU
i7 << need model # >> See Forum Rules !!
Graphics
rx570
Для этого мне понадобится немного больше информации.
  • На компьютере уже запущен клевер?
  • если да, загрузите папку EFI (без серийного номера)

  • Какое оборудование установлено
  • Процессор
  • Видеокарта
CPU i7 3820, GPU AMD HD7850 1gb, Bios updated to the latest version 4801
I use a bootloader opencore
 

Attachments

  • EFI.zip
    12.1 MB · Views: 55
Joined
Nov 23, 2016
Messages
52
Motherboard
ASUS Prime X299-DELUXE-3105
CPU
i9-7920X
Graphics
Vega 56
Mac
  1. iMac
CPU i7 3820, GPU AMD HD7850 1gb, Bios updated to the latest version 4801
I use a bootloader opencore
...hello Denis try this EFI. The config.plist is with the serial number from your EFI folder.
The BIOS settings can be found here, but I have CSM enabled on my board.
 
Joined
May 1, 2021
Messages
7
Motherboard
<< need model # >> See Forum Rules !!
CPU
i7 << need model # >> See Forum Rules !!
Graphics
rx570
...hello Denis try this EFI. The config.plist is with the serial number from your EFI folder.
The BIOS settings can be found here, but I have CSM enabled on my board.
Thank you very much for your help, but I get such a problem, with my efi it was the same.
 

Attachments

  • изображение_viber_2021-05-11_20-11-22.jpg
    изображение_viber_2021-05-11_20-11-22.jpg
    229.7 KB · Views: 39
Joined
Nov 23, 2016
Messages
52
Motherboard
ASUS Prime X299-DELUXE-3105
CPU
i9-7920X
Graphics
Vega 56
Mac
  1. iMac
Have you checked the BIOS settings?
 
Joined
Nov 23, 2016
Messages
52
Motherboard
ASUS Prime X299-DELUXE-3105
CPU
i9-7920X
Graphics
Vega 56
Mac
  1. iMac
@Denis1805 ...please try this EFI folder, it is a debug version. The computer will not start again but we get an ACPI dump. On the EFI partition a folder "SystemReport" is created and in it the folder "ACPI". Please attach it here.
 

Attachments

  • oc_068_debug_EFI.zip
    8.8 MB · Views: 38
Joined
May 1, 2021
Messages
7
Motherboard
<< need model # >> See Forum Rules !!
CPU
i7 << need model # >> See Forum Rules !!
Graphics
rx570
Maybe I missed something in the bios settings
 

Attachments

  • SysReport.zip
    31.1 KB · Views: 38
Joined
Nov 23, 2016
Messages
52
Motherboard
ASUS Prime X299-DELUXE-3105
CPU
i9-7920X
Graphics
Vega 56
Mac
  1. iMac
...ok, try this EFI
 

Attachments

  • oc_068_debug_V2_EFI.zip
    8.8 MB · Views: 58
Top