Contribute
Register

Asus P6T Deluxe V2 OSX El Capitan (10.11) Guide

Joined
Jun 20, 2013
Messages
36
Motherboard
Asus P6T Deluxe V2
CPU
I7-920
Graphics
RX 570
Mobile Phone
  1. Android
(Update: Everything but sound works for OSX Sierra 10.12 as well. Will update when I figure out how to fix sound.)

I thought this guide might prove useful if there are any other Asus P6T Deluxe V2 users out there. I have to go through mostly the same steps with each OS iteration, but now that Unibeast switched to Clover, a few steps have changed.

Creating UniBeast install drive:
  1. Follow the usual steps from the Installation Guide to get started.
  2. Choose "Legacy Boot"
  3. Choose "Inject Nvidia" if using an older Nvidia card like 4xx series
To Install:
  1. Plug the UniBeast USB drive into your PC
  2. If using motherboard SATA RAID, enter the BIOS by hitting DEL, change the SATA mode to AHCI
  3. At the bios post, keep pressing F8 to bring up the boot selector and select the USB drive
  4. At Clover screen, select Options:
    Add to boot args: nv_disable=1 cpus=1
    In SMBios settings, change Product Name and Board Version to MacPro5,1 [edited]
    Go back to main Clover screen
  5. Select the USB drive and press space
  6. Select verbose boot
  7. If you get "Waiting for root device" and an crossed out symbol with garbled text, keep trying different USB ports including ports in hubs. (If you have to reboot, you must enter all the Clover settings again.)
  8. If all else fails, try Safe Mode as well. It should eventually boot.
  9. Install OS X
  10. Leave thumb drive in on reboot because HD has no boot loader yet
  11. At the bios post, keep pressing F8 to bring up the boot selector and select the USB drive
  12. From Clover, select the HD drive and boot into your newly installed OS X
  13. Set up your system but skip networking/internet as it won't work. Say this computer is not connected to internet.
  14. Open a terminal and enter:
    Code:
    sudo nano /System/Library/Extensions/IONetworkingFamily.kext/Contents/Plugins/AppleYukon2.kext/Contents/Info.plist
  15. Find Yukon-88E8053 and make it Yukon-88E8056
  16. Find 0x436211ab and make it 0x436411ab
  17. Clear the kext cache - see below.
  18. Run MultiBeast and choose Easy Install
  19. Select "Legacy Boot"
  20. Select "Inject Nvidia" if using an older NVidia card
  21. You may remove the thumb drive
  22. Reboot
Motherboard RAID:
  1. edit /System/Library/Extensions/AppleAHCIPort.kext/Contents/Info.plist:
  2. Under GenericAHCI, Change:
    <string>0x01060100&amp;0xffffff00</string>
    to
    <string>0x01060100&amp;0xffffff00 0x01040000&amp;0xffff0000</string>
  3. Clear kext cache in terminal:
    Code:
    sudo chmod -R 755 /System/Library/Extensions
    sudo chown -R 0:0 /System/Library/Extensions
    sudo touch /System/Library/Extensions
    sudo kextcache -u /Volumes/THENAMEOFYOUROSXVOLUME
  4. Reboot
  5. Press Del on the bios screen and change SATA mode back to RAID.
Sound:
  1. Get the AppleHDA.kext from Zip file in this post.
  2. Copy the original AppleHDA.kext in /System/Library/Extensions to somewhere for safe keeping.
  3. Replace /System/Library/Extensions/AppleHDA.kext with the one from the zip file above.
  4. Open a terminal and use these commands:
    Code:
    sudo chmod -R 755 /System/Library/Extensions/AppleHDA.kext
    sudo chown -R root:wheel /System/Library/Extensions/AppleHDA.kext
    sudo touch /System/Library/Extensions
The last step is to set the Audio Id in Clover. There are several ways to do this, but I like to use Clover Configurator.
  1. Install Clover Configurator.
  2. Run it.
  3. Mount the EFI partition.
  4. Open EFI/EFI/Clover/config.plist
  5. On the Devices page, set the Audio Inject field to 7
  6. Save and quit
  7. Reboot
  8. Open System Preferences -> Sound
  9. Change “Play sound effects through” to “Internal Speakers”. This will play sound through the green audio port.
Alternate method using HDAEnabler (do not do this if you used the Clover Configurator method above):
  1. Download HDAEnabler7 from here.
  2. Copy HDAEnabler7.kext to /System/Libraries/Extensions
  3. Open a terminal and run these commands:
    Code:
    sudo chmod -R 755 /System/Library/Extensions/HDAEnabler7.kext
    sudo chown -R root:wheel /System/Library/Extensions/HDAEnabler7.kext
    sudo touch /System/Library/Extensions
  4. Reboot
  5. Open System Preferences -> Sound
  6. Change “Play sound effects through” to “Internal Speakers”. This will play sound through the green audio port.
Nvidia 4xx freeze fix:
While not specific to this board, freezefix is required for Nvidia Fermi cards (4xx, 5xx). You can download it here. Follow the install instructions.

Notes:
  • If using Raid mode, when installing a new OS patch, you must swtich back to AHCI mode in the bios, then redo all the kext steps above.
  • If using Raid mode, when installing a new OS major update, you must switch back to AHCI mode in the bios or the installer will crash on boot.

Not Working:
The front USB ports are not currently working.

UPDATED INFO (from discussion in this thread):

Audio problems:
[Swiftoholic] If you use the latest AppleHDA.kext or AppleALC you will need Lilu.kext too to make it work.

IMPORTANT INFORMATION WHEN UPDATING CLOVER BOOTLOADER:
After updating from Clover 3xxxx to 4114, every time the system started booting it would have a kernel panic that referenced com.apple.driver.usb.AppleUSBUHCIPCI(1.0.1). After wasting 6 hours trying everything possible, I finally stumbled onto a fix -- enable "Fix TMR" in the AHCI options in Clover. A description of what Fix TMR does is here, but I don't see how this is related to USB. :banghead:
 
Last edited:
Joined
Jul 17, 2015
Messages
50
Motherboard
P6T Deluxe V2
CPU
Core i7 920 @3,6GHz
Graphics
Palit GeForce GTX 980 Ti Jetstream
Mobile Phone
  1. iOS
Hey!

Thx for this guide, it worked perfectly!

have u figured out how to implement the usb controller?

I was looking up to patch the dsdt but it seems that it is definitely different because this board has many controllers or smthg like that.
In the dsdt it was named from usb0 to usb6, so no chance to just change ehc1 to eh01 like its written in other el capitan fixes.

PS: What I also can recommend is, to use the smbios from macpro5,1, it seems a lil' bit smoother and the Geekscore was also around 10% higher. But it looks like the speed stepping isn't quite well, from min to max, but I'm not quite sure yet.
 
Joined
Jun 20, 2013
Messages
36
Motherboard
Asus P6T Deluxe V2
CPU
I7-920
Graphics
RX 570
Mobile Phone
  1. Android
Hey!

Thx for this guide, it worked perfectly!

have u figured out how to implement the usb controller?

I was looking up to patch the dsdt but it seems that it is definitely different because this board has many controllers or smthg like that.
In the dsdt it was named from usb0 to usb6, so no chance to just change ehc1 to eh01 like its written in other el capitan fixes.

PS: What I also can recommend is, to use the smbios from macpro5,1, it seems a lil' bit smoother and the Geekscore was also around 10% higher. But it looks like the speed stepping isn't quite well, from min to max, but I'm not quite sure yet.

I haven't figured anything new out on this one. My USB ports all work except the front case ports. Odd they don't work under Ubuntu either, but work fine in Windows. In my previous Yosemite install, the front ports did work, but only for certain devices oddly. Bluetooth dongle and game controllers didn't work, but thumb drives and the Apple TV dev cable did. *shrug*

Interesting about the smbios improving performance!
 
Joined
Jul 17, 2015
Messages
50
Motherboard
P6T Deluxe V2
CPU
Core i7 920 @3,6GHz
Graphics
Palit GeForce GTX 980 Ti Jetstream
Mobile Phone
  1. iOS
ok, thx for your fast reply!

Hmm.. I guess I will let it for now, makes no sense al all because the rest works quite well.
Have you thought about upgrading to macOS Sierra?
Would be interesting if the existing kexts for el capitan worked on sierra too :)
 
Joined
Jun 20, 2013
Messages
36
Motherboard
Asus P6T Deluxe V2
CPU
I7-920
Graphics
RX 570
Mobile Phone
  1. Android
ok, thx for your fast reply!

Hmm.. I guess I will let it for now, makes no sense al all because the rest works quite well.
Have you thought about upgrading to macOS Sierra?
Would be interesting if the existing kexts for el capitan worked on sierra too :)

I just attempted to and the App Store tells me that 10.12 cannot be installed on this computer so I can't even download it. I suspect perhaps changing the system model in SMBios to something newer than MacPro5,1 might help...
 
Joined
Jul 17, 2015
Messages
50
Motherboard
P6T Deluxe V2
CPU
Core i7 920 @3,6GHz
Graphics
Palit GeForce GTX 980 Ti Jetstream
Mobile Phone
  1. iOS
Yeah, MacPro3,1 isn't supported anymore for macOS Sierra. But 5,1 is working quite well with this MB ;)
 
Joined
Jun 20, 2013
Messages
36
Motherboard
Asus P6T Deluxe V2
CPU
I7-920
Graphics
RX 570
Mobile Phone
  1. Android
Yeah, MacPro3,1 isn't supported anymore for macOS Sierra. But 5,1 is working quite well with this MB ;)

Thanks, 5,1 did the trick for downloading. A Clover update was required to see the new bootable partition the installer created. However, no matter what boot options I try, the installer never finishes loading. Oh well, not gonna waste a million years trying to get an upgrade to work. If I move to Sierra, I'll just wipe and reinstall like all the other major upgrades I've done in the past.

Edit: Almost a year later, I finally updated it. It actually did work. All I had to do was to change from RAID mode back to AHCI while updating. (My OSX drive does not use RAID, so there's no issue of it being able to read it.)
 
Last edited:
Joined
Jul 17, 2015
Messages
50
Motherboard
P6T Deluxe V2
CPU
Core i7 920 @3,6GHz
Graphics
Palit GeForce GTX 980 Ti Jetstream
Mobile Phone
  1. iOS
On my MacBook Pro i had the same prob, it was hanging on the first restart after i pushed the button to install it. but then i just killed it and the update was working like a charm :p
 
Joined
Jul 17, 2015
Messages
50
Motherboard
P6T Deluxe V2
CPU
Core i7 920 @3,6GHz
Graphics
Palit GeForce GTX 980 Ti Jetstream
Mobile Phone
  1. iOS
So after I broke my system by using a hfs writer/reader driver under windows, I've tried to install sierra now and it worked!

so the kext for the IONetwork still works and I made audio to work by defining the audio layout to 7 in clover and using the applealc patcher by vit9696 (https://github.com/vit9696/AppleALC/releases)

The Nvidia web drivers seems to be still very buggy for my 980ti because I can't use my Dual Monitor setup. When plugging in my vga monitor the system crashes. Was not a problem under El Capitan and a GTX 760.

Trying to migrate my data with the migration assistant over night. I hope it works, under El Capitan it was working too.

UPDATE:

The migration was successful :)

UPDATE #2:

Front USB is working now. I just have physically swapped the USB connection on the board to an other free port and it has worked out of the box :)
 
Last edited:
Joined
Oct 20, 2014
Messages
6
Motherboard
ASUS P6TD DELUXE
CPU
i7 990x
Graphics
r9 280x
hi.

Asus p6td deluxe, with AD2008 i've just tested on sierra.
apple+hda works, but a better result for me was voodoo 2.8.4. albeit after the install (unibeast yosemite!) i've got an error.
restart (i m note sure if before rst i ve used kext utility. guess not) and here it is.
oh, and i've set mac 5.1
 
Top