Contribute
Register

Asus N752VX

Joined
May 2, 2020
Messages
33
Motherboard
Asus N752VX HM170 / Clover
CPU
Intel Core i7-6700HQ
Graphics
Intel HD 530 1920 x 1080 / nVidia GeForce GTX 950M
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
@Feartech

Hi - sorry to reach out like that, i am stuck and saw that we seem to have the exact same laptop model. I've been trying to get my ELAN1000 touchpad (ETPD name) working since couple days using voodooi2c and chid, done all the GPIO pinning, from the i2c forums etc however it's still not being recognized as touchpad in sysprefs. it does work, tap2click and right click is ok, but no multifinger gestures. Any chance you can help me there? Appreciate.
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
20,692
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
@Feartech

Hi - sorry to reach out like that, i am stuck and saw that we seem to have the exact same laptop model. I've been trying to get my ELAN1000 touchpad (ETPD name) working since couple days using voodooi2c and chid, done all the GPIO pinning, from the i2c forums etc however it's still not being recognized as touchpad in sysprefs. it does work, tap2click and right click is ok, but no multifinger gestures. Any chance you can help me there? Appreciate.
here you go :)
 

Attachments

  • Archive.zip
    160.8 KB · Views: 21
Joined
May 2, 2020
Messages
33
Motherboard
Asus N752VX HM170 / Clover
CPU
Intel Core i7-6700HQ
Graphics
Intel HD 530 1920 x 1080 / nVidia GeForce GTX 950M
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
here you go :)
Thanks - would have been to nice - i manually amended my existing config.plist to include your patches.plist through xcode. (i am on catalina fyi). so all i've done is added your kexts to clover/kexts/other, added your two amls into the patched folder in clover and amended my config.plist. now when booting in verbose it seems to have loaded elan but right after it stops. i used my existing DSDT patched file to boot as well as with the original BIOS.aml. Both stop at same point. Patches I applied before:

bat: ASUSG75VW
FIX_WAK Arg0 v2
HPET Fix
SMBUS Fix
IRQ Fix
RTC Fix
PS Check Fix Windows 10 (which was installed when shipped)
Mutex non zero
USB_PRW 0x6D Skyklake instant wake

i know it probably doesnt help much and i should probably familiarize myself with proper error log postings. But before i do that maybe let me know if you instantly see my mistake. GPIO pinning with all the renaming of SBFI / SBFB and pinning to 0x47 was done too fyi.

Its a long shot, but given that we're likely using the same laptop, would it work if you sent me your full config.plist, all kexts and DSDT / SSDT files you use? Reading from forums i know that this is the wrong approach and i am only putting it out there because of our identic setup. let me know and thanks in advance.
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
20,692
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Thanks - would have been to nice - i manually amended my existing config.plist to include your patches.plist through xcode. (i am on catalina fyi). so all i've done is added your kexts to clover/kexts/other, added your two amls into the patched folder in clover and amended my config.plist. now when booting in verbose it seems to have loaded elan but right after it stops. i used my existing DSDT patched file to boot as well as with the original BIOS.aml. Both stop at same point. Patches I applied before:

bat: ASUSG75VW
FIX_WAK Arg0 v2
HPET Fix
SMBUS Fix
IRQ Fix
RTC Fix
PS Check Fix Windows 10 (which was installed when shipped)
Mutex non zero
USB_PRW 0x6D Skyklake instant wake

i know it probably doesnt help much and i should probably familiarize myself with proper error log postings. But before i do that maybe let me know if you instantly see my mistake. GPIO pinning with all the renaming of SBFI / SBFB and pinning to 0x47 was done too fyi.

Its a long shot, but given that we're likely using the same laptop, would it work if you sent me your full config.plist, all kexts and DSDT / SSDT files you use? Reading from forums i know that this is the wrong approach and i am only putting it out there because of our identic setup. let me know and thanks in advance.
i have moved on to OpenCore but you are welcome to the files, you will need to add your serial number etc.

it is also possible that you may require the special bios that i amended though, let me know and i can give instructions on that one
 

Attachments

  • OC.zip
    6.6 MB · Views: 39
Joined
May 2, 2020
Messages
33
Motherboard
Asus N752VX HM170 / Clover
CPU
Intel Core i7-6700HQ
Graphics
Intel HD 530 1920 x 1080 / nVidia GeForce GTX 950M
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
i have moved on to OpenCore but you are welcome to the files, you will need to add your serial number etc.

it is also possible that you may require the special bios that i amended though, let me know and i can give instructions on that one

will have a look thanks - for now my system is completely screwed -I cant book anymore. I replaced the new config.plist with the old version via windows10 and disabled the additional patches when booting. no luck so far. need to dig further and worst case start from scratch.
 
Joined
May 2, 2020
Messages
33
Motherboard
Asus N752VX HM170 / Clover
CPU
Intel Core i7-6700HQ
Graphics
Intel HD 530 1920 x 1080 / nVidia GeForce GTX 950M
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Ok - back to square one it is. Couldnt fix what i messed up. So I‘ll setup a new Mojave now and fix IntelGpu and Battery status first. Can I apply all the patches I‘ve done before (post 3191) without creating damage for the yet to be resolved trackpad issue? Also - shall I stay with Mojave until everything is fixed or move directly to Catalina?

Thanks again For your help
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
20,692
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Ok - back to square one it is. Couldnt fix what i messed up. So I‘ll setup a new Mojave now and fix IntelGpu and Battery status first. Can I apply all the patches I‘ve done before (post 3191) without creating damage for the yet to be resolved trackpad issue? Also - shall I stay with Mojave until everything is fixed or move directly to Catalina?

Thanks again For your help
choice of Mojave or Catalina shouldn't make a difference

the patched files i provided for you will stop the need for you in performing any DSDT patches
 
Joined
May 2, 2020
Messages
33
Motherboard
Asus N752VX HM170 / Clover
CPU
Intel Core i7-6700HQ
Graphics
Intel HD 530 1920 x 1080 / nVidia GeForce GTX 950M
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
choice of Mojave or Catalina shouldn't make a difference

the patched files i provided for you will stop the need for you in performing any DSDT patches
I see - couple things to consider though:
a) we might have different BIOS versions. I am on 2.17.1249
b) we most probably have different keyboard layouts (i have a swiss german keyboard, i strongly doubt you have the same)
c) you probably swapped your AC7265 Wireless module?

also - i read some things about OpenCore and as of now it seems slightly above my knowledge level - can i continue on Clover for the time being and still use your files?

thanks
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
20,692
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
I see - couple things to consider though:
a) we might have different BIOS versions. I am on 2.17.1249
b) we most probably have different keyboard layouts (i have a swiss german keyboard, i strongly doubt you have the same)
c) you probably swapped your AC7265 Wireless module?

also - i read some things about OpenCore and as of now it seems slightly above my knowledge level - can i continue on Clover for the time being and still use your files?

thanks
i had to update and my bios due to lack of later micro code to be able to get Mojave and Catalina to work, also my bios has Nvidia disabled and also something to do with XHCI handoff and IntelSGX as well

i can give you the bios if you like and instructions?

I have UK keyboard layout, yes, i swapped out the wifi module as well
 
Joined
May 2, 2020
Messages
33
Motherboard
Asus N752VX HM170 / Clover
CPU
Intel Core i7-6700HQ
Graphics
Intel HD 530 1920 x 1080 / nVidia GeForce GTX 950M
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
i had to update and my bios due to lack of later micro code to be able to get Mojave and Catalina to work, also my bios has Nvidia disabled and also something to do with XHCI handoff and IntelSGX as well

i can give you the bios if you like and instructions?

I have UK keyboard layout, yes, i swapped out the wifi module as well
So what i've done so far is roll back to mojave with unibeast/multibeast. i tried again to use your first files from yesterday (kexts, and patches and amended my config.plist to include your patches.plist). unlike yesterday, i was able to boot after, but no luck with the trackpad. Other than that, no patches applied yet. I am currently updating to catalina, but not sure what direction to go after that. Stick with Clover and try making it work there or get the necessary knowledge for OC. Also, what i dont understand yet, when using VoodooElan it doesnt work at all, when using voodooCHID i get at least the basic functions of the trackpad. Is that expected?
 
Top