Contribute
Register

Asus Laptop with El Capitan can't wake from sleep. Plz Help!

Joined
Nov 1, 2015
Messages
6
Motherboard
MSI Z77MA-G45
CPU
Intel Ivy Bridge i7 3700k
Graphics
NVIDIA GTX 1060 6GB
Mobile Phone
Android, iOS
hi,
I have installed El capitan and patched DSDT, everything (brightness, usb, IGPU, keyboard backlit, fn keys, battery, touchpad, gestures) is working properly.
When I put my laptop into sleep the screen turns off instantly and fan turns off after a minute and Power LED starts blinking as it should in sleep mode.
But when I wake it up using Power button or any other button, nothing is displayed on the screen(screen remains off) and power LED which was previously blinking turns off permanently. Now pressing Power button only lights up the power LED for 2-3 seconds and nothing happens then(no display).
It is like Sleep of Death.
I have to long press power button to reset the laptop.

My laptop specs are:
ASUS ROG GL552JX
i7-4720hq
16gb Memory
250gb M.2 sata SSD(Crucial) - El Capitan installed in this drive.
1tb HDD

I am attaching my native DSDT, patched DSDT and IOReg file

Please help...
View attachment native_DSDT.amlView attachment ioreg.ioregView attachment DSDT.aml
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,088
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
hi,
I have installed El capitan and patched DSDT, everything (brightness, usb, IGPU, keyboard backlit, fn keys, battery, touchpad, gestures) is working properly.
When I put my laptop into sleep the screen turns off instantly and fan turns off after a minute and Power LED starts blinking as it should in sleep mode.
But when I wake it up using Power button or any other button, nothing is displayed on the screen(screen remains off) and power LED which was previously blinking turns off permanently. Now pressing Power button only lights up the power LED for 2-3 seconds and nothing happens then(no display).
It is like Sleep of Death.
I have to long press power button to reset the laptop.

My laptop specs are:
ASUS ROG GL552JX
i7-4720hq
16gb Memory
250gb M.2 sata SSD(Crucial) - El Capitan installed in this drive.
1tb HDD

I am attaching my native DSDT, patched DSDT and IOReg file

Please help...
View attachment 160090View attachment 160091View attachment 160093
Power management not implemented...

http://www.tonymacx86.com/el-capitan-laptop-support/175801-guide-native-power-management-laptops.html

USB WiFi also problematic with sleep. Not recommended. Test without.
 
Joined
Nov 1, 2015
Messages
6
Motherboard
MSI Z77MA-G45
CPU
Intel Ivy Bridge i7 3700k
Graphics
NVIDIA GTX 1060 6GB
Mobile Phone
Android, iOS

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,088
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Hey,
I have implemented power management.
Here's the ioreg file: View attachment 160120

But the problem is same, laptop doesn't wake.
I have also removed usb wifi dongle, and tried to sleep the laptop but the problem is same.
Press F4 at Clover screen. Post EFI/Clover folder.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,088
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Joined
Nov 1, 2015
Messages
6
Motherboard
MSI Z77MA-G45
CPU
Intel Ivy Bridge i7 3700k
Graphics
NVIDIA GTX 1060 6GB
Mobile Phone
Android, iOS
Your ACPI files are not patched correctly. For example, you renamed GFX0->IGPU, but only to DSDT. You didn't patch the SSDTs to match. Same goes for the B0D3->HDAU rename.

Other:
- PNOT patch should not be used when OEM CPU SSDTs are included

Please follow the guide carefully: http://www.tonymacx86.com/el-capitan-laptop-support/152573-guide-patching-laptop-dsdt-ssdts.html
Hi,

I have applied those patches for SSDTs exactly the same way as mentioned in the guide.
I have also changed the config.plist to drop OEM SSDTs.
But after patching ssdts my Nvidia does not turn off and there are glitches in Display, also Wake problem was still there.

ioreg: View attachment Aman’s MacBook Pro SSDT patched.ioreg

patched SSDTs and DSDT: View attachment patched.zip

Clover Config.plist: View attachment config.plist
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,088
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Hi,

I have applied those patches for SSDTs exactly the same way as mentioned in the guide.
I have also changed the config.plist to drop OEM SSDTs.
But after patching ssdts my Nvidia does not turn off and there are glitches in Display, also Wake problem was still there.

ioreg: View attachment 160183

patched SSDTs and DSDT: View attachment 160184

Clover Config.plist: View attachment 160185
Refer to the EFI/Clover you provided in post #5. ACPI/patched has only SSDT.aml (from ssdtPRgen.sh) and DSDT.aml. No patched SSDTs.

If you're saying you made some changes... post EFI/Clover.
 
Joined
Nov 1, 2015
Messages
6
Motherboard
MSI Z77MA-G45
CPU
Intel Ivy Bridge i7 3700k
Graphics
NVIDIA GTX 1060 6GB
Mobile Phone
Android, iOS
Refer to the EFI/Clover you provided in post #5. ACPI/patched has only SSDT.aml (from ssdtPRgen.sh) and DSDT.aml. No patched SSDTs.

If you're saying you made some changes... post EFI/Clover.

EFI/Clover View attachment CLOVER.zip

As mention in post #7, I have patched SSDTs exactly according to the guide.
Booting with patched SSDTs brightness control does not work and Nvidia is showing in System Information/Graphics.
I am getting graphic glitches and wake doesn't work too.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,088
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
EFI/Clover View attachment 160190

As mention in post #7, I have patched SSDTs exactly according to the guide.
Booting with patched SSDTs brightness control does not work and Nvidia is showing in System Information/Graphics.
I am getting graphic glitches and wake doesn't work too.
Nvidia patch is wrong... not according to guide.

As stated in the guide, you must eliminate EC related code from _OFF and move it to _REG.

Here is your _OFF method:
Code:
        Method (_OFF, 0, Serialized)  // _OFF: Power Off
        {
            If (LEqual (CTXT, Zero))
            {
[B]                \_SB.PCI0.LPCB.EC0.SPIN (0x96, Zero)
[/B]                If (LNotEqual (GPRF, One))
                {
                    Store (VGAR, VGAB)
                }

                Store (One, CTXT)
            }

            SGOF ()
        }
I highlight the offending code in bold.

Note also same situation with code in SGOF (called from _OFF):
Code:
        Method (SGOF, 0, Serialized)
        {
            If (LEqual (CCHK (Zero), Zero))
            {
                Return (Zero)
            }

            Store (Zero, ONOF)
[B]            Store (\_SB.PCI0.LPCB.EC0.RRAM (0x0521), Local0)
[/B]            And (Local0, 0xCF, Local0)
[B]            \_SB.PCI0.LPCB.EC0.WRAM (0x0521, Local0)
            \_SB.PCI0.LPCB.EC0.WRAM (0x0520, 0x95)
            \_SB.PCI0.LPCB.EC0.WRAM (0x03A4, Zero)
            \_SB.PCI0.LPCB.EC0.WRAM (0x03A5, Zero)
            Store (\_SB.PCI0.LPCB.EC0.RRAM (0x0575), Local0)
            \_SB.PCI0.LPCB.EC0.WRAM (0x0576, Local0)
[/B]            Store (LCTL, ELCT)
            Store (SVID, HVID)
            Store (SDID, HDID)
            Store (EMLW, DMLW)
            If (LGreaterEqual (PCSL, 0x04))
            {
                If (LEqual (SC7A, One))
                {
                    SPP0 ()
                }
                Else
                {
                    Store (\_SB.PCI0.PEG0.LREN, \_SB.PCI0.PEG0.PEGP.LTRE)
                }
            }

            Store (One, LNKD)
            Store (Zero, TCNT)
            While (LLess (TCNT, LDLY))
            {
                If (LEqual (LNKS, Zero))
                {
                    Break
                }

                Sleep (0x10)
                Add (TCNT, 0x10, TCNT)
            }

            While (LNotEqual (LNKS, Zero))
            {
                Sleep (One)
            }

            Store (0x02, AFES)
            If (LGreaterEqual (And (PNHM, 0x0F), 0x03))
            {
                If (LNotEqual (P0UB, Zero))
                {
                    Store (GMXB (), MBDL)
                    PDUB (MBDL)
                }
            }

            If (LGreaterEqual (PCSL, 0x04))
            {
                If (LEqual (SC7A, One))
                {
                    C7OK (One)
                }
            }

            SGPO (HLRS, One)
            SGPO (PWEN, Zero)
            Sleep (0x64)
            Sleep (0x64)
            Return (Zero)
        }
I think I mentioned this before... PNOT patch should not be used with full set of OEM CPU SSDTs.

You will probably need the IAOE patch.
 
Top