Contribute
Register

ASUS K55A ALC270 No sound?

Joined
Aug 26, 2014
Messages
2
Motherboard
Dell Inspiron 3537 Hackintosh
CPU
Core-i5 4200U
Graphics
Intel HD Graphics 4400 1024 MB
Mac
  1. iMac
Classic Mac
  1. Power Mac
Mobile Phone
  1. Android
Hi everyone.

I have an ASUS K55A that I'm re-purposing into a hackintosh with Mavericks using Multibeast.
So far I have everything important working besides sound.

The sound is ALC270 with the following hardware ID:
HDAUDIO\FUNC_01&VEN_10EC&DEV_0270&SUBSYS_10431457&REV_1001
I've tried a handful of patched AppleHDA kexts, but none seem to detect the sound hardware.
VoodooHDA kexts give a kernel panic with a high screech (mic feedback-ish sound) from the speakers.
(I figured VoodooHDA wouldn't work - I just took the "why not" path after fussing about with AppleHDA.)

Does anyone have this sound hardware working in mavericks?
If so is there a patched AppleHDA that would work?
If not, how would I go about getting it working?

Thanks.
 
Last edited:

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,169
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hi everyone.

I have an ASUS K55A that I'm re-purposing into a hackintosh with Mavericks using Multibeast.
So far I have everything important working besides sound.

The sound is ALC270 with the following hardware ID:

I've tried a handful of patched AppleHDA kexts, but none seem to detect the sound hardware.
VoodooHDA kexts give a kernel panic with a high screech (mic feedback-ish sound) from the speakers.
(I figured VoodooHDA wouldn't work - I just took the "why not" path after fussing about with AppleHDA.)

Does anyone have this sound hardware working in mavericks?
If so is there a patched AppleHDA that would work?
If not, how would I go about getting it working?

Thanks.

See FAQ:
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
 
Top