Contribute
Register

Asus G752VT need help

Joined
Aug 24, 2016
Messages
17
Motherboard
Asus G752VT
CPU
i7-6700HQ
Graphics
GeForce GTX 970M
Mac
iMac, MacBook, Mac mini
Classic Mac
iMac
Mobile Phone
iOS
Need help to complete installation. This is my third hackintosh and I am still newbie. So what we have:
1) Success installation of El Capitan. ( I tried Sierra, failed, let's complete El Capitan first)
2) Wifi card changed by BCM4352 (14E443B1), bluetooth works well.
3) Lan is OK
4) Nvidia Geforce - OK
5) Audio (Voodoo) - OK
6) Sleep - OK (Shutdown - BAD, booting again)
7) Wifi - not completed
8) Touch pad - no idea what to do
9) USB - problems ( mouse - OK, external SATA USB - BAD)
10) Geekbench - very strange result (https://browser.geekbench.com/v4/cpu/1110952)
11) Brightness - did not try yet



Original information:




What we have now:




Attached:
IOreg, Clover, boot log, CPU-Z html (windows), System Info (windows)
 

Attachments

Last edited:
Joined
Aug 24, 2016
Messages
17
Motherboard
Asus G752VT
CPU
i7-6700HQ
Graphics
GeForce GTX 970M
Mac
iMac, MacBook, Mac mini
Classic Mac
iMac
Mobile Phone
iOS

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,716
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
All data according to the link was provided. I need your help that's why this post is here.
Your kextcache output already shows many mistakes... (no need to patch many of those kexts...).

You might as well start over with the Clover guide linked from the FAQ.

But what is your question?
 
Last edited:
Joined
Aug 24, 2016
Messages
17
Motherboard
Asus G752VT
CPU
i7-6700HQ
Graphics
GeForce GTX 970M
Mac
iMac, MacBook, Mac mini
Classic Mac
iMac
Mobile Phone
iOS
Your kextcache output already shows many mistakes... (no need to patch many of those kexts...).

You might as well start over with the Clover guide linked from the FAQ.

But what is your question?
Thank you. Well, if you don't mind: USB. It looks like USB ports are "unstable" after short time of use. Connected usb mouse is disconnected if I don't use it. Cannot copy files to USB SATA drive (2-3 minutes and process frozen). Could you check ioreg file to say what's wrong and what should i fix? I read a lot of articles on this site, too many ways and options. I did something wrong, the best way to learn to find it and fix.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,716
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Thank you. Well, if you don't mind: USB. It looks like USB ports are "unstable" after short time of use. Connected usb mouse is disconnected if I don't use it. Cannot copy files to USB SATA drive (2-3 minutes and process frozen). Could you check ioreg file to say what's wrong and what should i fix? I read a lot of articles on this site, too many ways and options. I did something wrong, the best way to learn to find it and fix.
Your ioreg shows evidence of using the port limit patch. It is not for long term use. It is to be used only for port discovery. Plan on creating a custom SSDT for USBInjectAll.kext as documented in ammulder's Skylake Starter Guide, such that you're under the 15-port limit.
 
Joined
Aug 24, 2016
Messages
17
Motherboard
Asus G752VT
CPU
i7-6700HQ
Graphics
GeForce GTX 970M
Mac
iMac, MacBook, Mac mini
Classic Mac
iMac
Mobile Phone
iOS
Your ioreg shows evidence of using the port limit patch. It is not for long term use. It is to be used only for port discovery. Plan on creating a custom SSDT for USBInjectAll.kext as documented in ammulder's Skylake Starter Guide, such that you're under the 15-port limit.
Got it, will do.
 
Joined
Aug 24, 2016
Messages
17
Motherboard
Asus G752VT
CPU
i7-6700HQ
Graphics
GeForce GTX 970M
Mac
iMac, MacBook, Mac mini
Classic Mac
iMac
Mobile Phone
iOS
Ok, a custom SSDT was created. I attached clover and ioreg. USB wireless mouse works well. But external USB SATA drive still does not work. Sometimes I cannot mount a disk or open a mounted disk. Sometimes I can see only root folders. Desktop asus and laptop HP 470 g3 works well with this usb dock.

I tried also _OSI to XOSI, did not help. Should we try debug version of USBInjectAll?

I removed unused kext and kext patches, fixed some mistakes. Geekbench shows result: 2000+/10000+.
 

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,716
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Ok, a custom SSDT was created. I attached clover and ioreg. USB wireless mouse works well. But external USB SATA drive still does not work. Sometimes I cannot mount a disk or open a mounted disk. Sometimes I can see only root folders. Desktop asus and laptop HP 470 g3 works well with this usb dock.

I tried also _OSI to XOSI, did not help. Should we try debug version of USBInjectAll?

I removed unused kext and kext patches, fixed some mistakes. Geekbench shows result: 2000+/10000+.
_OSI->XOSI patch not valid without SSDT that implements XOSI method.
Your UsbConnector values are wrong.
 
Joined
Aug 24, 2016
Messages
17
Motherboard
Asus G752VT
CPU
i7-6700HQ
Graphics
GeForce GTX 970M
Mac
iMac, MacBook, Mac mini
Classic Mac
iMac
Mobile Phone
iOS
_OSI->XOSI patch not valid without SSDT that implements XOSI method.
Your UsbConnector values are wrong.

XOSI patch is disabled in config, SSDT file was removed. I uploaded USB.dsl file, what usbconnector values are wrong? Please advice.
 

Attachments

Top