Contribute
Register

ASUS F556 lap drivers and clover confige

Joined
Jul 4, 2020
Messages
16
Motherboard
ASUSTek X556UV (U3E1)
CPU
i5-6200U
Graphics
Intel HD Graphic 520
Mobile Phone
iOS
I install MAC Catalina to ASUS F556 Lap.. it boots with fakegraphic inject 0x12345678 when trying to boot with intel IGP loading I try intelgraphicfix kext, rename gtx0 to igpu also. Please help me to build my Clover. No Audio and Wifi too. In Mojave EFI 2 folder works with Graphic. but no Audio or Wifi.
 

Attachments

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
23,425
Motherboard
Lenovo ThinkStation p300 ⌘
CPU
i7-4790K
Graphics
HD 4600
Mac
MacBook Pro, Mac mini
Classic Mac
Power Mac
Mobile Phone
iOS
I install MAC Catalina to ASUS F556 Lap..


Not a Desktop - Moved to Laptop Support.
 
Joined
Sep 29, 2012
Messages
16
Motherboard
Asus P8H67-M
CPU
i7 2600
Graphics
ATI HD 5770
Mac
Classic Mac
Mobile Phone
Try “-disablegfxfirmware” boot arg.
 
Joined
Jul 4, 2020
Messages
16
Motherboard
ASUSTek X556UV (U3E1)
CPU
i5-6200U
Graphics
Intel HD Graphic 520
Mobile Phone
iOS
Thanks for the reply..:)
I manage to fix Graphic card by updating some kext FakeSMC Lilu Whatevergreen IntelGraphicsFixup AppleALC.
But still no Audio or Wifi.. help me to fix???
Attached EFI fyi
 

Attachments

Feartech

Moderator
Joined
Aug 3, 2013
Messages
17,947
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
iMac
Mobile Phone
iOS
Thanks for the reply..:)
I manage to fix Graphic card by updating some kext FakeSMC Lilu Whatevergreen IntelGraphicsFixup AppleALC.
But still no Audio or Wifi.. help me to fix???
Attached EFI fyi
what wifi card do you have?


audio:

enable these:
Code:
<key>Fixes</key>
            <dict>
                <key>Comment-IRQ Fix</key>
                <string>The following fixes may be needed for onboard audio/USB/etc</string>
                <key>FixTMR</key>
                <false/>
                <key>FixRTC</key>
                <false/>
                <key>FixIPIC</key>
                <false/>
                <key>FixHPET</key>
                <false/>
            </dict>
make this:
Code:
<key>Audio</key>
        <dict>
            <key>Inject</key>
            <integer>13</integer>
        </dict>
look like:
Code:
<key>Audio</key>
        <dict>
            <key>Inject</key>
            <string>No</string>
        </dict>
make this section:
Code:
<key>PciRoot(0)/Pci(0x1f,3)</key>
            <dict>
                <key>#layout-id</key>
                <integer>3</integer>
                <key>#PinConfigurations</key>
                <data></data>
                <key>#hda-gfx</key>
                <string>onboard-1</string>
                <key>#no-controller-patch</key>
                <integer>1</integer>
            </dict>
look like:
Code:
<key>PciRoot(0)/Pci(0x1f,3)</key>
            <dict>
                <key>layout-id</key>
                <integer>3</integer>
                <key>#PinConfigurations</key>
                <data></data>
                <key>hda-gfx</key>
                <string>onboard-1</string>
                <key>#no-controller-patch</key>
                <integer>1</integer>
            </dict>
and then you may need to change the layout id (currently set to 3)
to whatever codec you have:

test each of the numbers, reboot and see if you get audio, if not, try another number

remove these:
FakePCIID_Broadcom_WiFi.kext
IntelGraphicsFixup.kext
BroadcomWiFiInjector.kext
Shiki.kext
VoodooPS2Keyboard.kext

install VoodooPS2Controller.kext

update your AppleALC.kext as well

remove 10.6 - 10.14 folders, only have "other" folder in kexts folder
 
Joined
Jul 4, 2020
Messages
16
Motherboard
ASUSTek X556UV (U3E1)
CPU
i5-6200U
Graphics
Intel HD Graphic 520
Mobile Phone
iOS
what wifi card do you have?


audio:

enable these:
Code:
<key>Fixes</key>
            <dict>
                <key>Comment-IRQ Fix</key>
                <string>The following fixes may be needed for onboard audio/USB/etc</string>
                <key>FixTMR</key>
                <false/>
                <key>FixRTC</key>
                <false/>
                <key>FixIPIC</key>
                <false/>
                <key>FixHPET</key>
                <false/>
            </dict>
make this:
Code:
<key>Audio</key>
        <dict>
            <key>Inject</key>
            <integer>13</integer>
        </dict>
look like:
Code:
<key>Audio</key>
        <dict>
            <key>Inject</key>
            <string>No</string>
        </dict>
make this section:
Code:
<key>PciRoot(0)/Pci(0x1f,3)</key>
            <dict>
                <key>#layout-id</key>
                <integer>3</integer>
                <key>#PinConfigurations</key>
                <data></data>
                <key>#hda-gfx</key>
                <string>onboard-1</string>
                <key>#no-controller-patch</key>
                <integer>1</integer>
            </dict>
look like:
Code:
<key>PciRoot(0)/Pci(0x1f,3)</key>
            <dict>
                <key>layout-id</key>
                <integer>3</integer>
                <key>#PinConfigurations</key>
                <data></data>
                <key>hda-gfx</key>
                <string>onboard-1</string>
                <key>#no-controller-patch</key>
                <integer>1</integer>
            </dict>
and then you may need to change the layout id (currently set to 3)
to whatever codec you have:

test each of the numbers, reboot and see if you get audio, if not, try another number

remove these:
FakePCIID_Broadcom_WiFi.kext
IntelGraphicsFixup.kext
BroadcomWiFiInjector.kext
Shiki.kext
VoodooPS2Keyboard.kext

install VoodooPS2Controller.kext

update your AppleALC.kext as well

remove 10.6 - 10.14 folders, only have "other" folder in kexts folder
thanks for the help
now speaker is working for port 13

these are kext from L/E

please help with WIFI

thanks again
 

Attachments

Last edited:
Joined
Jul 4, 2020
Messages
16
Motherboard
ASUSTek X556UV (U3E1)
CPU
i5-6200U
Graphics
Intel HD Graphic 520
Mobile Phone
iOS
my wifi may Qualcomm, how to check
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
17,947
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
iMac
Mobile Phone
iOS
thanks for the help
now speaker icon is visible for port 13 but no sound
these are kext from L/E
for catalina, keep your 3rd party kexts in clover/kexts/other
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
17,947
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
iMac
Mobile Phone
iOS
what to keep..
in terminal, do this:
Code:
sudo kextcache -i /
you will see a list of kexts, move them to clover/kexts/other

then re do the command:
Code:
sudo kextcache -i /
you should then see no kexts listed
 
Top