Contribute
Register

Asus 1155 Patched BIOS Repository

Status
Not open for further replies.
Joined
Dec 16, 2011
Messages
109
Motherboard
Mac Pro 3,1 Mountain Lion
CPU
i7 4,8 OC'd
Graphics
GeForce GTX 570 HD
Mac
  1. Mac Pro
Classic Mac
Mobile Phone
  1. iOS
Hey Brycv, I've downloaded the new DSDT you created, thank you. Should I start from scratch and use te DSDT in combination with other kexts from multibeast? Or can I just go into my s/l/e and delete the kexts I already installed and then apply your new DSDT?
 
Joined
Mar 8, 2011
Messages
250
Motherboard
Asus P8Z77-I Deluxe
CPU
Core i7 3770S
Graphics
Intel HD 4000
Mac
  1. MacBook Air
Classic Mac
Mobile Phone
  1. iOS
draken182 said:
Hey Brycv, I've downloaded the new DSDT you created, thank you. Should I start from scratch and use te DSDT in combination with other kexts from multibeast? Or can I just go into my s/l/e and delete the kexts I already installed and then apply your new DSDT?
It's not a full DSDT. It's a patch. You need to extract your vanilla DSDT (or use the copy you sent me) and then apply the patch in DSDT Editor. Once applied Compile it and click fix errors in that dialog. You should have no errors at all.

The DSDT would be used along with the UserDSDT install in MultiBeast but also requires the ALC8xxHDA and AppleHDA Rollback options in MultiBeast for audio to work. You would also need hnak's E1000 ethernet driver for the P8Z68-V or P8Z68-V Pro. It is included with MultiBeast but is an older version. The latest is available here:

http://www.insanelymac.com/forum/index. ... pic=205771

Install with KextBeast is the easiest.
 
Joined
Dec 16, 2011
Messages
109
Motherboard
Mac Pro 3,1 Mountain Lion
CPU
i7 4,8 OC'd
Graphics
GeForce GTX 570 HD
Mac
  1. Mac Pro
Classic Mac
Mobile Phone
  1. iOS
brycv said:
draken182 said:
Hey Brycv, I've downloaded the new DSDT you created, thank you. Should I start from scratch and use te DSDT in combination with other kexts from multibeast? Or can I just go into my s/l/e and delete the kexts I already installed and then apply your new DSDT?
It's not a full DSDT. It's a patch. You need to extract your vanilla DSDT (or use the copy you sent me) and then apply the patch in DSDT Editor. Once applied Compile it and click fix errors in that dialog. You should have no errors at all.

The DSDT would be used along with the UserDSDT install in MultiBeast but also requires the ALC8xxHDA and AppleHDA Rollback options in MultiBeast for audio to work. You would also need hnak's E1000 ethernet driver for the P8Z68-V or P8Z68-V Pro. It is included with MultiBeast but is an older version. The latest is available here:

http://www.insanelymac.com/forum/index. ... pic=205771

Install with KextBeast is the easiest.

Awesome! You're the best! thanks for being so quick on this!
 
Joined
Mar 8, 2011
Messages
250
Motherboard
Asus P8Z77-I Deluxe
CPU
Core i7 3770S
Graphics
Intel HD 4000
Mac
  1. MacBook Air
Classic Mac
Mobile Phone
  1. iOS
draken182 said:
Awesome! You're the best! thanks for being so quick on this!
No problem. Your results will help with the guide I'm putting together which should benefit lots of users.
 
Joined
Dec 16, 2011
Messages
109
Motherboard
Mac Pro 3,1 Mountain Lion
CPU
i7 4,8 OC'd
Graphics
GeForce GTX 570 HD
Mac
  1. Mac Pro
Classic Mac
Mobile Phone
  1. iOS
Hmm, ran a fresh install, compiled DSDT, patched with your new one no errors or warnings!!! Placed it on the desktop. Opened up multibeast chose userdsdt and chose the two audio kexts and fakesmc in multibeast. After reboot it hangs on the apple logo loading screen. I ran -v in chameleon screen, but I'm not sure what to look for. The only error I get is "error: EFI ROM did not publish 'hda-gfx' associative property!\n"" failed in "/SourceCache/AppleHDA-179.1.4/AppleHDA/AppleHDACodecGeneric.cpp" at line 331 giro ExitError


Any idea how to get in?
 
Joined
Dec 16, 2011
Messages
109
Motherboard
Mac Pro 3,1 Mountain Lion
CPU
i7 4,8 OC'd
Graphics
GeForce GTX 570 HD
Mac
  1. Mac Pro
Classic Mac
Mobile Phone
  1. iOS
Never mind. I forgot to go back into BIOS and change the correct settings for everything. DER!

Audio works
Ethernet worked (thanks for the link to the updated AppleIntelE1000e)
Wi-Fi card works
Graphics card works
Everything reads correct in About this Mac

The only thing that doesn't seem to work is the bluetooth, but i use this method:
http://tonymacx86.com/viewtopic.php?f=7&t=18410 and so far so good.
 
Joined
Mar 8, 2011
Messages
250
Motherboard
Asus P8Z77-I Deluxe
CPU
Core i7 3770S
Graphics
Intel HD 4000
Mac
  1. MacBook Air
Classic Mac
Mobile Phone
  1. iOS
draken182 said:
Never mind. I forgot to go back into BIOS and change the correct settings for everything. DER!

Audio works
Ethernet worked (thanks for the link to the updated AppleIntelE1000e)
Wi-Fi card works
Graphics card works
Everything reads correct in About this Mac

The only thing that doesn't seem to work is the bluetooth, but i use this method:
http://tonymacx86.com/viewtopic.php?f=7&t=18410 and so far so good.
Excellent! I'm glad to hear it's all working well. Bluetooth seems to be a touchy thing. I have two different USB Bluetooth Dongles and only one works well (the Jabra A320S).
 
Joined
Dec 16, 2011
Messages
109
Motherboard
Mac Pro 3,1 Mountain Lion
CPU
i7 4,8 OC'd
Graphics
GeForce GTX 570 HD
Mac
  1. Mac Pro
Classic Mac
Mobile Phone
  1. iOS
brycv said:
draken182 said:
Never mind. I forgot to go back into BIOS and change the correct settings for everything. DER!

Audio works
Ethernet worked (thanks for the link to the updated AppleIntelE1000e)
Wi-Fi card works
Graphics card works
Everything reads correct in About this Mac

The only thing that doesn't seem to work is the bluetooth, but i use this method:
viewtopic.php?f=7&t=18410 and so far so good.
Excellent! I'm glad to hear it's all working well. Bluetooth seems to be a touchy thing. I have two different USB Bluetooth Dongles and only one works well (the Jabra A320S).
yes i have read that a lot. the boards built in wifi does work using the method posted in the above link. thanks again! ill keep testing it.
 
Joined
Mar 8, 2011
Messages
250
Motherboard
Asus P8Z77-I Deluxe
CPU
Core i7 3770S
Graphics
Intel HD 4000
Mac
  1. MacBook Air
Classic Mac
Mobile Phone
  1. iOS
draken182 said:
yes i have read that a lot. the boards built in wifi does work using the method posted in the above link. thanks again! ill keep testing it.
Very good.
 
Joined
Dec 16, 2011
Messages
109
Motherboard
Mac Pro 3,1 Mountain Lion
CPU
i7 4,8 OC'd
Graphics
GeForce GTX 570 HD
Mac
  1. Mac Pro
Classic Mac
Mobile Phone
  1. iOS
One other thing is i can't seem to get HWMonitor to work? Any ideas? i've copied ACPISensors, IntelCPUMonitor and RadeonX kext's into the s/l/e folder, and when i run HWMonitor, it only displays HD's
 
Status
Not open for further replies.
Top